Zwave repair feature in ST

I have tried the Zwave network repair feature but it never completes the task and says ‘finished.’ I have run this for more than an hour and it never finishes… IOne I first used it, and had only a couple of devices, it did seem to do a repair. I now have about 35 Zwave devices installed in my system…in an average size house.

It was my understanding that I could occasionally run this to improve my device performance by optimizing the mesh network. When I called ST, the initial person I spoke was not certain about this feature and someone would call back…and no one did.

Should I wait longer???

I have waited over night before no luck. All of my other locations (7) come back with a finished message. The 7 that do work have a very low number of zwave devices on them but the one with around 100 devices 80 of which are zwave never finishes. I do believe that it helps the one that does not finish .


Some hints:

Run ZWave repair from the IDE ( > My Hubs > View Utilities (about 1/4 the way down the page on the rt) > Repair ZWave

That will give you a link to a live logging tool so you can see whats going on.


Nothing seems to happen when I start this. There are not logs, notes, etc…nothing. Should something happen?

When you click the link it should pop a message saying ‘ZWave repair initiated click here to view progress’. Clicking that link should give you a menu that should populate over time with anybwrror messages found…

Okay. So it just runs…and nothing is found then nothing displayed? I was thinking it also reorganized the mesh and made the system more efficient - and would give some sort of notice that it had completed its task.

Well in a normal world it would show something. I went back and looked at mine last night and lo - it didn’t… SO here’s a workaround:

Once you fire off the repair, back out of it up to the hub level. (You should see List Events and View Utilities.)
Go into List events, it will sow hub level network logging. THERE you should see the events popping, including the repair start, any errors and end. I can’t remember the category but they should be pretty obvious.

And thanks - i found a ghost device in mine I had to fix last night when I ran my own…

I went back and looked at the log and it appears to be ‘repairing.’ Thanks for the heads up and help.

I am not a ‘tehno’ guy and these pages look more for ‘developers’ and programmers. Or, folks working with the previous ST application? I just switched from a Homeseer system after using it for 5 years. It became too complicated and required more ‘programming’ and testing than I wanted to do - and their support was difficult to work with. And when the SSID drive stopped working and I lost all of my programming/settings - I became frustrated and switched to Smartthings as it seemed very easy. I have the latest hub and have about 40 devices throughout my house tied in the network. So far, it works pretty well and that automations are easy to set up.

The IDE is the ‘under the covers’ stuff. …And you caught it mid transition, :slight_smile: as evidenced by - oh wait that didn’t work? Let’s try this…

I having an issue with routes where I have device network id’s listed in a route that I cannot find in my device list (sorted by ID and they do not exist). I initiated the zWave repair, had same issue w/ the progress tracking, followed your instructions on finding a location to track progress and nothing - other than zwave repair starting - is showing up.

I have 81 devices in my network. How long should the repair take to complete or show traceable progress? Does anyone know what causes the devices to disappear leaving orphaned device network ids? I have a few devices (GE / Jasco) that I cannot seem to get to respond or be discoverable through ST. Will zwave repair address the latter issue?

1 Like

Hey. I have ST but I am no expert…and certainly not a programmer. I think you wanted Nathan…
Good luck.