Z-Wave Repair Option missing on Samusng WiFi Mesh Hub

I am using SmartThings via the Samsung WiFi Mesh Hub (similar to regular V3 hub).

A major of my Z-Wave devices unexpectedly dropped offline for the first time ever and I want to invoke the Z-Wave repair utility.

There used to be a “Utilities” option on the SmartThings Hub configuration screen but I don’t see it anymore. Am I looking in the right place? Screenshot is attached.

I tried invoking Z-Wave repair from the IDE but it doesn’t appear to do anything, perhaps since the IDE is deprecated / obsolete.

It should be under Settings… they moved it in the Fall

1 Like

It’s buried under Settings->Z-Wave utilities.

My Settings page has fewer options and is oddly greyed out

Is there any other way to invoke Z-Wave repair?

@h0ckeysk8er, @jkp,
Is there anywhere I can log a bug report for the missing Z-Wave utilities option?

I suspect the SmartThings WiFi mesh hub is less popular than the regular V3 hub and Samsung may’ve inadvertently hid the Z-Wave utilities option.

Perhaps the regression wasn’t caught during testing and I’d like to make it known.

uninstall / reinstall the app, reboot the hub.

contact ST support after that

1 Like

I have the Wi-Fi hub and the Z-Wave utilities are there for me.

1 Like

Reinstalling the app worked!

I am using the SmartThings App on 2 iOS devices and 1 Android device and they were all missing the Z-Wave Utilities option. Reinstalling the app resolved the issue. I’m not sure why but the remedy worked.