Z-Wave Repair Does Not Finish

My Z-wave repair never completes. It just spins and spins. I have even let it run overnight. Tried running it from the IDE but I get nothing in the IDE.

I’m wondering if this is tied to my icons not appearing any longer next to my “Things”. When I try to assign an icon the library is empty.

This may be two separate issues.

Are you running it from the classic app, new app, or the IDE?

I only ask because I can only seem to run it successfully from the classic app.

I had some initial troubles last night also, using the classic app… But then I guess it worked itself out. In the new app, I can’t even figure out how to do it?

I have tried in the Classic app and the IDE. Neither seems to work.

I also can’t figure out where it would be in the new app. Thinking about deleting that app entirely.

ZWave repair in the new V3 app:

Select your home hub device in the new app. Select the 3 dots in the top right corner. Select Zwave utilities.

1 Like

Yes it’s two separate issues. The icon issue was introduced by SmartThings when they ‘updated’ classic to v.2.18

Yes it’s two separate issues. The icon issue was introduced by SmartThings when they ‘updated’ classic to v.2.18

Was it not ever fixed? Or are they dumping on Classic?

If you go into the ide and select hubs -> list events, you can see the results of z wave repair in the hub event logs. The apps often don’t display anything useful for me on a repair.

No it’s not fixed. If you want it fixed submit a support ticket through SmartThings at Support@smartthings.com. That said, they’ve already announced plans to depricate classic sometime in the next year or so, so odds are you likely won’t see a lot of effort on thier part to put in a fix for it.

Ran for me fine from ide. Do you get any errors after it starts, like device X couldn’t delete routing and such?

I hope my perilous journey into z-wave tables can help you :wink:

I have 35+ Z-wave devices and LOTS of Z-Virtual stuff. The more you have, the longer it takes btw.

Z-wave repair in new app attempted 6-9 times and after over an hour per time with wheel spinning I can say with absolute certainty that nothing was repaired and lots of time was wasted but hey, my wife was happy that I was untethered so the kids got more quality Dad time.

I’ve gotten classic to succeed a few times and tested out the success by moving repeaters, unplugging devices and such just to verify that it wasn’t a superficial repair. The classic repair usually takes me about 8-15 minutes. Lately it is hit and miss when it wants to work and like others have said, maybe its due to the phasing out.

IDE repair has been the workhorse and seems to be the best chance at repairs but I have found a few things to make it go smoother. It seems unnecessary to do this and many would think I’m silly but I turn ON all my Z-wave devices, lights and all and then run it from IDE and 100% success. Maybe I’ve been lucky and this is a ritual that is as unnecessary as not washing my underwear but its easy to do and doesn’t smell bad :slight_smile:

If going through IDE, you just have to remember the order of operations
“My Locations”–>Select Location–>Click on your “ACTIVE” Hub–>“View Utilities”–>“Repair Z-Wave network” and you should be good.

All,

OK, I finally found it in the new app (who designed the app?), quite the pain. It appears to work there. Also have run it in the IDE, but not sure if it does anything.

Guess I’ll call this a win and move on. Now I have two phone apps that sort of do the same thing. Progress.

In my version of this new app, the only options on the 3 dot menu are “Edit” and “Manage Locations” I can not find anything relating to zwave repair.

You need to first select the SmartThings Hub device.

I thought I did. Whem my app opens I see all the name of my hub and below it are all my rooms. On the right of the screen are the “+” to add a new room and the 3 dot menu I described above. On the lefttside is the “Hamburg” menu. When I touch it I get a new screen showing all the features of the current hub. There is a dropdown menu on this screen that let me select this V2 hub or my old V1 hub. If I select the V2 hub from this menu it simply returns me back to the very first screen I get when I open the app.
If, instead I select the gear icon I get another preferences screen related to my account.

Like I said, cant see the repair utility anywhere

Find your actual Hub device in whatever room you have it in. Example - see the first device listed in my Study:

Select it then tap the three dot menu:

1 Like

Ok, I am still thinking in “classic” mode where a hub was not assigned a room. Could not find it amywhere until I scrolled to the bottom of the screen and found “Devices not assigned to a rom” (or something lie that. That did the trick

Thanks for your help

2 Likes