Z-wave network down after power outage?

Due to the extreme cold our area has been subjected to rolling blackouts today. We’ve had two that lasted about 20 mins each. The 1st one woke us up, so I’m not 100% sure my issue is related to the power outage since the last time I tried to use any of my z-wave devices was running a routine when I went to bed. It was fine then. My hub is in my network on a large UPS so it never lost power. I have tried rebooting my hub. Power has been back on for about 40 mins and all of my z-wave GE switches and other z-wave devices are either not responding, showing offline, or (and this is rare) are responding about 1 min after I issue the command. I’ve never encountered this issue post power outage before (typically if I have issues it’s that the power outage kills GE switches…lol). Any ideas? Some of my switches have migrated, but not all. It’s affecting them whether or not they have migrated.

Login t to IDE:

  • check if z-wave is functional in hubs section
  • reboot the hub in the view utilities section in the same hubs section.

Start with those.

Thank you. I had already rebooted & checked that. I think I found the issue. Lost 6 of my 40+ GE switches. When I ran the z-wave repair it showed a bunch with errors. Most are physically near my hub, guessing the mesh is really messed up. Aaaaand we just lost power again.


Older GE/Jasco switches have been known to be damaged by power surges. I have lost some just from turning a circuit breaker off then on.

Do the switches work manually? If the have air breaks have you operated the air breaks.

If they are bad and less than 5 years old contact Jasco. They have good about replacing bad switches less than 5 yrs old.

Yes, I am all too familiar with this issue (even from flipping breakers). I’ve just never lost this many at once. Flipping air gap switches doesn’t help and they won’t operate manually. I just realized there are 4 on our back porch I need to check too, but the power is out again. I have 4 ‘in stock’ right now, so I’m down at least two and no one has them locally anymore. Lowes carries the Eaton ones, but I wasn’t really a fan of them the one time I tried one.

1 Like

Yep. This is exactly what happened to me after Texas Snowmageddon a couple of years ago. With the power bouncing you probably lost a few switches that were doing core repeating for your network. (in my case I lost six…)

For me the incident was the catalyst to replace all my remaining 12xxx series Jascos, and install two shiny new SPAN electrical panels with whole home surge suppression.

Hope your lost soldiers are still under warranty. My outage incident was at that awkward price where it hurt but it wasn’t expensive enough to claim on insurance…

1 Like

Sadly I’ve pretty much exhausted all my receipts that are less than 5 years old (and the switch date codes are well over 5 years old). That being said Jasco has replaced without question many switches for me while I did have receipts. It ended up being 5 dead switches (I can’t count I guess) - and I had 4 switches in stock - went ahead and replaced 4, removed the 5 dead ones from Smartthings, adopted the new ones, ran another z-wave repair, and all seems to be back to normal (except for that one dead switch I still need to swap). I miss when I could run to Lowes and get replacements. As luck would have it Jasco’s own website has them on sale for $10 off so I went ahead and bought another 4 switches. The only bad thing is the ‘free shipping’ doesn’t tell me how long it will take to get them here (actually none of the shipping options gave an ETA). Although the warranty replacements have always arrived in a timely fashion. Thanks all & Merry Christmas!


A few years ago I lost two switches to a power outage. I purchased replacement switches online so they took a few days to arrive. One of the switches I needed to replace right away with a dumb switch, but I left the other in until the replacement arrived. When the replacement arrived I first replaced the dumb switch, then, before I replaced the other smart switch I flipped it on (I couldn’t remember if it was on the same circuit as the dumb switch) and it worked. So… power outage, switches quit working, go to replace it three days later and it’s working. Been working since. And the other one? I had it sitting on a bench downstairs for a couple years. Out of curiosity I put it in when this whole edge thing was announced. It picked up the driver and has been working fine for a couple months now.