Z-Wave Fan Controllers with Alexa Speed Control? (2023)

Are there any zwave fan controllers that still work with SmartThings AND show control speed with Alexa? The wife is disabled and needs Voice control. We have always used the GE enbrighten fan controllers but that does not seem to work anymore.

It’s not really about the device model, it’s about the edge driver, and whether it exposes the speed levels to the voice assistants. So the good news is that makes it an easier fix, you just have to find the right edge driver to use for your existing devices.

@csstup has a driver that works with a number of models, if you can give us your specific model numbers, we can see if that’s a possibility.

[ST EDGE] Enhanced Z-Wave Fan Controller


As @JDRoberts mentioned, let us know your device model (easiest way is thru the advanced web app, go to the devices section, find your fan controller(s) and copy down the “manufacturer code”. This is the zwave fingerprint that drivers use to match to your device.


If the driver doesn’t currently support your device, it likely can be added without too much fuss.

1 Like

I will definitely do that but won’t be home for a couple hours. Another related problem I was trying to replace a fan controller that went bad(assumably) and smartthings will not see it as discoverable. Any Ideas? Jasco thinks it is a smartthings problem…

Hello finally made it home. The model is GE Enbrighten ZW4002 if that is what you need.

Have you tried a general exclude and/or a factory reset on that switch?

1 Like

Yes we excluded it and still nothing. On another note I had A leviton fan controller here and put it in and I can’t add it. I have the feeling I forgot how to add them correctly. I have SmartThings Hub v. 2

Is the GE fan switch currently included to your ST hub? If so, try the driver I linked. If not, try a factory reset on the fan switch (quickly toggle 3x up then 3x down, then the LED should blink 5x if successful). Then put the ST hub into inclusion and toggle the switch up 1x to include.

I’m not familiar with Leviton switches so can’t help much there other than to say you should try putting the ST hub into general exclusion mode first to reset the switch, then try including it.

I will reinstall the GE switch tomorrow. I am not familiar with how to change the driver though if there is a tutorial that would be great!

Also How do I put the V2 hub in general exclusion mode? It has been a LONG time since I have had to do anything at all to our ST so didn’t learn a lot that way

You can use the ST app or the ST Advanced Web App. In the ST app, it will be in the 3 dot menu in the device panel for the hub. In Web App, there is an option on the details page for the hub.

All custom edge drivers are installed in the same way.

  1. follow the invitation link to the channel page
  2. select the edge driver that you want to download
  3. subscribe. It will be automatically downloaded to your hub. This can take several hours but usually it happens almost right away.
  4. open the Smartthings app on your mobile device, go to the device that you want to have use the new driver, and click on the little gear icon to open its details page
  5. choose the “driver“ option if it is there. (If it is not there, then you will have to remove the device and re-add it, which probably means you will also have to rebuild all the routines that use it, but since you are changing to a new driver, it should already be there.)
  6. now you should see a list of the available edge drivers that are already on your hub that match this device’s fingerprint. Choose the one you want to use. And that’s all there is to it. :sunglasses:

If that doesn’t work, let us know, and we can figure out what else is going on.

You will find these instructions in more detail plus pretty much everything you could ever want to know about edge Drivers in the community FAQ:

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022)


So the new driver worked Great restoring Alexa Speed control! Thanks so much everyone.

But a big problem I still have is I can no longer add any fan controllers to My V2 hub. I can’t seem to make the switches I install discoverable. I have to be doing something wrong or have forgotten a step along the way. The hub works for other adds; I did a test adding a GE plug in switch I had laying around and it worked perfectly. I have a brand new Leviton And a brand new GE zw4002 installed and can not add them. What do you think I am doing wrong? Does it have something to do with and old Hub? If so what should I upgrade too?

WAIT WAIT WAIT! Looking at the advanced app the Ge controller did add this morning when I reinstalled it. IDK why the Phone app said it failed. I told me it failed multiple times. As soon as i renamed it in the advanced app it appeared in the phone app and Alexa. Thanks so much.

Now does anyone know how to add this stupid Leviton? lol

That driver worked PERFECT thank you!

1 Like

Try a factory reset first. Sometimes z-wave devices need to be reset to work properly - it may have network info stored either from when you were previously trying to join it or from testing at the factory. I found this manual that says you press and hold the top part of the paddle for 14 seconds, releasing when it flashes red and amber.

Then try inclusion. That manual says you need to press and hold the top part of the paddle for 7 seconds, releasing when it turns amber. Then press again.

I’d suggest you NOT use the “scan nearby” option to put your ST hub in inclusion mode. That option scans everything - zwave, zigbee and LAN - and I’ve found all that traffic can make it tough to get a zwave device to join. If you’re having trouble with the QR code then try going through the “by brand” prompts. Either of those should only trigger zwave inclusion.

1 Like

Zwave has two different concepts: factory reset and exclusion. Reset only resets the values of the parameters, it does not remove the information about which network the device has been joined to. For that you have to use exclusion.

The manual that you linked to explained that process, and that you will have to issue an exclusion command from a zwave controller in order to clear the old network information.

1 Like

While it’s a bit ambiguous, the manual makes me think the factory default procedure does both for that device.

1 Like

Ok will try that next. I forgot to mention another odd thing: when setting it to be discoverable it should go to amber lights… it does not it goes straight to green…then 4 red fail blinks. Ok going to go try the reset. Honestly I don’t think I care for the Leviton product much though.

We have two of the Leviton fan controllers and they work great for us. What don’t you like about them?