Z-wave devices just stopped working throughout the house (14 Feb 2023)

Have you tried a Zigbee mesh repair? Unplug your hub for about 30 minutes and then plug it back in and it will force the repir. If you have a V2 hub also remove the battery.

Well so for me, this is not working out :frowning: So I have the community GE/Jasco drivers installed (for a Z-wave switch) and I can see them listed in the drivers section for the Hub in the app. Unfortunately, they are not listed as driver I can switch to on the devices in question and for some reason a lot of the devices don’t even give me the “Driver” option on the menu in settings for the device, I’m a little confused by that, and I have a mix of devices but they are listed with that community driver option as ones supported.

There are two different reasons why a driver that you do have installed on your hub is not showing up as an option under an individual switch, even though they should be compatible.

A) that particular model has not had its fingerprints added to the new driver. That’s why we really do need to know the specific brand/model of the switch you are having problems with. For Jasco switches, this will be stamped on the metal surround of the switch module, underneath the face plate. Newer models will also have a separate QR code in a paper sticker on the surround.

If this is the problem, then you will need to contact the author of the edge driver that you want to use and ask them to add your model to the driver.

  1. another possibility is that the pairing failed partially and so the fingerprint that smartthings has for the device is all zeros. In that case, the solution is to remove the device from your account and add it again. This problem is actually more likely to occur with newer models because they have a bunch of new security features, and that security access is what might fail. So if your switch does have a QR code, you might want to try adding it that way first and then switch the driver.

As far as the device that doesn’t have a driver option at all, it is still using a custom Groovy DTH from the old architecture. Right now while both options are possibilities, the custom DTHs are taking priority.

There’s a fix for that as well, but it takes many steps, it’s more complicated, and it’s not reversible, so I am hesitant to recommend that until you’ve checked the other issues I mentioned above.

But as always, the first rule of home automation applies: “the model number matters.“ :thinking:

1 Like

I’ll try and get the actual model for the Jasco ones where I get the “Driver” option but don’t have the community driver offered as an option, but yeah it weird about the other ones (GE) where I don’t even get the “Driver” option in settings - I don’t have a single custom DTH installed or listed so I don’t get why I don’t get the option at all, even if it was just to see it using the standard Z-wave edge driver.

1 Like

That can happen when a device fails to pair properly and ends up with all zeros for the fingerprint. I’ve seen that happen for a number of reasons including not setting the device up with S2 security if it is supported.

It would help to know the fingerprints of these devices so we can point you in the right direction. I would suggest using the API Browser+ from @TAustin to verify the fingerprints.

1 Like

Thanks, that was super helpful actually (specifically the link for API Browser). The first where I couldn’t see/change the driver in the Smartthings app is up behind a bookcase and the API Browser let me determine firstly that I was wrong - not a Jasco/GE unit, that’s an original Smartthings brand dimmer switch. It also shows that sure enough it IS set as type DTH but also will not let me change the driver there in API Browser, I just get “Inelligible device”. I guess I’m gonna have to crawl/climb around each of the problem devices and determine exactly what make & model it is first, are there actually devices for which there is so edge driver?

SmartThings didn’t make dimmer switches. It’s probably telling you the author of the DTH being used. :thinking:

Can you post a screenshot of the entry?

You can not simply change a DTH to and Edge Driver.

You can wait for ST to do an automatic migration or you can delete the device and re-add. For Z-Wave devices you must also do an exclusion.

Sure thing…

Ah gotcha, this whole move to Edge thing I’m finding pretty confusing. I can certainly try and do just that (exclusion and then re-add) on this particular one to see what the results are like.

1 Like

Google for manufacturer code 0x0063 says this is a Jasco model. I’ve not paid enough attention to the Mfg Name in the API Browser, the ones I’ve just checked are showing SmartThings for devices still on DTH and SmartThingsCommunity for ones on Edge (even if they are stock drivers)

Most likely your devices is using a built-in DTH. If that’s the case and you do go thru the pain of excluding it, deleting it, and re-adding it, it should convert to an Edge driver.

Keep in mind that removing it will disable or delete any automations it is part of. That includes Scenes, Routines, and Smart lighting. You’ll want to save screenshots of everything so you can recreate after the new device is added.

1 Like

Yeah but I thought from the original Smartthings communications we were supposed to be done with that migration at the end of December!? Using the API Browser, it seems I’ve got a fair amount of devices still on DTH - is there some new statement as to when we’re supposed to expect all those to be migrated? Migrating via going around to each physically excluding and then re-adding sure sucks.

they adjusted the timeline to end of Q1 2023

1 Like

There have been multiple delays for migration of devices to Edge drivers. There has been no official communication of when the migrations will be completed other than “Q1 2023”.

1 Like

You can use a virtual device as placeholders in both triggers and actions for Routines to keep them from being deleted. You will still want to take note of the conditions and actions, but it saves the hassle completely rebuilding them from scratch.

1 Like

Well regardless, I do appreciate everyone’s help and comments in here. At least I have answers for things like why I can’t switch to a particular edge driver or why I don’t get a “driver” option at all on certain devices. I’m going to exclude some of my DTH z-wave stuff and try it add it back in as edge, although I don’t really expect that’s gonna make the difference on my initial problem that led me to the thread - the fact that some of my devices respond super slowly now or sometimes not at all, and that’s something that seems to be across my devices regardless of whether they are DTH still or Edge. If only it was a matter of replacing certain devices, but the responsiveness issues seem to move around and sometimes be with certain devices and sometimes others.

1 Like

I can sympathize. I have one switch that is slow to respond. It’s in a multi-gang box with two others that are fine.

It happens to be a GE/Jasco Z-wave switch that operates two wall sconces that have Kodak brand Edison style bulbs. Those bulbs are sensitive to trickle current that some switch models use to stay online when the load is switched off.

After you exclude a Z-Wave device and re-add it to ST, it is a good idea to run Z-Wave repair to help keep your Z-Wave mesh healthy.


Hi all! Brand new to the community here - far from a technical expert and looking for any/all help possible. Have had a great running Z-Wave set up on Smartthings V2 for many years now with 50+ GE/Jasco switches/dimmers. About 8 weeks ago, I started having the issue where everything is online, but the app will not update the on/off state or control these devices. I have performed multiple Z-Wave network repairs, excluding and reincluding, rebooting the hub, none of these fixes have worked. I tried the cool community driver by @philh30 and it will now update the on/off state within the app when I manually press the switch, but still not able to control these devices via the app. Any help anyone can provide is MUCH appreciated!