Most Z-Wave Devices Stopped Responding, Please Help (14 March 2024)

Hi folks. Yesterday 98% of the z-wave devices stop responding. I have a V3 hub and most of the z-wave devices are from Enbrighten Z-wave plus in-wall switches. There is no power failure in the house and I haven’t done anything to the system. The Zig-Bee devices work fine along with AC control. All the motion sensor also work fine. The light on front is green. I have tried reboot, power cycle the hub and repair Z-Wave network. I have deleted and reinstall the app. None of the method work. The app and the web interface show the hub and devices are online. However, when I press the button on the app, it just keep circling and nothing will happen. Sometime it will show the message “A network or server error occurred. Try again later.” The only Z-wave switches that work are the Enbrighten Z-wave fan switch. Anyone has any idea what else can I do to solve the issue. Thanks.

Update: I called the Samsung about the problem. After checking on their end, the technician said everything look ok on their end but will issued a ticket and escalate it to the advance team. She said she will get back to me 24-48 hours. Without notice, all the Z-Wave switches start to work this afternoon. I wonder if this might have to do with their server.

Update 1: All the Z-Waves Devices stop responding again. It only works for 3 hours and then it just stop working. This is so frustrating without knowing why it stop working.

Update 2: After a week of waiting and the case as escalated to Tier 3, I think Samsung support has given up. The usual suggestion of rebooting, deleting app, power on and off didn’t do anything. The next suggestion is that I am running out of memory, I need to either delete some devices or move them to a new hub. I believe Eric M is correct about the driver. I have over 90 Enbrighten Z-Wave switches which probably use the same drivers. I move 60 of them to Hubitat and they are functioning fine. Even clearing all those devices, the problem still remain. I am not sure what else to do beside keep moving devices to Hubitat until I have less than 20 devices that use the same drivers.

Update 3: Eric M is correct on the number of driver. I had over 300 devices on the hub. 70 of them use the same driver for the GE/Englighten Z-Wave Plus smart switches. After I move 52 devices to Hubitat, the rest of the devices start to work again. It’s been 3 days, no more delay or non response devices. I sure hope Samsung will fix this in the future.

1 Like

Eight of my battery-powered Z-Wave sensors now show “offline” for the first time ever… Is this possibly connected to the rollout of firmware 51.002?

2015 hub V2. Affected sensors are all battery-powered Z-Wave (not ZW+), from First Alert (smoke) and Monoprice/Vision (motion).

FOLLOW-UP: All back online within a couple of hours.

1 Like

I believe this may be a type of driver based memory limit that has been decreased or enforced on the new hub firmware. We have seen some of our Inovelli users that have many devices using the same driver that the driver re-initializes over and over again which makes the devices unusable. If you can use the smartthings-cli to watch the logs you will probably see the same thing.

5 Likes

@samjjp2009

Your issue sounds very similar to something that happened to me.

Have you tried Rebooting your HOUSE?

It worked for me :blush:

Thanks for the suggestion. I have tried all the step except shutting off the circuit breaker for the house. I have a lot of equipment that require constant power. Since I am running out of option, I might try it tomorrow if the problem still remain.

2 Likes

I would be very surprised if cutting power did anything in your situation. Given that at one point the devices came back online, you don’t have the buffer reset requirement that a few devices, mostly older, GE zwave switches, can have.

As a former field tech, I feel obligated to mention once again that cutting power at the circuit breaker should be regarded only as a tactic of last resort, as there is a very real possibility of physically damaging some of your devices which were otherwise working fine. And not just your smartthings-connected devices: cutting power in this way can potentially damage anything connected to the mains, including very expensive electronics and appliances.

No, it’s not that likely, and if you have individual surge protectors on everything, it’s even less likely (although you might then have to replace some of the surge protectors). But it is a possibility, and if you don’t have to take that risk, I wouldn’t. :thinking:

Cutting power at the circuit breaker is like punching someone to knock them out so you can perform a medical operation. Your devices don’t like it, and they can’t always handle it. And sometimes it’s a matter of cumulative damage over time (this is particularly true for smart bulbs).

So, sure, if you have tried every other option first, including contacting SmartThings support, and you have waited three days to see if SmartThings fixes something on the platform side that takes care of it, and you still have nonresponsive switches, you can consider turning off just that circuit breaker. ( I don’t recommend cutting all the power to the house. Just my professional opinion.) just be aware of the risks involved.

(And, yes, of course, electricians do cut power sometimes when needed, and power does go out in storms sometimes, but neither of those is completely riskfree. As licensed electricians will tell you. So, obviously, it’s your choice, It’s just good to be aware of the possible downside.)

Before taking that step, I would definitely look at the logs as was suggested above to see if instead you are having the restart loop issue that others are having now and that causes the same symptom. That has nothing to do with your own devices, it’s a platform change that smartthings made that broke some stuff. It will get fixed when SmartThings fixes it. Meanwhile, doing a soft reboot on your hub should temporarily clear the memory and solve it, but it will keep coming back until the platform issue is resolved.

To clarify what happens in the hub every time it restarts, and that depending on the number of drivers and devices installed it may take up to half an hour to stabilize.
In this process you can see the state of the memory in advanced users web as explained below and in the CLI logs the drivers are restarted sequentially until the state of the memory is established at a minimum soft limit.

Several devices can appear offline in the process

This is normal? who knows!

I Posted this in dec 2023

After hub initialize:
The memory status Hard Limit appears when starting init all drivers.

Sometimes in a few minutes the memory status goes to Soft Limit and then to Ok in other few minutes. Without any driver being reinitialized.

But other times it remains at Hard Limit for a long time and the drivers begin to initialize sequentially every minute or so and sometimes it takes up to 15 or 20 minutes to go down from Hard Limit to Soft limit and the drivers stop initializing and after a while the status changes to Ok status and everything starts working fine without delays

Perhaps it would be convenient when the Hub is rebooted to leave the app without using it until the memory status drops to soft limit and hub stabilizes.

I don’t know if this can help someone monitor their Hub with problems.

And this post too

The previous beta firmware updates, 52.x, the hub restarted quickly, but yesterday with version 52.20 it took a long time, several drivers were restarted and several zwave and zigbee devices were offline for a while, I left it and everything was fixed in a while.

3 Likes

Always good points & advice from @JDRoberts!!!

With some observations/thoughts added inline…

Recall that in my situation, the locks also came back online at times, but were sluggish at best. The Whole House Reboot “did” solve the problem instantly.

Agreed… but I “was” at that point (noting my prior troubleshooting steps)

To that point, I will edit the Step-By-Step to at least power down anything that is under your control, or you feel may be sensitive to power outages, such as computers or appliances with a history of sensitivity or susceptibility to power outages/restorations.

Many major appliances don’t even have an on/off switch (or at least one that people are aware of LOL): you plug them in, they go from a “no power” state to “power”, certainly mimicking a Power Outage or turning a Circuit Breaker Off/On. In my 40 years experience in building homes and working with electricians troubleshooting all kinds of issues, the worst kind of on/off cycle is a “quick” on/off… aka “flicker”. Which is why I recommend a good 2-5 minutes of power off. Give everything a moment to remain in the off/powered-down state before restoring power.

I’ve had to cut power to my own homes and many others over the years, to work on a circuit, install generators, etc. without ever once creating a problem with any electrical device. As well, same for countless power cuts without notice due to storms, line work, etc.

I am personally very comfortable in this approach, but @JDRoberts words of caution should be thought about before taking the Whole-House Reboot steps!

1 Like

As a retired electrical engineer I want to 2nd what @JDRoberts said. Don’t open (shut off) your main breaker except when there is no other options.

Some personal examples of problems that have occured:

  1. I opened the main breaker at camp to make some electrical system changes. When I went to re-close (turn on) the breaker one leg would not stay closed, so the breaker had to be replaced. The breaker was old and obsolete, so I had to find one on eBay, have it shipped and coordinate an outage with the power company. Result was I only had partial power for about a week.

  2. Over the years I have lost several GE/Jasco Z-Wave switches when opening sub-breakers to add additional smart switches.

  3. In the fall of 2022 I lost a half dozen surge arrestor power strips due to repeated power outages (power turning on & off) caused by a loose connection on a utility line up the street. When these surge arrestors failed some sound like muffled gun shots, and others smelled like electrical fires had occured. I have since added a whole house surge arrestor, and the utility fixed there line.

Again don’t turn off the main power if you can avoid it. Z-Wave problems are not a good reason.

4 Likes

Different processes, with different risks.

when you restore all power to the house at once, you are surging demand on the line. Very different than plugging in one device at a time. This is the reason why brownouts can cause damage to electrical equipment: it’s everything coming back on at the same time that’s a problem.

2 Likes

Highly recommended! I’ve installed them in a number of places we’ve lived and, although evidence is anecdotal, we’ve not had any surge-related issues. At a prior job, involving unattended two-way radio equipment controlled over leased telephone lines, a “whole house” surge protector was part of our overall practice for improving the reliability of each site. We had one radio site, in particular, that was in a high area with a tall tower which was exhibiting failures several times a month. After installing the remediation–which included the surge protector–failures dropped to maybe one every few years. YMMV, but I believe the expense/trouble installing such a device where the power comes into your home is well worth it…

3 Likes

Thanks for the suggest, erocm1231. I have start the Smartthings-cli log and here is a partial report.

2024-03-17T04:27:30.973660238Z TRACE Z-Wave Switch Setup driver zwave_switch with Capability handlers:
CapabilityCommandDispatcher: zwave_switch
default_handlers:
switch:
on
off
energyMeter:
resetEnergyMeter
switchLevel:
setLevel
colorControl:
setSaturation
setColor
setHue
refresh:
refresh
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → eaton accessory dimmer
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → Inovelli LED
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → Inovelli LED → Inovelli LED LZW 31SN
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → Dawon smart plug
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → Inovelli 2 channel smart plug
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → zwave dual switch
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → eaton anyplace switch
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → fibaro wall plug us
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → Dawon Wall Smart Switch
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → zooz power strip
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → Aeon smart strip
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → Qubino Relays
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → Qubino Relays → Qubino Relays
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → Qubino Relays → Qubino Relays → qubino flush 2 relay
default_handlers:
refresh:
refresh
switch:
on
off
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → Qubino Relays → Qubino Relays → qubino flush 1 relay
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → Qubino Relays → Qubino Relays → qubino flush 1d relay
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → Qubino Relays → qubino dimmer
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → Qubino Relays → qubino dimmer → qubino DIN dimmer
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → fibaro double switch
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → fibaro single switch
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → Eaton 5-Scene Keypad
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → Ecolink Switch
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → multi metering switch
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → Zooz Zen 30
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → Z-Wave Device Multichannel
default_handlers:
child_dispatchers:
CapabilityCommandDispatcher: zwave_switch → Aeotec Smart Switch
default_handlers:
child_dispatchers:

This log keep going none stop. Is this the re-intializes you talk about?

Thank you for the warning, @JDRoberts. I will not be cutting power to the circuit breaker. I believe you are correct on the restart loop. It seems that I get the Z-Waves devices to work between 4-6 pm (roughly 2 hours) for the last 2 days. I will monitor again tomorrow to see if the same thing happens again. As for the soft reboot, I reboot it at the webpage under Hubs and reboot, it doesn’t seem to solve the situation. Am I doing it wrong with the soft reboot?

1 Like

Absolutely great point @JDRoberts !

And different homes, some older/some newer, some with large ongoing power draws while occupied, others with minimal power draws while vacant, some with battery backups on all electronics (such as TV’s, A/V equipment, computer equipment, etc.) certainly all factor in.

Regardless, a slightly more nuanced approach should be taken and once again I’ll be modifying the whole-house reboot procedure post a little later :slight_smile:

For example, folding in how we implement a portable generator during a power outage for some people: The power is already off due to a storm outage; We turn off the main breaker; Turn off ALL of the individual circuit breakers; Introduce generator power; Turn on main breaker; Slowly begin turning on the needed circuits, one-at-a-time until their needs are met (of course being mindful of what the generator can handle).

To be clear, like many of you, having maintained multiple office & home networks over the years, there have been many times in my experience where rebooting one/or/two network components wasn’t enough: There is something about a Therapeutic Power-Cycle that clears the field and gets it back up & running.

For example, in a Mesh WiFi Network with say 5 Satellites, rebooting the main Router doesn’t do the trick, nor soft-rebooting the Satellites. There are times when Power-Cycling all 5 Satellites and the Main Router brings it back into working order.

Now comes the Z-Wave Mesh Network that lives in a Smart Home: Virtually every single one of the “wired/constant-power” Z-Wave devices is a Repeater, handing off communication to the next, etc. If THEY are never power-cycled, the glitch is never cleared.

My modifications to the whole-house reboot post will take on this form…

  1. First: If you only have a handful of constant-power Z-Wave devices or you know which specific circuits all of your constant-power Z-Wave devices are on, there is no need to do a whole-house reboot!
  2. But it’s important that you know, or can identify, every Z-Wave device in your house. If you only have a handful, pretty straight forward. If you have like 50+, it’s easy to forget this light switch, that sensor, the water shutoff, etc. It could be that “one” Z-Wave device that’s creating the bottleneck.
  3. Start by powering down your SmartThings Hub(s).
  4. If you have any electronic devices on those circuits (A/V Equipment, Computers, Appliances, etc), be sure to gracefully power those down first!
  5. Then turn off only those circuits with Z-Wave devices on them, one at a time.
  6. Wait say 3 minutes.
  7. Power on your Hub(s) and wait for them to fully initialize.
  8. Then power on the circuit breakers one at a time.

The whole-house procedure will take on the form I outlined above when introducing a portable generator.

2 Likes

edited above to include:
If you have any electronic devices on those circuits (A/V Equipment, Computers, Appliances, etc), be sure to gracefully power those down first!

2 Likes

Yes, this is what I have seen elsewhere. If you see that information scroll across the log over and over again then that is what I mean by saying the driver re-initializes. I have only seen in when there are many devices that are using the same driver. Over 20 ish, but the sample size of users is small so I can’t completely confirm that.

I appear to have the same problem. Z-Wave devices stop working. I cold reboot the hub and they start working again for a few hours and then stop again. Very frustrating!

1 Like

@mwiseman

A Z-Wave Mesh Network continues to live in your house, even after rebooting the Hub. Just like traditional Routers & Wi-Fi Mesh Networks, sometimes the bottleneck exists within a device other than the main Router. As well, sometimes a Soft Reboot is not enough and a Power-Cycle does the trick.

Take a look at this post, as well as the cautionary posts above, and consider Power-Cycling your entire Z-Wave Network.

With input from @JDRoberts and others, it has been refined to carefully power down & power up either a Limited number of known Z-Wave Circuits, or an Entire House.

I’ve run into an issue and am wondering if this is related… I’m in the process of installing many Zooz dimmers, all the same model. Up until the 22nd one or so all parameters were easily configured via the official Zooz edge drivers, however subsequent after the 22nd do not respond to parameter changes through the official driver. SmartThings saves the entered parameter in the app, but the configuration never makes it to the dimmer.

If I change to Mariano’s Z-Wave Device Config MC driver and wait for 30 minutes or so I can get the parameter changes to register. Then when I change back to the Zooz driver those changes are not represented in the parameter settings of that driver. It just remembers what I entered previously and didn’t actually update to the dimmer.

Any ideas?

Hi @Nick_T

The values of the preference variables can only be changed from the App.
For the driver they are read-only and therefore the value displayed in the app does not have to be synchronized with the real value of the parameter stored on the device.

If you manage to change the value of the parameter on the device with another driver, for example, then when you return to the original driver the preference will continue to show the value that the app previously had.

To synchronize it, change the preference value in the App to the actual value on the device, then the value will be sent and everything will be synchronized.

The platform currently has an intermittent problem, which causes a preference value is nor sent or sent several consecutive times to the device and that may be part of the problem you see in the driver.

2 Likes