Your location is not correctly setup

trying to install webCoRE Smartapp in my ST mobile app (not classic) in the My SmartApps section. I kept getting the error message “Your location is not correctly setup. Please follow these steps to setup your location timezone”

When I got to ‘Manage location’ the entry under geolocation has a pin on the exact location with my full UK address and postcode.

I have tried moving it away, then moving it back again, but it makes no difference

Eventually I tried enabling one of the default apps under AllSmartApps

When I tried Webcore again after that the problem had gone away

Hope that might help somebody

1 Like

I’ve hade this problem for some time now… I tried to install an default app “Smartthings home monitor” but I Still get the same error message "Your location is not correctly setup. Please follow these steps to setup your location timezone”

Is there any more information to help me install webcore?


As you can guess from the error messages, webCoRE is checking whether the timezone has been set up and being told no.

It would be interesting to know what the location looks like when viewed in the legacy environment via the IDE, and also in the new enviroment (e.g. via the CLI or other access to the REST API). Specifically is the timezone actually set in the legacy environment?

It could be one of those unintended consequences things like Sunrise/Sunset where removing Hello Home (routines) also removed the Weather Station child app. That was fixed by making it a child app of Smart Lighting and adding it whenever a Sunrise/Sunset automation was created in that. Actually that would be worth a try in this case. Something somewhere has to create the timezone.

If it’s any help, the default app I installed was doorknocker, which is as basic as you can get.


Well now the IDE shows the location as co-ordinates (N & W) and timezone as Europe, London. I didn’t view location in the IDE when I was having the problem. WebCoRE was my first venture in Smartapps, so nothing previous could have messed with it.

The ‘built in Smartapp I added, after which Webcore seemed to be happy with location setup was doorknock, which does not have time or place settings.

Use the classic app and find you location. Hit save and go to the new app.
It worked for my.