"You are not authorized to perform the requested operation" at Login


(Dave Isenhower) #1

I signed up with a new account back in December. For the past week, I have been getting messages on my mobile app that says “You are not authorized to perform the requested operation”. After a while, I got logged off of the app and when I tried to log back in, it returns the same error message – I can’t even get past the login screen.

When I tried to log into the smartthings.com website with my account, it said the account didn’t exist. This is weird, because I have been running with this account for a month and now it appears to have disappeared. I registered on the site again with the same email address, but I still can’t log into the app on my iphone. I know my credentials are good because if I enter the wrong password, I get a failed-login response instead.

I tried uninstalling the app and reinstalling…same thing happens.

Any ideas?


RESOLVED: "You are not authorized to perform the requested operation" loging into Android Mobile App
(Kevin) #2

You may want to try restarting your phone. I doubt it will fix it, but it’s worth a shot. If that doesn’t work, you may need to contact support because the message below is still on the SmartThings Status page.

A small subset of users have reported receiving errors when logging into the SmartThings mobile app and IDE. This is related to the fixes that we are currently implementing. Please attempt to log in again, but we can’t guarantee success until the repairs are complete. We will continue to provide updates accordingly.

  • Jan 22, 17:28 EST*

(Dave Isenhower) #3

Hi Kevin,

I just tried restarting the phone and, as expected, it didn’t help. I’ll keep an eye on the SmartThings Status.

I did discover a new symptom. I logged into the graph.api.smartthings.com web interface, I get “Access denied” when I try to view my “Home” location. I don’t know if it’s related, but seems like a good chance that it is.


(Jon) #4

I had the same problem, exactly. You will not be able to add devices, modify some smart apps, or edit devices in the IDE. The only way I was able to fix it was to submit a support ticket, wait over a week for them to get back with me to ask if I would reinstall my app, which I had stated was done in my email, then wait another 2 days before they actually fixed it, after I responded.

Put in a ticket and wait. Hopefully the take quicker care of you.

–buba


#5

Stunning - over a week for a company to respond, after you’ve spent hundreds of dollars on nifty gadgets?!


(Yoav ) #6

I guess I should also wait for a week… So disappointing !


(Lane ) #7

I just started having this issue last night. I believe it has something to do with modifying rooms in the app. I submitted a support ticket myself, but waiting a week to use the system is truly unacceptable. Maybe its time to dump smartthings and move over to wink where at least you can actually get support if you need it.


(Kevin) #8

Hello everyone. I’m new to the forum, but wanted to share my experience with this same issue. I started receiving the dreaded “You are not authorized” error message on day one after creating rooms on the app. I emailed customer service because it was Valentine’s weekend and received a reply on Monday, 2/15, acknowledging the issue. The CS rep advised me it was a known bug caused by “a corruption in the permissions for your location.” They “escalated” my case to the cloud engineers and my log in was restored by the next day. Evidently the app is still experiencing other known bugs such as showing multiples of the same room. CS assured me they are working on that issue as well. I hope this helps and good luck!


#9

I was installing a Zen Thermostat last evening and when I attempted to set up a room, my device logged out and now I am unable to log in on any iPhone or iPad.

I keep getting the message that I am not authorized to perform the operation.

How do I get them to fix my problem?
Thanks
Joe


(Dan Crandall) #10

Yep, same thing happened to me yesterday (Sunday). Samsung Smartthings Support was fairly prompt with an email response informing me that a support ticket was created first thing Monday morning. It’s now Monday afternoon and I have received another email from support informing me that this is a known issue having to do with creating rooms and that my problem has been escalated to one of the support engineers for resolution. I hope to hear back soon.

It’s now 2:30pm on Monday and I’m pleased to say that I am able to login to my account once again.


(Chris Holdcroft) #11

I received the same message on my iPhone last night restarting phone made no difference can still access my account via browser and my smarttiles anyone else? I am beginning to lose faith in the platform what is going on?


RESOLVED: "You are not authorized to perform the requested operation" loging into Android Mobile App
(ocpd+adhd+alz+md+hfa+fms+lol=me :)) #12

Oops…didn’t notice this is the iOS area.
So, I moved my comments about this one to here…


(Dave Isenhower) #13

To follow up on this thread, ultimately this required filing a ticket to SmartThings Support. They acknowledged it as a permission error that could only be resolved by their technicians. After about a day, the issue was corrected.


(Andrew Collier) #14

I’ve had this problem for the past two days. I opened a ticket and didn’t get a response for 24 hours. The response was that they may not be able to fix it until after the weekend. Ironically I received a separate email telling me I am getting an update for my hub sometime Monday. Coincidence?


#15

Is there an easy fix for this now? I am getting it on multiple devices.

@slagle ?


(Tim Slagle) #16

Send me a PM with permission to look into your account. :slight_smile:


(Chris) #17

I’ve got this problem as of today. I have an app which was working fine, ever since this morning started returning ‘not authorized’. Is there an easy fix?


(Chris) #18

I was able to fix my issue by uninstalling the app. Previously, I was just updating the already installed app.


(Ron Gallant) #19

Is there any insight on to why this happens? I am not able to enable iAuth on my app because I get the “Access Denied” page. :persevere: