Getting "You are not authorized" message

I’m new to SmartThings as of last week. For some reason when I go to edit anything and when most pages are loading, I get the error, “You are not authorized to perform the requested operation.”

I am using ST as a secondary z-wave controller. All of my devices are showing up and I can control them, but I cannot add any Smartapps, create rooms, or edit any of my information.

Did I do something wrong? I’ve e-mailed support, but they have been closed for several days for the new years. Any help would be appreciated.

Is this in the app you are getting this error?

What about in the IDE (

Hey Brian. Yes, this error is in the app.

When I log into the api site, I can do most things, but I’m getting access denied on the locations page.

Did you ever get this resolved? How long did it take to get a response from Support?

Hey Brett,

Yes! Support was able to resolve the problem. It took them 6 days to respond because of the holidays, but they responded the Monday they opened and it was fixed by Tuesday. A little disappointing at first because this was my first experience with Smartthings, but everything seems to be working fine now.

Good to hear, thanks! Same situation, first experience with this setup… Hopefully it will be better after this…

I’m having the same issues and awaiting response from support. Been two days now, so I agree it is disappointing to have something like this not work out of the box.

The issue appears to be related to something on the backend. I did get a response from Support, about 24 hours that they were working on it, and about 2-3 hours after that things started working. Not too bad, since then everything has been stable and functional, no further hiccups. Feeling better about the purchase and solution.

In my case, they state the reason was caused by my use of the Android App on my BlackBerry. Not sure what that would have to do with it, but that is the claim. I have plenty of other devices to use and can live without having access to ST from my phone for the moment.

1 Like

… and now I’m getting the message as well - at a camp I’m only at on the weekends. If it takes Support days to respond, this will take a loooong time to resolve. It’s my first time using SmartThings, so as you can imagine the frustration level is stratospheric.

After waiting two days for help, I deleted the one SmartThing I had managed to configure, and then tried to delete all the rooms, hubs, and locations associated with it (through the GUI). I got error messages left and right, but tried two or three times to delete each item.

The single (original) location that threw Access Denied messages in the GUI still appeared on my smartphone app, but the picture I had added to it disappeared. I could not delete it in the GUI, and the smartphone app threw the “You are not authorized” message. But, I went ahead and added another location (same house, different name), then I re-added the hub, which went quickly. After about 20 minutes of trying all over the house, I was able to get the original first device to pair with the hub by holding it within about 2 feet, and then I was able to add all the rest of my devices in the house regardless of location, and I was able to add rooms as well.

I still cannot delete the original location, and the smartphone app still throws errors randomly. For instance, adding a room is about a 60% successful exercise, but even when it throws an error, I just click Next (or Done if that’s what I would have anyway), and each time it has successfully created or deleted or configured the object I was working on.