You are not authorized error when creating Piston


(Steven Parker) #1

I am new to all of this but believe I have successfully installed CoRE to my account as I am able to load it to the mobile app via My Apps. I click the Dashboard to initialize and it says it was successfully initialized. But when I try to create a Piston, I click IF and get the error message "You are not authorized to perform the requested operation. Get the same error if I try to delete CoRE, but it does actually delete it.

Has anyone else experienced this and found a solution. I am using a Lumia 950 and the Windows Smartthings app.


(Bob) #2

I know this is not the answer for you but you might want to install webCoRE instead.
This is the next iteration of CoRE and besides being able to backup/restore/duplicate etc. pistons, you can also use your PC as well as your tablet/mobile to build pistons and makes life easier in general.
Just a suggestion as most people are gradually migrating over.
Happy automating. :slight_smile:

PS. Have you Oauth’d CoRE in the ide?


(Steven Parker) #3

I did Oauth, but I think the security codes aren’t in sync - though I haven’t figured out where to change them and get them back into sync.

Not to sound like a newb (though I am), where do I find the webCoRE?


(Bob) #4

The following thread is a good place to start.
It will give you an idea of what you can do.
Also, just do a search for webCoRE and you will get lots of hits for it.


(Robin) #5

(Steven Parker) #6

My issues must be due to the Windows phone. I’ve installed the various webCore apps and when I click on webCore and then Next - I get an error message saying "Oops! Looks like you need to double check some inputs… but there isn’t any place to enter anything. Oh well - it was just an idea I wanted to try out.


(Robin) #7

Yup… Windows phone does not work with webCoRE… think of it as an incentive to upgrade to a proper phone lol