Yeelight integration with SmartThings

Hello I have few pieces of Mi Smart Bulb Essential (MJDPL01YL) which they added in MI Home app.
I used to add these lights to SmartThings via Yeelight login in SmartThings.

Now, after yeelight login in SmartThings it says there is no devices found. You can check the screenshot below.

How can add these Mi Bulb lights again to SmartThings?

Thanks

3 Likes

Have you gone to linked services under menu and opened the yeelight link?

@Paul_Oliver and @AlejandroPadilla Hello Pablo, when verifying this it gives error 404, we do not have it and it says that it does not have any associated device. With Google home it already works. I’ll have to write who?

Hi everyone, in this case, you need to contact Yeelight support so that they can investigate what happened, if they need help investigating they must contact us via build@smartthings.com with the logs from their cloud.

I have already contacted Yeelight, they have already fixed their information. This is the error that appears when trying to add the device via the cloud.


2 Likes

Hello, I have the same problem. It seems its a mistake on smartthings end, other apps i’m able to link and login into yeelight (xiaomi).
Please fix this (no pressure), as i don’t like google home ect… way more options with smartthings :smiley:

For the first screenshot, the error message must be in the logs on the Yeelight server, normally related to a requestId that we can use to track what happened, references to How works schema integrations

For the second, What steps did you follow to get the error?

@AlejandroPadilla I have written to Yeeligth and they say that they have already fixed everything on their part. In fact, before it no longer worked with Google home and now it does. What I did the same as before, trying to log in with my account but I get the 404 error. And that’s it. I can’t do anything else, because I go back and it says there are no devices

The way that devices are integrated with SmartThings is different, in the case of schema integration after the access is granted
1- Smartthings will send a discovery request
2- The partner needs to respond with the device information

If you try again and share with me the time/date and your time zone I can check what is Yeellight’s response I also will need support access to your account, but SmartThings can modify what they are responding to.

Here is the full proccess

I tested it with the Yeelight and Yeelight Pro integration but I can’t reproduce the 404 error on Android and SMartthings version 1.8.10.21

Support access steps:

  1. Confirm the email account registered in the forum is the same one you use for SmartThings. If not, please share it with me over DM.
  2. Enable support access to your account:
  1. Go to the SmartThings Web (my.smartthings.com)
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.

I have have the same problem with Yeelight integration. Always the 404 page, and no devices. Any solutions?

@AlejandroPadilla it is already activated. I have seen that another user has the same problem. And if the account is the same one you always use with Yeelight

Thank you for the support access, When was the last time that you tried to add the device?

@AlejandroPadilla 21/11/2023 11:45pm

@Jesus_De_Oliveira I noticed in the SmartThings logs that ST sent a Discovery request, and the response is ‘DiscoveryResponse does not specify any devices.’ This indicates that Yeelight is responding with devices: [], I couldn’t find any errors from SmartThings Sorry.

If these devices worked in the past, there’s a possibility that they made some changes to their connector because they handled that process.

In the case that the developers of Yeelight communicates with us I can share the requestId so that they can track what is happening on their side.

I don’t know whether any of these are connected, but in the last few weeks, there has been a big increase in the forum of people saying that devices that used to work stopped working, and when they tried to re-add them, they could never complete that process.

This includes
yeelight
Treatlife
wiz
Leviton WiFi
Samsung televisions
Samsung ovens
A developer-created endpoint smartapp

Note that these are all non hub integrations.

Also, something about the Hue hub, but I think that’s a different new problem and engineering is already looking at it. :thinking:

3 Likes

@JDRoberts that is interesting, there’s a bug on the last Android version that affects Partners that have Cloud-to-Cloud integration and Hub Connected integration, which affects how are added C2C devices but I’m not sure if all of those cases are related.

Could you tag me or share the posts with me to check what’s going on? :saluting_face:

If they are talking about the custom driver yes you are right

2 Likes

Hi
I have the exact same problem. I also granted the SmartThings Support team with access to my account.

This problem started to happen a while ago, for both Yeelight and Tuya Smart.
I suspect it might be a bug on ST side.

Many thanks!

@AlejandroPadilla Good afternoon, do you have any information about this? Still the same problems.

Hi @Jesus_De_Oliveira, Unfortunately, no, the issue I mentioned, which affected some Schema integrations (Sengled, Wiz, etc.), was resolved in December, if I remember correctly, so, it must be another problem.

Hi there,
same problem here, but I can figure on what ist going on.
The first time I linked yeelight with smart things, I used the wrong yeelight account. (just signed in with google). My lights are regristered to another account. Now, when I delete yeelight integration and try to link it again, smarthings gives me the 404 Page and links to the first linked account again by itself. So I cannot link the account with my regristered lights.
Is there any chance to delete the data, that is cached in my smarthings account or watsoever?
Thx a lot.