Yale Lock Doesn't show up in IFTTT

I have the Yale YRD210 working well with SmartThings. However, the SmartThings channel in IFTTT doesn’t show it as a lock - in fact it doesn’t show up at all.

I’d like to expand the usefulness of my Yale lock through IFTTT. Any ideas how to get it to show up?

It should show up once you’ve authorized IFTTT to access it through ST. You have to authorize each individual device, so if you add any new devices, you have to go through the authorization process again. You can start this from either the IFTTT side or in the ST mobile app.

In the ST mobile app, go to the Dashboard and tap on the “SmartThings Internal” category.

Then click on the tiny gear icon on the IFTTT tile to open up its details page:

This will allow you to specify the devices for IFTTT control. Click DONE at the top right when finished.

After this, the devices should show up as selectable from IFTTT.

That said, what exactly is it you want to do? ST is actually somewhat unusual in allowing IFTTT access to locks–most IFTTT channels don’t. So for example Harmony will not allow IFTTT control of any activity that includes locks, even ST-controlled locks.

I’m having the same issue with my Schlage Camelot lock, however when I go to my dashboard in SmartThings, I do not see any option for “SmartThings Internal”

Please help

I’m sure it’s confusing. :disappointed_relieved: You’re replying to a post which is 18 months old, so the SmartThings mobile app has changed several times since then and the screens are different now.

To find it now (January 2017), do the following:

  1. Open the SmartThings mobile app

Two) choose the automations icon (checkmark at the bottom of the screen) to open the list of automations

  1. tap on “smartapps” at the top right of that page and that will open the list of your currently installed smart apps. You should see the IFTTT smartapp in that list.

Here’s the official support article: