IFTTT Devices not showing up

devices
integration
ifttt

(Harp D) #1

I’ve linked my SmartThings hub v1 for my home to my IFTTT account and I checkmarked every light switch and motion sensor and authorized it.

However, when I try to create a recipe, none of the devices show up under switch on/off or motion detected “IF” actions. The dropdown said “please select a switch” but there is nothing to pick in the dropdown.

I have also tried using the IFTTT app on my phone and it too doesn’t list the devices in the drop down.

I have tried disconnecting, reconnecting the smartthings channel many times over the last few days. I have also tried only checkmarking a few switches and not everything when authorizing but still nothing shows up.

Any idea what’s going on?


Problems connecting from IFTTT (February 2017)
#2

Hi, just curious why you want to link ST to ifttt?


(Paul Mullen) #3

I’m not sure why he wants to do it, but for my case, I want to say, “Alexa, trigger basement off” and have all the lights in my basement turn off.


#4

you can just group the lights in Alexa app and do the same thing without IFTTT


(DataCrypt) #5

I just purchased 4 Samsung SmartThings water leak sensors and am greatly disappointed! The only thing it seems I can do in the event of a water leak is setup a SmartApp to send me a push (text) notification. I don’t have any sirens or bluetooth speakers (supporting TTS) to trigger.

Worse is it says I can us IFTTT to get a phone call in the event of a water leak. I went to IFTTT, saw the applet, turned it on, entered my number (got a call to enter a PIN), then ultimately IFTTT won’t show any of my devices! It’s just a blank drop down list saying “Please select a moisture sensor”.

Anyone have a resolution to this. I don’t see how to have IFTTT discover my SmartThings devices. Any help would be greatly appreciated. Thanks for your time.

Kind Regards


(Will Gladden) #6

I’m trying to add Smartthings to ifttt and having the same issue. Would like to use ifttt to open gate when code is texted to my number with a #.


(amatolusa) #7

I too don’t see how to have IFTTT discover my SmartThings devices. IFTTT doesn’t list my multisensors. Any help would be greatly appreciated.


(amatolusa) #8

Had to re-authenticate to smart things hub to see new devices. Then things started working.


(composedjourney) #9

How did you do that?


#10

Smartthings --> Settings --> Edit Connection. There you can select your switches, sensors etc.
Worked for me, now they show!


(Paul DeVito) #11

Just went thru that and it worked. Thank you!! So just to clarify, you have to go to ifttt app, discover, search SmartThings under services, settings, edit connection, and log in there. You’ll have the option to add all your devices. Thank you man!!