SmartThings Community

Xiaomi/Aqara Water sensor


(Jason B) #18

Thanks so much…success!

Out the box, pressing it briefly results in a single light response. (1)Held it down until it flashed repeatedly, then released. (2) Pressed down once and quickly released, which was followed up with a SINGLE light response from the sensor. Rinse and repeated step (2) until it was eventually picked up by the hub.

Big thanks again to the OP @chippie and @mjbshark for preserving my sanity tonight! lol

@mmorey79 & @seekingsun try it. I believe the quick flashing means it’s in pairing mode; single presses and waiting for the SINGLE flash in between before pressing again, 'till it’s picked up by the hub.

Edited- to clarify the methodology


#19

Thank you, will try later tonight. Do you have to be really close to the hub like with some devices or can you pair it from across the room?


(Jason B) #20

I was able to pair them where I planned to install them.


#21

I don’t get it, not working here. I push and get an immediate blink, followed by two short blinks. That sounds like it’s supposed to be. But I have been pushing the button on 2 different units for at least 100 times and the hub won’t recognize it. I push, wait for the blink, wait another second or two and then push again. I tried taking the batteries out, resetting it by holding it for a bit longer and then pushing again. I was trying it a bit away from the hub as well as right on top of the hub. Not sure if I am missing anything here…?

Thank you all for the great support!


(Gabriel Grant) #22

I’m having the same experience, with two units.


(Maverick Asc) #23

I had issues where the device was not getting recognized at all. Here is what I had to do for it to work (putting it in beginner words, as I am a beginner):

  1. Look at this thread: Xiaomi Zigbee Outlet (Steps to Pair any Xiaomi Zigbee device!) for instructions on how to pair Xiaomi devices in general. Keep this information in mind as you are looking for "catchall: " (without quotes) to show up in IDE (http://ide.smartthings.com).

Or look for this entry:

debug non-TV event zbjoin: {"dni":"**XXXX**","d":"YYYYYYYYYYYYYYYYYYY","capabilities":"80","endpoints":[{"simple":".....................manufacturer":"LUMI","model":"lumi.sensor_wleak.aq1"}],"parent":"FFFF","joinType":255}

You need the value of “XXXX”, so note it down (for lumi.sensor_wleak sensor).

  1. Put the hub in pairing mode. These devices do not show up so easily when you put the hub in pairing mode, to say the least, and even if you are trying to locate them in Live Logging (a. go to IDE, b. select your location & hub, c. go to Live Logging page).

NOTE: People have recommended to use List Events on the HUB (a. go to IDE, b. select your hub, c. go to List Events page) for easily looking for this information. Note not all catchall: can help you identify the device. Some catchall: is related to device metadata and battery information for existing devices. You are looking for catchall: with the device signature like so:

image

image

in it. So be careful with false positives!

  1. Follow the reset & pair process:

    RESET: 
    a. Hold the sensor down for some time till the light flashes and then turns off (takes around 1 minute or so). 
    b. To complete reset, you need to hold it down again and then wait for the light flash to turn off. Reset completes at this step.
    
    PAIR:
    a. Put it in pairing mode, by pressing it for 4-5 seconds till it starts flashing: these are slow flashes 0.5 seconds apart. Then let go the button and you should see a couple of quick flashes and then device goes blank and then after 1-2 seconds flashes again one time. 
    b. This is when it pairs and you should see a the "catchall: " show up followed by a zbjoin.
    
  2. Add the device from IDE using steps mentioned in Step 1. Change the device type to “SmartSense Moisture Sensor” (or you can use the custom DH and select Xiaomi Aqara Water Sensor) from the list.

  3. IMPORTANT: Go back to Smarthings app and “Add a thing” and Pairing should now complete.

  4. You now need to establish the link between the sensor and the device by dunking the sensor in a bowl of water filled shallow, just enough to produce the water leak effect!

ENJOY!

Also, I have created a custom device handler for this thing: to get battery status etc: https://github.com/MaverickASC/MaverickASC/tree/master/Aquara

This is a Beta version so you may have to check back for updates / fixes.


(masoninc23) #24

After reading MaverickASC directions i was able to get both my sensors added without any issues using the catchall method. Make sure you select the sensor type as moisture sensor.


#25

I dont get any catchall in my event logs. Can you break down the steps even further?


(Maverick Asc) #26

How many devices have you tried this on? I have 8 sensors and 7 of them are configured. The last one is not configured and it also won’t show up no matter what.

Possibly the battery it came with needs to be replaced. I wrote and custom DH to add the device automatically to Smartthings and to figure out the battery status. The battery part seems to be working fine and I am getting battery percentage from the devices and it looks accurate.

But automatically adding the device needs to be fixed. It apparently adds the device as a “thing” but I do not see any visible prompt on the screen like other devices.

debug non-TV event Thing added
debug non-TV event zbjoin: {“dni”:…,“manufacturer”:“LUMI”,“model”:“lumi.sensor_wleak.aq1”}],“parent”:“FFFF”,“joinType”:255}

So still needs a bit of work. I will publish the DH soon so others can use it as well, after a little bit more testing.


#27

My sore thumbs thank you good Sir!

After hours of thumb pressing the steps you noted worked. Got 2 sensors to work, 15 more to go!

BTW how did you get the battery level to work?


(Jimmy) #28

Yes, please do post a link to the code!


(David Westall) #29

I have the Xiaomi water sensor and can’t get it to pair with my SmartThings hub. When I press the button on the sensor and let up the light flashes immediately one time followed by 2 quick flashes. I never see anything in Live Logging. I’ve pressed it over 50 times, waiting several seconds in between, nothing. If I hold the button down to reset, the light turns on solid and blinks off every 3 seconds. I’ve held it down over a minute but it never completely shuts off. I tried a different battery, I tried holding the battery down while pressing the button. Nothing seems to work. I only have one of these devices right now, but have 2 more on the way. I’d really like to figure this out.


(Maverick Asc) #30

Okay so full disclosure, I am very new to Smarthings (just got the hub last week) and I have very limited understanding of the platform. But using my limited development skills (was a DEV earlier but now a PM) I was able to produce this ALPHA release of my custom DH: https://github.com/MaverickASC/MaverickASC/tree/master/Aquara issued under Apache license. Most of the time went into reading the terms of Smarthings Apache license and trying to understand what I can and cannot do. But broadly my understanding is that I should be OK.

Please note that this is a ALPHA release, so there are bugs! But battery and wet / dry status is reporting correctly. I need to determine what the other messages mean. Reach out to me on this thread for support if it did not work for you. I will try to answer / help best I can.


(Jimmy) #31

what value are you seeing for battery? I’m getting 25%, which seems low since i put in a new battery a couple weeks ago.


#32

I’m in the same boat as you. I’ve taken a multimeter to the battery and validated that it has enough juice. Still no go on pairing.


(Jason B) #33

Try pushing down immediately after seeing the single blink instead of waiting 2-3 seconds (but DO wait for light to be off before pressing). Each press should be like a click; brief…don’t press and hold.

Hope that helps!


(Derek) #34

Thank you MaverickASC! I have been trying to get these to pair for a couple of weeks with no luck. Your post from 9/28 is very helpful. I was able to get all 3 to pair (In IDE, My Devices, + New Device) and they work. I have them listed as SmartSense Moisture Sensors. I have not tried the DH yet. These do not seem to pair just using the app.

The key is checking under “List Events” for the Hub and looking for the Catchall event with the 4 character code. It does not show up in Live Logging. You do have to manually refresh List Events in order to see the recent events. I also needed to reset my hub a couple of times (Unplug and pull a battery) before I was able to get the hub to communicate with the sensors. If you are pairing more than one, check List Events for the 4 character code and use it to pair (In IDE, My Devices, + New Device) and then save the new device (In the App, cancel Add a Thing and then start it up again, you will have a new device to save) and then do the next one. After each one I had to reset the hub. One took almost 3 minutes to show up and 2 took less than 1 minute to show up in List Events.

Good luck. Once they are paired they work to detect moisture!


#35

David, you are on the right track. The key (at-least for me) was to have 1 solid flash followed by 2 quick flashes. I kept pressing down to keep on having this pattern repeat ever 2-3 seconds, while the hub was in pairing mode.

Another key thing is the hub’s logs (List Events) not Live Logging. It’s over here that the catchall error message will display. Once you have the catch all display, follow MaverickASC’s instructions.

When I get a single flash after a quick press/release I’ve rebooted the sensor (per MaverickASC’s instructions) and kept trying until I get the 1 solid flash followed by 2 quick flashes.

This is what I did to get 2 sensors working within 20 mins. I still have about 15 more to go.


(DTomas) #37

I can’t find any catchall string on live logging. So maybe I can find it on List events? What should I search on that? and do I have to click “All” ?

I’m looking back right now(13 hrs ago) to see if any catchall on my List Events.


#38

Yes, hit “All” in List Events. If a “catchall” event has occurred it will look something like this: