Xiaomi/Aqara Water sensor


Just received two of them but can’t figure out which DH to be used? Has anyone already added them to ST?

Solved! Used smart sense moisture sensor!!! and it worked


@sballoz did yours show the battery % with the smartsense handler? Mine reflects wet/dry, but not the battery %.

For me too. But still great, the battery is a plus.

No battery!

did you use a handler for this

Use smartsense moisture sensor

I am new to startthings use the app to find it or do I need to add handler
moisture sensor
also will smart sensor send a alert like the rest of water sensors
thank you for any help

Go to app -> add a thing and then click on the sensor until it gets recognized in the app as a “thing”. Go to the ST web under devices and edit the “thing” type into smartsense moisture sensor. Done

Can some please post a link to the DH for the xiaomi water-sensor?

There isn’t one yet

Guys what is DH? and does this - https://www.gearbest.com/home-smart-improvements/pp_668897.html work with ST hub?

Device Handler. And it does except for battery reporting.

I am having trouble getting them to pair. I pushed the sensor button in multiple different variations but the smartthings app won’t find any of the two sensors that I bought. Per google translate and the manual you are supposed to push it for 5 secs, but that didnt work. I removed the batteries and put them back in, I am pairing right on top of the hub, nada. What’s the secret here?

The livelog detects something but that’s about it: detecting status for 1ddc6fdf-a2d1-4368-8fc1-1c47e3xxxxxx : false

1 Like

Same here, I can’t get it to pair to save my life.

1 Like

Could you describe in detail how you managed to pair the sensor? Apparently my clicking technique is not on point and can’t get this to pair.

Thanks in advance!i

1 Like

i just paired three of these and did not figure it out until the 3rd one…

The instructions quoted below worked for me (posted a few pages up)… Less is more… I too was pressing the heck out of the thing for 30min…

I would sure love to get the battery working at some point as with a device like this it would be unfortunate to find out battery was dead after you have a leak…

chippie /MARK
No holding the button!

just press/release it, wait a few seconds for the LED to flash back, keep repeating until it shows in the app. As you get close the LED will flash 3 times then again 3 times after a second or two. Just continue to single press the button and wait a few seconds for the LED to respond. The hub will pick it up.

You can reset the sensor by holding the button for several seconds until the LED stops flashing, then release, you should get a single flash after that press and hold the button again and the LED should flash quickly for a few seconds, wait for it to finish then release the button. The Sensor should be full reset now. Try to pair it again…


Thanks so much…success!

Out the box, pressing it briefly results in a single light response. (1)Held it down until it flashed repeatedly, then released. (2) Pressed down once and quickly released, which was followed up with a SINGLE light response from the sensor. Rinse and repeated step (2) until it was eventually picked up by the hub.

Big thanks again to the OP @chippie and @mjbshark for preserving my sanity tonight! lol

@mmorey79 & @seekingsun try it. I believe the quick flashing means it’s in pairing mode; single presses and waiting for the SINGLE flash in between before pressing again, 'till it’s picked up by the hub.

Edited- to clarify the methodology

Thank you, will try later tonight. Do you have to be really close to the hub like with some devices or can you pair it from across the room?

I was able to pair them where I planned to install them.