Will Secondary Controller Still Work?

I’ve had an Intermatic Home Settings HA07 controller for years which I mainly use to automatically turn on outdoor lights at dusk and off at a set time in the morning. I realize that I can’t pair the lights that it controls with ST’s because it is a master controller. My questions are:

Is there a way to have the HA07 still control the lights as it does now, but also have them controlled by ST’s?
If so how do I do that?

In order to have two controllers on the same Z-Wave network, one of them must join the other’s network. This will always dismantle the joining controller’s network.

Our recommended course of action would be to exclude all the lights from your HA07, then add it and all the lights to the SmartThings hub, then re-include the lights to the HA07 buttons. This would make the SmartThings controller be the primary.

There is a Z-Wave function called a “primary controller shift” that is optional for controllers to implement. Looking at the HA07 manual, it’s not clear if it can do a shift. If it can, you could do a primary shift to the SmartThings hub which would leave the network intact and make the hub the new primary controller on the original HA07 network. This would overwrite any Z-Wave devices you’ve joined to the hub, but ZigBee devices would be unaffected.

If you really don’t want to re-include your lights, you could try adding the hub to the HA07 network as a secondary using the “duplicate the network” function on the HA07 and the “Join/Leave another Z-Wave network” Z-Wave utility for the hub. I wouldn’t recommend having the SmartThings hub be a secondary to a less-featured controller, but it should theoretically work. Again, the hub’s Z-Wave network will be overwritten. If it doesn’t work well, you can exclude the hub from the HA07 and it will create a new network.

If you try making the ST Hub a secondary could you post how it goes? I still haven’t had any luck with that option.

Duncan, could you please post some information on how to make SmartThings HUB secondary to a different z-wave hub, like HA07 or vera.

Thank you.

Thanks Duncan I’ll give that a try.


  1. Put the other controller into include mode (or transfer network info or whatever they call including a controller, it should be in the manual)
  2. In graph.api.smartthings, go to your hub page -> Z-Wave Utilities and click “Join/Leave another Z-Wave network”
  3. it’s completely up to the other controller to find the SmartThings hub and transfer all its network info to our hub, it can take a few minutes

That’s it. Remember that any Z-Wave devices in your SmartThings will be disconnected and have to be excluded before they can be rejoined to the other network.

If you do this, don’t call support and bug them about Z-Wave stuff not working quite right. This is a non-standard way to use the SmartThings hub and isn’t often tested when we add features.

1 Like

I have managed to setup a secondary controller - but I think there may still be an issue with UPDATING the secondary when you make a change to the Z-Wave Network.

I have an OpenZwave compatible USB stick that is connected to a server running the free ZVirtualScenes software. That was my primary setup until I bought SmartThings. I used some OpenZwave utilities to shift the Primary Control over to my SmartThings hub. All went well for maybe 30 or so of my devices. I did have to go and add a couple of devices that did not copy over (I think something timed out before the complete transition).

So back to the UPDATE issue … there is a function in the software for my USB stick to receive an update from the Primary - if I add or remove Z-Wave devices. I can’t figure out how to send the update from the ST hub however.

Of-course all of this secondary stuff will become irrelevant to me when the ST team gets the Android app where it needs to be. Then I will no longer need my secondary PC server.

Thank you Duncan, I’ll give it a try.

@Duncan - I am using the Vizia RF+ installer stick as I have a 4 zone Vizia in wall controller that SmartThings does not know how to program the buttons on.

I removed all the devices from the SmartThings hub and set up a new network as primary using my installer stick. I then initiated a primary controller shift which the installer stick reported as successful.

The SmartThings hub changed its network ID to be that of the stick and the stick now reports it is secondary. The strange thing is that only 2 of the devices are showing as transferred.

When looking at the ST logging it still shows all the proper devices chattering so they are clearly assigned to the correct network ID. I even tried manually adding devices of the same type with the same ID via the web only to get a nasty duplicate ID error thrown back.

Clearly the missing devices are lurking somewhere. I would normally just re-pair but I’ve not found a way for the SmartThings hub to send an update to the secondary controller so if IDs change the switch will stop functioning.


So when you try to add the device manually it gives an validation error on deviceNetworkId. But you don’t have another device in your devices list with that same hub and network ID? That might be something we need a server person to look into the logs for.

You should be able to go through the add process with SmartThings without first removing them from the network to get them properly added to the database, but that probably won’t work either if manually adding doesn’t.

I’m assuming you have at least 0.10.* firmware on your hub.

I do have the latest firmware.

I removed them all using the utilities since I could not see them from the app. They un-paired and I was able to re pair them but as I suspected they changed IDs and this made the in-wall controller not work.

My latest method seems to be working well - what I call the Fleetwood protocol (aka Tell me Lies). I was able to use the network recovery tool from the Leviton program. It then assumes the installer stick is the primary controller, even though in the eyes of the ST hub is is still secondary from the network hand-off the first run. This makes the network programming feature active in the software and allows me to see all the devices and send updates to the in-wall controller.

Because the SH hub cannot send updates anyway this means I have to do a network repair scan if I add a device to the network that I want to program the in-wall switch to use. The ST app does loose track of the device dim levels here and there but shows status correctly most of the time. If the devices are turned off the switch is generally unaware and the light will stay on but at least the switch is working.

1 Like

I have a Honeywell L5100 Controller. I added smartthings hub as another controller to it. I needed to exclude all devices on both controllers. I then included all the devices I wanted on the smartthings hub first and then went to the L5100 controller and pressed include and it added all the devices from smarthings hub. I then named all the devices and can control and see all devices from both controllers. I have an Aeon MultiSensor which the honeywell L5100 really does not recognize but the smartthings hub does. So I can only view and do things with it from the smartthings hub.


Has anyone had any luck with getting SmartThings to see newly added z-wave devices from a primary? I successfully setup SmartThings as a secondary controller, but I’ve added a z-wave light switch to my primary and I can’t get it show up on my SmartThings…

Z-Wave primary controller does not automatically update secondary controllers when you include/exclude devices (unless there’s a SUC/SIS controller in the network). You’ll have to do manual copy which of course sucks.

1 Like

by ‘manual copy’ do you mean, remove and re-add the secondary controllers?

I suspect this feature is no longer functional. I’ve been trying it over and over and the result of clicking the “Join/Leave another Z-Wave network” option is exactly equivalent to not clicking it:

  • I click “Join/Leave another Z-Wave network”
  • It says “Z-Wave learn mode initiated for 8 seconds” on the web browser
  • Nothing visible happens on my hub (the solid green light stays solid green)
  • I initiate a secondary transfer on my GE controller (SETUP > TRANSFER > SECONDARY > ALL)
  • It says “SENDING / SETUP WAITING” on the screen for a minute or two and then times out without displaying the usual “SUCCESSFUL” message.
  • When I reload the web page for the hub, nothing has changed.

I’ve also tried transferring from a Nexia hub, with the same lack of anything happening. Is this still working for anyone else?

I am able to get the ST to be a secondary controller when using a Leviton controlthink stick, and set up my network today. I am not sure polling the zwave devices works as they mostly go inactive a few minutes after rebooting, but they did all transfer to the ST hub correctly.

I am unable to use the Aeon Z-Stick S2 stick and get the same symptoms as masto above, so it appears that the type of primary wave controller matters. Hopefully they can get this sorted.

With over 30 Wave devices all round my house in the wall, I don’t see how I can reliably use the Hub to add them (I did it once and it took ages to add each device, and then when I made the stick secondary so I could program some in-wall scene controllers only a subset of the devices were transferrred out of the ST hub, so I’ve gone back and made the stick primary and use the ST hub as secondary).

@domabo, When you did the transfer to the ST hub, did you get a blinking light or any indication that it was in a special mode?

No blinking light on hub. Solid green (unlike when in inclusion mode). My stick does blink when its transferring so I did see that of course.

Unfortunately it’s still not a great solution. After adding names, icons and sorting into groups, I added one more device on the stick, and looked to update the hub. I tried the update function on my stick, but it failed, which meant I had to exclude and then reinclude the hub which deleted all the prior work and I have to start over with the customization. I wish there was an API or something I could use so I could least update from a csv file or something.

It would be great to have more “central management” of Z-Wave networks. It’s such a pain to walk every controller around to every device. Anyway, I don’t really even care if it works well, I was just hoping to use this as a way to “reset” my network and start over. There’s no way do to that (I’m hoping support can help on Monday), but in the meantime I thought this would be a workaround.