Where’d the widget go? (18 June 2021)

I did the update and now my widget is gone!

1 Like

Did you go into edit widgets and make sure smartthings is selected?

Tagging @Automated_House for insight as he just got his working again

Yes, but it’s not an option there. :man_shrugging:t2:

The widget type changed from the pre-iOS 14 widget type to the iOS 14 widget type. Are you looking for the widget in one of the locations described by Apple? Use widgets on your iPhone and iPod touch - Apple Support

Previously the widget would be added from the Edit → Customize option at the bottom of the Today View.

SmartThings just isn’t an option on there.

Hmm. Do you see the widget settings option (menu → gear icon) and have selected scenes?

I don’t have it or see it any longer too, even tho the widget option is available in the new app

So weird. Finally it showed up after rebooting my phone & closing all apps.

1 Like

Same for me - iphone reboot and the new ST widget was there to add.

i managed to add the widget but its a joke instead of running the scene only it opens the app and then runs the scene. any ideas why they have done this ?

So why are we now only able to house 4 widgets at a time? what is happening - before we had the option to select from many (~16+) then later we got capped at 8 and now it appears with this latest update we’re only able to hold 4 widgets at a time from the iphone sceen? why is this or is there something the iphone isn’t handshaking with in smarthings?

It’s so stupid. It just gets worse & worse.

seems the samsung QA dept only releases a new version when they ensure its much worse than the last

Anyone else having the problem where the Smartthings Widget just never shows up in the list? Restarted iPhone 3 times. I’ve got all the newest versions of iOS and Smartthings. I’ve tried everything and the widget is not on the list. I’ve tried both the old and new way of adding the widget.

Two more restarts did the trick. That seems really stupid. Now if they would just bring the Apple Watch app back.

1 Like

See the following:

that isnt the case, tp link has a widget and it does not open the app. just controls the device.

As far as I can tell, it’s up to the app writer right now as to which version of the widget they are using. If they are using the pre-iOS 14 version, then it is actionable. But once they update, it won’t be.

I’d be glad to be wrong on this.


The Kasa widget uses the Today View widget that is pre-iOS 14. You can tell the difference mainly because you can’t add their widget to a home screen panel.

1 Like

thanks! alas you are right! there was me blaming samsung for the dumbest step backwards ive ever seen. so the wiget is now a glorified open app button, what were apple thinking?

looks like samsung have tried to mitigate this by adding a favourites home screen on their app so you can still manage to run a scene with two steps. instead of the swipe right click widget. its now open ST click favourite. highly irritating