No iOS widget

Hi guys, I am using Smartthings hub wifi and iOS app to control the hub.

However, I cannot see a widget to add to the widget screen. Like I just cannot see a widget at all.

I have even gone into the app settings and selected my favourite scenes. But no luck. I have also tried deleting and reinstalling the app.

There is no widget showing up at all.

Any help please. Thank you.

On your iOS device, have you clicked edit below the widget screen, clicked on customize and selected SmartThings to appear in the widget screen?

Yes I have tried it but it doesnt show up in there. It’s really weird. I have also tried turning the phone on and off, but no luck.

Just checking…

In menu > settings > widget > you selected 8 or fewer scenes and they have a blue check mark to the right and you clicked Save in the upper right of the screen?

Just checking in to see if this has been resolved. I’ve never been able to get widgets working with the new app. 2 scenes created and selected and it just doesn’t appear anywhere and doesn’t show up in a search.

deleted and reinstalled app
Removed and re added devices
Tried new devices
Power cycled

Bought a new phone!

I’m out of ideas at this point. I’m getting really frustrated with all the things that should work but don’t.

I think I figured this out. I was having a problem after installing the new app and updating it. You no longer can add the widget by clicking edit and then choosing customize on the iOS widgets screen. You have to hit the plus in the upper left-hand corner and then scroll all the way down and find the smart things widget. It’s fancier and stuff that way I guess.

I am now getting the widget, but most of the time the shortcuts don’t even show up within it, just a big button to open the app.

@Automated_House Pointed out in another thread that it is Apple that has changed the behavior of widgets, so that most regular widgets now do open their app. Annoying. :rage: But It is smartthings that made the decision to cut the number of scenes on a widget from 8 to 4.

The alternative is to use Siri shortcuts for apps that support shortcuts, but unfortunately, smartthings does not. shortcuts are nice because you can add them to the home screen and you can add them to an Apple Watch. And they don’t have to open the app.

If you have an IFTTT pro subscription, IFTTT does work with webhooks, so you can make it work that way although it’s annoying.

You should also be able to use the webhook method with webcore, I just don’t personally know how to do that.

The point is once you can get a shortcut created in iOS, you can add a widget-like button for that on your home screen or add it to your Apple Watch.

I know that feels like way more trouble than it’s worth. If you contact smartthings support about widgets, ask them to add iOS shortcuts as an alternative.