Where are all the V2 Excitement Posts?

Nothing prevents someone from opening the Garage Door, just like nothing prevents someone without SmartThings from turning on their lights via switch, unlocking their doors with a key, or using multiple remotes to control different vendors’ devices for media activities. However, with the exception of the challenges faced by those like @JDRoberts, most of us are interested in HA because it allows us to make something already easy even easier. SmartThings did a great job of that with the combined/sensor button in v1 at a little more than half the price of the Chamberlain. Further, nothing that was advertised about v2 seemed to imply this functionality would be lost. So I think those of us who used it are curious why and wish it were back.

1 Like

So want Something like this? :wink:

u

3 Likes

Sent ya a message showing ya what I mean so as to not completely hijack this thread.

1 Like

So, I finished my switchover to the V2 hub this weekend. It was about as tedious as I expected. Deleted all my smartapps/routines, then went around to my Z-Wave switches and excluded them all. That whole process feels kinda sketchy, but in the end I was able to get them all removed except for 1, which I was able to exclude using the new hub.

I was not able to delete my location, even after removing everything. I e-mailed support, and they took care of it the next day. In the meantime, I went ahead and created a new location for the new hub. Then began the process of re-adding everything. The Z-Wave switches were easy. The Zigbee devices were annoying, especially my PEQ motion sensors. You have to take the battery out, then use a pen to hold the tiny reset button while putting the battery back in to get it into discovery mode. All this of course while I’m on a stepladder because my sensors are all on the ceiling. From there, it was a matter of recreating all the modes, routines, and smartapps.

My other 2 users are still listed under my account. I have not attempted to open the app on their phones to verify I can create presence sensors based on them, but it seems like it will work.

I have just 1 main issue after everything. There is apparently a bug with SmartLights where dim levels aren’t working in automations. You can set them up (i.e. "Turn on and set to 30%), but the hub totally ignores it and just turns the light on, which turns on at whatever last % it was at the last time it was on. This is a fairly crippling bug to my lighting automations as I change dimming settings quite a bit between day and nighttime. It’s really awkward to have lights go to 100% in the middle of the night when I have to get up for something. My workaround for now is to have a routine that sets the lights to the desired “nighttime” percentage, and I run that right before running “Goodnight” but it’s still really awkward and limits what I could do before with lighting rules. Support said they’re working on the issue.

Otherwise, my impressions are positive. Switches do seem to be snappier with the new hub, so hopefully this will give me the improved reliability I was hoping for.

1 Like

This should be fixed soon :smile:

4 Likes

Here’s my excitement post, great experience so far!

2 Likes

I noticed the same thing. After I set up everything I went into each light and manually set the dim level. I then hit refresh and it worked just fine. Even after I would change it for something else, the smart lighting app would set the right level each time after that.

Oh, and I would hit the refresh with a long hold, just to make… Several times.

I agree with @smart,

How about this?

Hint! You Press the BIG GREEN button at the top of the room!

Also, set the Primary device for the room to be the Tilt/ST Multi Sensor.

You can’t press the big green button if its just a multi and not a SmartSense Button. Its the button devicetype that gives you that functionality when using a multi-sensor/relay combo vs a myq device. Further if you put it in Doors and Locks you can save yourself a click or two getting there.

It work for me.

Agreed on this!


Make the following changes to your Z-Wave Relay and your ST Multi Sensor Device Types:

Doors and Locks, along with all other shortcut groups, is not supported in the V2 version of the official smartthings mobile app. If you have it, you only have it because you had it in the V one version and it transferred over with you. Once you remove the last device from that group, you cannot get it back again. And new people just starting with the V two app will never see it at all.

1 Like

Agreed @JDRoberts.

For all New Comers to V.2 Hub/App, and want to automate your Garage Door/Gate you can check out my updated automation which includes the new Room addition for Garage Door/Gate:

Moved my hue bridge over to hub 2 today. I read all the horrors stories about errors and such. Not for me. Maybe I am lucky. The other nice thing about hub 2 or apps 2. It even brings over the hue bulb custom names. How cool is that.

2 Likes

It’s one of the best integration now from the worst. ST certainly did a great job with this.

1 Like

Yep, literally everything worked right out of the crate for me. I haven’t even needed to get intimate with graph.api! I’ve just poked and prodded around to see what’s there otherwise everything is just stock.

Yeah, I’ve read all of the horrors stories too… I’ve had zero problems.

It looks to me as if the ones that are really having trouble are the ones that came up from hub V1.

I did a migration from V1 to V2 and with the exception of platform issues the day I started the migration it was smooth. It was time consuming but I enjoyed going through and optimizing my setup.

1 Like

My excitement is that almost all timers are not working in any smartapp.

Gentle wake smartapp, fails to trigger by time 100% of the time. if I manually fire it, it works great. so now I need to set up an external device to trigger it as it seems that timers will be broken for a while.

Try uninstalling that one and starting over. I have two instances of that using the same devices and they overlap in time… they fire and work perfectly every day.

I will give it a try. It is the only timer smartapp for that lamp I have and it worked perfectly when I was on the V1 hub.

In fact I’m going to delete all timer apps and only reinstall that one.