What is going on here!?! (Multiple device failures)

I’ve seen this happen if you have multiple Sonos devices - not sure if that’s been fixed or not.

I’d email support and get them to look at the logs from their end, hey light be able to pinpoint the issue


Just emailed this post to support. I only have a single Sonos speaker connected to SmartThings and it has been connected for a couple of weeks with no issues.

Nothing added in the last day or so when this issue is happening suddenly.

I assume you also have the batteries out of the hub when you are unplugging it?

Correct. I actually chatted with support for a while today. They are looking into it and when I am home with the hub I am going to touch base with them and do some hands on troubleshooting.

1 Like

Still having issues. Things were working pretty well for a few days and now I am getting:

“Failed to update mesh info” and /or “Failed to update route info” for all z-wave devices.

I have reset the hub multiple times and z-wave repair multiple times, no better.

The odd thing is the devices still work, they are controlled relatively well in ST. But obviously something us up with all of the repair errors.

Look for the device that’s throwing the error and run a replace on it. Then run again zwave repair until you get it to complete successfully. If the device name is not something you know, it could be named something like E4 or a letter and a number, then you have a stranded device. Contact support they may be able to help. If you recently attempted to remove some zwave devices, then put them back in because those left zombies behind. Been there done them all and is no fun. Good luck.

Also check this thread:

Unfortunately, the OP says that the error message is being returned for all zwave devices.

That’s unlikely to be a ghost device problem.

The OP is already talking to support, which is a good thing – – this looks like one which will require their involvement.

Exactly, it’s pretty much all of the devices. And as I said, they work, but when I do a repair I get those errors…

Can you post the detail log of your failure.

Didnt get quite as many this time, but at least like this:

Some of those failures are in the same room as the hub and work just fine turning on and off through the app

Ok, so you only have 6 zwave devices in total? Regardless, I would start with your Porch outlet and run a replace and/or a power cycle. Is the porch outlet by any chance a GE waterproof black box outlet?

I have more z-wave, earlier in the day even more failed. I have maybe 10 z-wave and equal amount of ZigBee. Just started the process a couple of weeks ago! That’s why it’s frustrating that they aren’t working well, not that complex a setup…yet.

When you say power cycle you mean just turn it off and on at the outlet itself? It’s an in wall GE outlet. There is an outdoor one but didn’t fail that time around…

The reason I was asking if it’s an outdoor module, because my horror story with the whole mesh going unresponsive started when I tried to exclude one of those. What I mean by power cycle, is cut the power to the devices. Unplug the outlets or pull the tab on the switch, or flip the breaker for a few minutes. If you do the breaker, you may end up needing to pull the batteries in your zigbee devices as they may get stuck.

Should I do that for all the devices?

Its so wierd, so I just checked the logs because I was going to try another repair and I see this error:

Aeon Z-Wave Metering Switch [13]: Not responding

I go to the switch, hit on in ST app, and it works just fine on and off. So why is it throwing an error out of nowhere. That switch isn’t even in use I just have it plugged in as a repeater…

UPDATE: Tried another repair just now:

Isolate the device that doesn’t respond to commands from the mobile app. If you only have repeaters, do a replace on them. I have seen this behaviour with my Iris outlets. Some just need a power cycle

Ok will try.

I had 4 iris smart plugs set up as both ZigBee plugs and Z wave repeaters. I ended up removing the Z-Wave repeater part of them because I think they were messing with my system.

Update: tried everything, they all work. Which weirds me out even more…

You probably ended up with stranded devices after removing the iris outlets. Support may be able to see them and delete them. But if they cannot, their response will be that you no longer be able to run zwave repairs. If you are perfectiomist like me, then you need to reinclude the deleted repeaters and then exclude them properly or keep them on your mesh.

Thanks for all of your help. I am a dentist and I would no be ok with no more repairs. I want this system to run perfectly with no errors!

Will ask support tomorrow about any ghost devices.

Adding back the iris repeaters and removing them again sounds like a nightmare and I did remove all them properly even if it did take forever!

I hope they find and delete the ghosts. If not, your last resort is to include/exclude again each of your removed outlets. The ghosts then, will be deleted automatically. I know how frustrating this is. Good luck