What happened? Can't save a thermostat control app. Error in the description

I noticed it was very cold in my house, and I usually fix this by re-saving the app. But starting today at some point, I get a message that says cannot save default page. Looking at the Live logging the error is below
error groovy.lang.MissingMethodException: No signature of method: script14504715485442020617704.attribute() is applicable for argument types: (java.lang.String) values: [thermostatFanState]
Possible solutions: attribute(java.util.Map), attribute(java.lang.String, java.lang.String), attribute(java.lang.String, java.lang.String, java.util.List), tileAttribute(java.lang.String), attributeState(java.lang.String) @ line 12

Edit: tried to just update my thermostat with the things app for the thermostat. and i get the same error. When that device control issue showed up around 30 minutes ago, did we lose some of the api or is the issue still going on?

I am having the same issue and the same error code. I lost thermostat communication around 1:30 MT. I was using the stock ST Z-Wave Thermostat device type fro my CT100. I tried a 15 min hub reboot, no help. I changed the device type to @RBoy Thermostat and it was communicating, but the app UI was crippled. Tried changing back to original device type and got:

Error 500: Internal Server Error
URI /device/update
Reference Id 2371a3b6-3c0b-4daf-a97f-90b3ab2c5451
Date Fri Dec 18 23:22:28 UTC 2015

Put a email into support, don’t expect answer very soon, but you’re not the only one.

Same issues here:


  1. The UI is crippled due to the buggy Android 2.0.7 update and I’ve posted a workaround for it here:
    [RELEASE] Enhanced Z-Wave Plus Thermostat (CT30/CT50/CT80/CT100/CT101/CT110/ZTS110/ZTS500/GoControl/Honeywell/Universal) Device Handler with Battery, Humidity, Clock Set, Alarm, Swing/Temp, Deadband Configuration and Updated User Interface
    DO NOT update to 2.0.7 Android if you want to use the new user interface on the devices. They broke it.

  2. For the error you mentioned, this is a platform error, report it to ST and just try again after a while (few minutes or hours) and it should work fine.

@cjm3407 your error looks like you’re using the wrong type (you’re trying to create a device type from create smart app page)

1 Like

Is breaking routines, so let the fun begin! (the generic/ official z-wave t-stat is)

1 Like

Thanks for the quick response! Unfortunately I made the change, saved, published, didn’t work. Went into edit device type and updated, still showing a big question mark. When this problem started, I did not have the question mark, just an unresponsive device.

I’ll give it some time to heal and try again. Do you think I need to remove and replace the device?

The point is i haven’t changed anything. The issue that popped up earlier with smartthings has broken something.

Same here, I only started the changes after it broke. It seems to correlate with the new app update. Just making the changes to try to get it working again.

Seems like it has been fixed.

Mine actually never stopped working…weird