WeMo set-up in UK


(Gary Coombs) #1

Hi,

I’m new to SmartThings, so please excuse my early lack of understanding!! I bought the starter kit yesterday and have successfully paired in my Sonos system along with the motion sensor and door open/close.

I do have a Wemo plug already which I use in my office for turning on a plug in radiator. I would default to using IFTTT, but that doesn’t seem to be available in UK yet. I understand WeMo isnt fully supported yet in the UK, but I was advised to go through to the developer area (https://graph-eu01-euwest1.api.smartthings.com/). I have located the device type code for Wemo and published my own version, but I am failing in how you then pair the device?

Can anyone help. Really appreciate it.


(David Tucker) #2

You also need to publish your own version of the WeMo Connect smart app. Then run the smart app from the My Apps section of the Smart Apps marketplace in the SmartThings Mobil App. This should initiate a search for WeMo devices on your network.


WeMo device types not appearing in 'new device' list
#3

In the IDE go to smart apps and choose add smart app. Choose from template then look in the list on the left for Wemo (Connect). Select that and save. Then go into the app on your phone. go to the market place icon, scroll down and find MyApps choose wemo connect and follow the instructions. Make sure you have setup your wemo switch and the wemo app on your phone first though.
I am in the UK and have been using the wemo connect smartapp for a month now with zero issues.
Have a look here http://support-uk.smartthings.com/hc/en-gb/articles/204784341-Connecting-Belkin-WeMo-to-SmartThings it gives some iformation but i thinks its outdated now.


(Marco) #4

Hi Hugh,

thank you for supporting me in the process with Wemo Switch.
On my mobile app I run the my wemo (connect) smartapp flagging the wemo switch discovered. Unfortunately I don’t manage to terminate the process as error is returning: “Failed to save page: firstPage” . any thoughts about it? Thank you in advance

Marco


#5

You are welcome ;). Is it a normal switch or an insight switch. I don’t think insight switches are working yet.
Ok so in the ide you have the smart app and the device type added?


(Gary Coombs) #6

Thanks @HughB and @djtucker for quick responses, I’ve got it working. Really impressed as was able to do it remotely!


(Marco) #7

Ciao HughB.

It’s a normal switch. I didn’t add the device type in ide (what would be the Device Network Id, in case?) but the smart app recognized the presence of the wemo switch during the installation. Once selected it I don’t succeed to save the process.

Thank you again for you support

marco


(Marco) #8

Again,

when I try to link the wemo switch to smartapp by way of ide insted by way of mobile app the log returns this: java.lang.NullPointerException: Cannot get property ‘value’ on null object @ line 230

Marco


#9

There are two types of custom code that can be installed through the IDE: smart apps and devices types. It sounds as though you may have used one for the other.

This FAQ should help:


(Col) #10

i’ve gone through the create/publish from Wemo (Connect) template, when i run the app i can find my wemo switch but when i select it and click done i get an error: An unexpected error occurred.

java.lang.NullPointerException: Cannot get property ‘value’ on null object @ line 230


#11

Hi, I was having the same issue as described - I couldn’t connect my Wemo switch thought the Smart Things app.

I had setup my Switch in Wemo app, connected to my Wifi, it was working through the Wemo app. Perfect. Now to setup ST.

Thanks everyone for the steps, but I was still having problems.
I’d found the IDE, logged in, created the new Smart App from the template as described. I didn’t need to change the type, not that I could see this anyway…?

I eventually found that you have to edit the newly created smart app and add the location. (Edit your app by clicking the name, then on the right, click “Set Location” then “Save”. Boom - good so far.

As soon as I did the first part, immediately underneath I was seeing my Wemo switch from the IDE, but I couldn’t “install” it. Each time I installed, and saved, it said:
“java.lang.NullPointerException: Cannot get property ‘value’ on null object @ line 230”

Solution…
Do all of the above, but don’t try to install the device from the new Smart App after setting a location.
Go to “My Devices” and add a new device, using the Wemo Switch “Type” - add the MAC address of your Wemo switch as the Network ID (it’s on the back of the switch).
Now go to the ST app, go to “Market Place”. At the very bottom you find the “My Apps” section and find the newly created “Wemo (Connect)” app. It will find your device and you can add it into your “Things”.


(Mel) #12

:scream: what a nightmare getting this installed. You have done well figuring all of that out. I tried following your instructions but have given up. Will pay the extra for a Samsung power outlet!


(Ule) #13

Hi , This is a wemo connect smart app and devices handlers, it has a timer check, try it