Wemo Problems Since Last Update

Since the last update my Wemo Motions no longer function properly or really at all. Also my Wemo switches work but do no show the proper status in the app unless you refresh them a few times.

1 Like

@tgrant48 are you still seeing the issues as of today?

I haven’t had WEMO issues in a long time, but somehow they got added to ST (I’m guessing the new update captured them when I added a device and I missed that fact.)

Today, I found that they all showed on in ST even though the (WEMO) schedule should have turned them off. So I tried to turn them off in ST. When that didn’t seem to work I opened up the WEMO app and they spun for a long time before showing “offline” in the WEMO app.

After a hard close of the app and allowing at least 30 minutes to pass, they have come back in sync in the WEMO app.

If the devices are out of sync in the Wemo native app, it is possible that device may have connectivity problems. ST integration only refreshes the subscription with the device, once per hour. So there is nothing in the integration that could cause the connectivity issues.

Just a coincidence then that I started to have WEMO issues after they were added to ST. BTW, I don’t believe in coincidences…

I’m still having issues - their status doesn’t update in the ST app. It’s therefore causing my automations to not work because ST thinks the switch is off when its really on.

@whyintheworld I am not asking you to believe in coincidence either. As an engineer you are trained to investigate every possible angle. That is the only reason I am asking you if the issue is limited to the ST integration (issue that we are tracking) or whether the issue also exists in the Wemo app (which is the first we have heard of)

@RobMan looking at your issue right now

@workmonk Just was typing with Ethan at support. Same issues with my 4 Wemos. I even removed them and added them back to SmartThings. Still no luck on reporting proper status. Hope this gets resolved soon.

Hi @staticfade
Have you allocated a static IP Address to your WeMo’s?
I’m just interested as I used to get lots of issues with mine, not with ST ironically but in the WeMo app.
Allocating fixed IP cured it for me.

1 Like

No I haven’t…I certianly can give that a try though. I have had the Wemo(Connect) smart app working for a very long time and never had the issues of reporting status correctly like this. While talking with support I even tried removing the wemos and adding them back…but no luck. I will give that a shot…but hope that isn’t the solution

It was over a year ago I allocated fixed IP.
So it may not be the reason in this case.
Just thought it might be worth a try.
My devices are also on SLC now from WeMo (Connect).
No issues with either DTH allocated to the device.

Excellent…I am definitely going to try this…do you by chance use the CoRE Piston app with the Wemos?

Yes I do.
I can turn off in the WeMo app and the status changes in the ST app and visa versa.
Also if I turn off in the WeMo app and the status updates in the ST app, a piston I have which turns the Insight or Switch on, then sees this and turns the Insight/Switch back on. So it is reporting status updates OK to both apps.

Have been busy and away from home all day.Will let you know later.

I came home and they were not working so I decided to remove them (wemo motions) and reinstall once again. So far so good. After several tries they are turning lights on with motion. Stay tuned until tomorrow. I will try the wemo switches next. They were working but not showing properly in app. I.e. Turn off, switch goes off but icon either still showed on or “Turning Off” until one or more refreshes

Mine started working again yesterday afternoon… I do have fixed IPs for the Wemo’s but still had the issue prior to yesterday.

I don’t use the Wemo App anymore. I don’t even have it installed anymore. Is that a problem?

Should be no issue with that.