Wemo light switched stopped refreshing


(Bertan Aygun) #1

Since the last app update, my wemo light switches stopped refreshing. The device state will refresh correctly if I force a refresh through the device screen but won’t update state when I use the switch itself.

I noticed that Smartapps no longer list a Wemo app but can’t remember for sure if there was one or not. I tried removing and adding the switch again to no help.

Do other see the same issue? Is there anything I can do the work around this?


(Andy Walsh) #2

Same for me since the update. Not figured out a work around so will have to keep refreshing I guess. Hopefully a new fix will appear soon.


(Joel W) #3

Report it to Support, I did and I hope all the other people using WeMo do also.


(Joel W) #4

I also am taking a chance using Pollster to keep the WeMo awake. Not sure it will work, but worth a try.


(Bertan Aygun) #5

Pollster works to refresh but it is not instantaneous so is not useful in
all cases. Maybe this is a opportunity to change it with a zwave switch :slight_smile:


#6

More here:


(Derek Scritchfield) #7

Disabling device health seems to have resolved the issue with mine


(Joel W) #8

Pollster is a bandaid, but it doesn’t have to Poll every second, I also stopped Health check, which is a major part of the problem.


#9

My Wemo also stopped refreshing, please excuse my ignorance, what’s “health check”? I haven’t updated the app, do I have to update to see it?


(Bertan Aygun) #10

This seems to have worked for me, after I removed the device and added it back through automatic discovery the state gets updated correctly now. Note that it didn’t work before when I added it manually.


(Joel W) #11

In your situation, like others have said removing and adding back might be the only solution. Health Check is part of the most recent release of the IOS and Android app.


(Andy Walsh) #12

Yep will do.


#13

Thanks for the reply, I don’t want to update the app because I heard it’ll enable auto discovery which I want to avoid. I also have to many wemo devices to delete and add because I’ll also have to delete and reprogram all the associated smartapps. I guess pollster is what I’ll have to live with for now


(Joel W) #14

Are you using Super LAN Connect Beta? If not try to contact the beta team, it might help also. The new update might have that installed, but I didn’t hear from Beta that it was. If you do update the App, and WeMo connect disappears then it is installed. I just wouldn’t turn on Health check.


(Bob) #15

Hmm. This is strange.
I have one Insight and one Switch.
If I have the room open and press the button on either, the ST app updates immediately.
If I turn on using WeMo app, ST app updates immediately.
Both my WeMo’s are using SLC and I deleted WeMo (connect) and WeMo Advanced (connect) from my DTH area.
I’m using a Galaxy S6 and the app is at 2.3.1.
I also have health check on.
Not sure if all this information is of use but just thought I would relay it to you.


#16

I have Health Check on.


(Joel W) #17

I have SLC, as soon as I turned Health Check on my WeMo stop responding or updating I turned off Health check and it seemed to help, but still updating is slow. What is really strange WeMo is working in ST but WeMo app can’t find them. I wonder now if this is a Belkin problem.


#18

Submitted a trouble ticket last night, haven’t heard back from smartthings. I hope they’ll resolve it soon.


#19

Update this afternoon:


#20

Same issue here. Reinstalled all wemos and disabled device health. This did not resolve the issue for longer than an hour.

This is brutal. How is it that SmartThings rolled out an update with features no one asked for and in the process broke a functionality that is fundamental to the platform operation??