Welcome Code is Invalid


#1

I have a brand new SmartThings Hub straight out of the box and when I go to set it up I am told “Your Code is invalid”.

I have already done the hard reset suggested which didn’t help. I have the code which was in the box.

I have many smart devices connected to use with my Alexa and this is without a doubt the most difficult thing with the most pitiful instructions. Why isn’t the welcome code printed on the hub? Why doesn’t the instructions in the app tell you where to find the welcome code, instead of forcing me to the internet to find out that info. Why doesn’t this crap device connect up easily like all my smart outlets, lightbulbs and switches?


(Mark) #2

You should communicate directly with support via email, chat or phone. Probably the fastest way to figure out why you’re getting that error.

FYI the ST hub is very different than a standalone bulb or switch that connects to wifi and can be controlled by Alexa. So its setup process is different; obviously it shouldn’t be doing what you’re experiencing though.


#3

I would love to talk to support. However they’re open the same hours I work, so who knows when I’ll be able to get to them. It would be lovely if they had at least chat available out of the standard business hours.


(Chris) #4

Let’s get that “crap device” connected. Check your DMs


(Kevin Laird) #5

I have the exact same issue. Invalid Welcome Code. Can I get a fix as well? No word back from Samsung so far :frowning:


(Joe Anonymous) #6

Exact same issue. New Hub v2. Plugged in, watched the LEDs change colors. It appears to have updated firmware, solid green light. Tried the Welcome Code using the latest version 2.3.8 Android App and it rejects the code. Tried the factory reset, watched the LEDs, same outcome. Did another factory reset. Removed all power, including batteries. Verified code on card was same as code in battery compartment. Downloaded the Windows app, tried from a Windows phone, same outcome. It’s sitting there, stupidly with a green LED, but won’t it won’t talk to anything.


(Mark) #7

Open a ticket with support.


(Joe Anonymous) #8

I did. First I got a reply asking for a picture of the serial number. In response to sending the picture I got a further response that said "Sorry to be the bearer of bad news. This hub is actually not able to be set up. I am very sorry for the inconvenience and we are currently trying to fix this issue. We ask you to wait through the weekend for a solve, but you are more than welcome to return this device. We will definitely get this working for you if you bear with us and you won’t be without a working Hub for very long."
While I appreciate the prompt replies, they didn’t actually do anything to resolve the issue nor inform me of what the possible fix might be if I wait through the weekend. It’s Memorial Day, btw, so does that include Monday?


(Mark) #9

Wow that sounds kinda terrible. Maybe someone from customer support like @Brad_ST or @Aaron can help.

Unfortunate timing with the holiday weekend, too.


(Joe Anonymous) #10

A follow-up response included: "There is a good chance that we will replace the Hub for you, but the developers make the call once they determine the fix. I am limited in what I can disclose, but yes this is a new issue for a few of the Hubs that we have seen. Sorry I cannot tell you more at this time."
All I wanted to do was install a set of LED strip lights to replace two sets of halogen motion detector lights that burn-out with increasing frequency and create bright spots and shadows. But the LEDs require some form of hub or control and rather than go with a single-purpose Sylvania, I opted for a SmartThings hub. And the accompanying smart phone app, and new accounts and log-ins and passwords.
Isn’t this technology supposed to be mature by now? I suppose I can use tiki torches. I’m pretty sure I’ve mastered fire as a technology, and I don’t have to wait for the developers if I have trouble with a lighter.


(Mark) #11

In many respects, no. Although it depends what exactly you’re referring to. The ST hub supports multiple home automation protocols and has a lot of cloud processing so is prone to issues in many more ways than a single-function hub like the one that controls lightify bulbs and LED strips.

This problem with new ST hubs not working has been reported by several people in the last few weeks. I haven’t seen any of them post the responses from support like you did. Certainly seems like something is weird is going on.

ST can do a lot of great stuff but it’s often plagued by different reliability issues. This seems to be a new one in a long list.


(Ali Haroon Sheikh) #12

I have the same issue, my welcome code is invalid, can I please know how to fix this


Invalid Welcome Code
(Mark) #13

See above.


#14

I am having the same problem. My wife set up the Smart Things hub app on her phone just fine, but when I try to do it I get the same “Your Code is invalid” message. What do I do?

As a side note, it’s crazy that the app’s setup process doesn’t even tell you what code it is asking for, or where to find it. I had to Google this to determine what it was asking for. It just says “ENTER CODE HERE” without anything more. The setup process also has a field for inserting your birth date but it doesn’t even tell you that’s the date it wants. There’s just a mandatory date field without any caption indicating what is being requested. I had to think for a moment about whether I should be inserting the current date or my birth date, which seemed like the only reasonable options.


#15

Was this card not included in the box for your hub?

https://www.samsung.com/us/support/answer/ANS00048957/

WelcomeCode

And here’s another link on the entire setup process


#16

Yes, the card was included and I do have the code. The problem is not that
it is impossible to figure it out – I did do so after scouring the hub
itself looking for a code and then searching Google after that failed –
but that the setup process is not user-friendly and could be significantly
improved by some incredibly minor, simple tweaks. In my case, I already
knew from my research before purchasing the product that I’d have to
download and set up the Smart Things app, so I got that going as soon as I
pulled the hub from the box and plugged it in. My wife actually removed
the product from the box so I didn’t see the card first. The point is that
it would be trivial to add something like “(included in package)” or “(see
card in box)” instead of a bare instruction to “ENTER CODE HERE.” The date
field point is just as crazy, not because it is a huge hurdle in the
process – again, I could only think of two logical dates that it could be
asking for – but because it would have been trivial to actually state what
it is that the field is requesting. This is about user-friendliness.


#17

I will have to disagree. The instructions are there for a reason and if they are overlooked, then you are shooting from the hip. Even if they were missing, a 30 second search on the support site gives you very explicit, detailed instructions, even if they aren’t perfect or intuitive for a first time installation:

These INSTRUCTIONS / DIRECTIONS are pretty explicit:


(Edgar Cantu) #18

I have the same problem, We buy a new Hub for our office and my coworker do all the configuration on her smartphone but when I try to add a new location on my app I get the “Your code is not Valid”


(Dominik) #19

Hi, i got my new Smartthings Hub (UK) today and ran into the same issue. Really bad, wanted to use the weekend to setup new smarthome.
Opended a ticket with support.
Can´t somebody from support explain, why this is happening and how to fix or prevent in the forum?


#20

As you said: I will have to disagree. Software and setup procedures should be self explaining without confusing the customer with too much information. But the information “(your) birthdate” instead of “date” (or not even that) or “Enter code here” instead of “enter welcome code from the buttom of the product / information sheet”, is just bad. This has nothing to do with the fact that the necessary information can be found somewhere online. Why the hassle if two more words can spare the confusion - where would be the harm in not having to go online or to go through the box? Right, there would be none.
Even for people who did all that and then want to add another device a few months later and maybe not having the box/information nearby anymore, whould be helped…