Weird app issues, all of a sudden. Dead in the water

SmartLighting and other apps seem to be affected by an issue that prevents updates and removal.

If I try to update any of my SmartLighting rules I get “Failed to save page: namePage” or “Failed to save page: mainPage”

If I try to delete a rule so that I can recreate it I get an exception. So I don’t have the ability to edit or remove a rule now which I discovered while trying to figure out why my my rules with “when motion stops…turn off” stopped working a couple days ago.

I have a few other apps giving the same errors. Most notably SmartTiles which I started troubleshooting as well because it has now stopped working around the same time.

SmartTiles is now giving:

{"error":true,"type":"java.lang.reflect.UndeclaredThrowableException","message":"An unexpected error occurred."}

I’m pretty much now dead in the water in many areas. Anyone else experiencing the same? I’ve contacted support already.

The platform is throwing that error everywhere. So when saving a page/app, if it occurs, that’s the result. Hopefully it stabilizes soon.

I’m having the same issue as of this morning… Smart Lighting apps did not fire, and I can’t change or remove at all… Getting errors.

Submitted a ticket to support. Should see a canned response in 2-3 weeks…

I was having this issue with the old version of SmartTiles. I updated to the latest version and the issue went away.

All the other problems still remain, but at least that’s one less… :smile:

SmartThings stopped communicating with my hue bridge, so I tried to remove it and all of the bulbs. The bridge removed, but the bulbs didn’t now I have half my apps that won’t remove and I can’t add he bridge again because of these errors. I opened a ticket and will wait the 2 - 3 weeks for a response as well.

I can only assume they are prepping for the hub firmware update which is happening tomorrow. If that’s the case, it sucks that their release management allows them to impact their live environment.

1 Like

I think some of the problems that you’re going to see come from trying to troubleshoot things, thinking that the problems are on your end, but in reality there’s probably very little that you can do. And yes, it doesn’t help that the status page says “everything’s cool”

I ran into some issues yesterday and started poking around thinking that it was Rule Machine or the TCP gateway. After a while I just stopped and started reading all the posts about people having issues with basically every component in the system, so I knew that there was nothing I could do.

Like I said, I’ve pared down my system so that there’s a lot of control but very little in the way of automation, so I can still have access to some of my stuff when things go belly up. The ST / TCP connection has never been bulletproof, so I’m already used to either using the TCP app or web interface, and that has been rock solid throughout the ST hiccups.

Yeah. I went the route of removing the Hue Bridge because thats what they have always told me to do in the past. It really sucks when this happens because I have to redo all of my automation. I am looking into other options to control my hue bulbs outside of smartThings just incase it goes belly up. Unfortunately I haven’t had time to develop the interface and purchase the hardware.

Yeah I did that like once or twice with TCP then I just gave up. You have to fish out all the apps that use your bulbs (SmartTiles, SharpTools, Rule Machine, etc) and remove them, then you have to delete the device, then the app, then start over from scratch. That’s probably the worst way to troubleshoot something IMO.

Of course it would be interesting if you could “export” all of these things and re-import them later, or have a “nuke” button that would remove devices from apps without having to spend 20 minutes at it, but alas that’s wishful thinking.

So like I said, after a couple of bouts of this I figured it wasn’t worth the trouble and I just use the TCP interface to manage TCP bulbs. In the event that ST decides to work with the bulbs by some crazy coincidence, then things are a little better, but I don’t depend on that happening consistently.

Dang, didn’t even know there was a new version. I’m very likely running the older version. Hopefully this clears up that issue. This at least brings my control panel back online. Thanks!

1 Like

Gee it sure would be nice if SmartThings would send out a notice that they are having problems. I’ve been down on various things for more than 24 hours. I saw another post on this forum where a rep said there are platform problems, but I still haven’t seen a notification from them.

I had the same with older version of smarttiles… but since I have my own copy of it I didn’t want to update…
I went back in the ide and edited the smart app and edited the oauth section (since the error is in the oauth code)
and just update/re saved it… and now it works ok and I can save .

I’m getting the same thing non-stop on trying to edit pretty much any smart app. Most routines no longer work. about half my automations are triggering. Approaching the worst it’s been since I jumped into ST. We’ll see what tomorrow’s update brings before I completely throw my hands in the air. However, right now it feels like a ploy by somebody doing metrics to show “significant fixes” with tomorrow’s build, by breaking that much more stuff right before hand!? i.e., the timing of all this failure is a bit weird… that’s all.

Based on past performance, I’m almost inclined to agree. The only problem with your theory is that tomorrow’s update is only for v2 hubs, but everyone (North America at least) is impacted by the current outage. :skull:


Like I said, it’s weird.

On another note, I tried installing the latest SmartTiles and still seeing the same issue. I was using the non-Connect version of the app. I guess I was a few versions out of date.

I’ll have to play more when I get home.

SmartTiles died because it was doing a couple of simple “runIn()” calls which depend on the SmartThings scheduler. We pushed out a temporary hotfix this morning to bypass those calls.

We’ll try to “catch” more errors to avoid fatalities in the future, but it is hard to predict what can go wrong. In general, you’re not supposed to have to check every single standard commonly used method provided by a Platform vendor. What’s next … try/catch on “println()”?

I have a few third party apps that are acting all weird for me also. My hue bulbs are unusable through ST. I had to work around those problems using IFTTT. ST is once again starting to aggravate the Family. My hobby may be nearing it’s end.

Thanks! I’m back up (on both versions).

1 Like

Seems ST has resolved the issue(s).

1 Like

Well how do fix this issue ? My smarttiles has become absolutely impossible to delete, even from IDE and it prevents me from deleting ANY device so it is VERY annoying. After the consistent logging off which lasted for weeks, now that… At the end this smartthings causes me more annoyance than anything else, and I’m not a newie.

Couple things:

  1. Have you contacted support? You say you’re not a newbie which very likely implies only support can solve your issue. I will assume you’ve taken care of all the “newbie things” like remove all devices from the app before attempting to delete.

  2. What error message are you getting? Can you elaborate?

@tgauchat @625alex

1 Like