Wayne-Dalton WDHA-12 doesn't connect, can I bridge two zwave networks?


#1

I’m having a hard time finding support for this. I’m trying to add my WDHA-12 to a Smartthings Hub v2 as a secondary controller. It only shows up as a zwave remote and I can’t do anything with it. No buttons to assign appear anywhere. I’m not interested in setting up ST as secondary, however following the process through “my locations” menus for this does not work either. ST app simply reports that it “failed”. I have verified that my WDHA-12 works fine with a zwave device independently of my existing zwave network.

So… has anyone been able to get this working?

My next approach would be to somehow bridge these 2 independent zwave networks using some kind of switch or relay connected to the WDHA zwave network and hardwired the output to a zwave sensor with dry contact inputs connected to ST on the other zwave network. Hoping that I could then trigger events on ST from a button on the WDHA.

Does anyone have any idea if this would work? Is there a better solution, maybe even a module that bridges 2 zwave networks that would bit more elegant?


#2

I have this device too, and one way I was thinking of getting it working would be to have the WDHA turn on/off a Z-Wave device directly (as a secondary controller) and this device would then indicate it’s status back to SmartThings. SmartThings could then do something with that status. I don’t have a Z-Wave device to test this with, though.

In the end I’ve decided to just put my own electronics inside and convert it to ZigBee, but I haven’t finished this yet.


#3

@rpress Your first idea was the approach I tried. Can’t get the WDHA to exist in the same zwave network as ST and operate as a secondary controller. And I can’t have a device connected to both WDHA and ST at the same time, so I can’t operate it by WDHA and monitored it by ST.

Did that make sense, sometimes my wife says I’m confusing :smile:


#4

The manual says it can be used as a secondary controller.
http://www.usdoorcontrol.com/instructions/waynedalton/wireless_gateway.pdf (page 11 and 4)

You tried that and it didn’t work? I’ve never tried it but it looks like it should work. :slight_smile:


#5

@rpress yes that’s exactly what I tried. WDHA “thinks” it’s become a secondary controller so that part works fine. ST however sees it as a zwave remote instead but whitout any features of a remote nor of a controller. So I’m left with the inability to add a device to WDHA (can only add to the primary) and the inability to pass the actions through ST to any device.

By the way, WHDA works great independently. I’ve connect Homelink in my Tesla and my Toyota both to zwave lights and switches in the house and garage. It reacts very fast.


#6

With the idea I’m thinking of, SmartThings doesn’t need to know about the WDHA at all, as long as the WDHA is on the same Z-Wave network and can control a different device.

Did you try adding a device to a scene like on page 4 (after it’s a secondary)? Maybe you’re saying that it can’t add a device to the scene when it’s a secondary controller? It looks like that should work according to the manual.

If it can add the device, then SmartThings will be notified when the state of the device changes (and not the remote itself) and you can trigger something with that. Clear as mud? :stuck_out_tongue:


#7

Yup, that’s clear but the problem is you can only have one primary controller per zwave network and you only add a device to a single primary. If WDHA and ST don’t work together then they can’t see the same thing.

I’d love to hear about it actually working but I think I’m stuck with the bridging idea. Add the “thing” to the WDHA and hardwire to a dry contact sensor added to ST. Extra cost for a sensor for each of the 3 buttons.


#8

Can’t you add a device to a scene that’s created by a secondary controller? I don’t mean join a device to a network created by the secondary controller. Isn’t that how all Z-Wave remotes work, they create a scene and you pair a device to that scene.


#9

Yes, I think that’s how it would work but only if the secondary controller existed in the same network and is seen by ST as a secondary controller. As soon as I add WHDA to ST, it becomes useless. It’s neither a controller nor a useful remote. And WDHA thinks it’s become a secondary so you can no longer add a thing to it’s scene. At that point WDHA has given up control to ST.


#10

This conversation spurred me on to do the ZigBee modification to my WDHA. It turned out great.


Using Homelink to trigger routines?
#11

@rpress can you provide any notes on how to accomplish a ZigBee conversion? If this give me integration with ST I’d like to try the same thing.
Thanks


#12

Yes I can give you the necessary info. I don’t have a lot of time as I’m moving soon but I’ll try to help if I can.

I wrote a simple device handler that works with SmartApps like Button Controller or Rule Machine.


#13

Oh and speaking of your Tesla, I also connected the OpenEVSE to SmartThings:
https://groups.google.com/forum/#!category-topic/openevse/networking/mZFD4SZgGvQ


#14

Here’s my modification: