Was there a change in how the level state is set in the zwave dimmer switch generic DTH when switch is turned off?

It’s entirely possible that I’m mis-remembering, but I thought at one point, the zwave dimmer switch generic DTH would leave the level state variable at at it’s previous value when the switch was turned off. Now, when the switch is turned off by any means (at the switch, in the ST app, through voice control, etc), the Level is getting set to 0. Though, In a quick look through recent commits to the DTH, I don’t see anything obvious that would change this behavior.

I’m currently pegging this as the culprit for an issue I’m having with turning on these dimmer switches with my harmony remotes. It appears that for dimmers, Harmony may be using a set level command to turn on the switch, and using the value that’s stored in the level state for the new level. So, if I just use the ‘on’ button on my harmony remote to turn on the lights, it sets the level to ‘0’, effectively doing nothing. I then have to use the level rocker on the remote to increase the level, thereby actually turning the light on.

I have a ticket in with Logitech already, but I kind of want to confirm that I’m not crazy and there was actually a change in the DTH behavior. I’m also not quite sure this behavior is appropriate. When the light is turned on from the switch, it will return to the previously set brightness value; however, by setting the state variable to 0 in ST, there’s no way to keep track of what that value is from within ST

I can’t confirm this, but I can confirm the behavior you are seeing. I believe it is a bug with the hub firmware.

1 Like

@tgauchat’s like of your reply reminded me that I hadn’t tested actiontiles yet. Of course, it still works fine there as well, meaning pretty much every other integration (alexa, google assistant, actiontiles) is handling things the logical way by just issuing an on command. While Harmony is using an overly complex method. Hopefully, something will come from my ticket with them

1 Like

I can confirm the the harmony app and remotes did this problem originally with the CentraLite Smartthings dimmers, but the GE/Jasco dimmers were fine. That all changed with the last update. Now neither work. I contacted Harmony about the CentraLite dimmers, but they said they could not duplicate the problem. I have a ticket in with Harmony about the GE/Jasco dimmers but, they keep saying it works fine on their end.

Here is the log file when I try and turn on the dimmer via Harmony remote.

Make sure you contact support so they can prioritize.

Thanks for sharing the screenshots! The HBus timeout is a response from Harmony API. In the past I noticed this kind of errors when there was an update available and haven’t been applied yet.

1 Like

Just submitted a ticket

Thank you for the report. We’ve identified the issue and will need to fix it in the hub firmware. In the meantime a couple of potential workarounds:

  1. Create a Smart Lighting rule to Turn On & Set Level the light when that light turns on. This should run locally and when the firmware is updated down the road you can delete the automation. Note that I have not tried this but believe it will work. This is the workaround I’d recommend trying first.
  2. Self publish the DTH and change the device to use the self published version. This will force the device to run in the cloud but will avoid the bug. This will have to be undone when the firmware is updated if you want the device to run locally again.
  3. Set the level instead of just turning on wherever possible (SmartApps, through voice, etc…).

Got it working by self publishing the DTH. thanks for the work around. Took a few minutes to figure out why it wouldn’t pull down the DTH in github, but then realized I needed to set runLocally to false

Funny anecdote…I got a response back from Logitech support last night saying they had spoken to ST, ST devs had taken up working the fix, and referred me to this (my own!) forum post. I still think it’s a little odd how the Harmony’s implement their “on” commands, but maybe it’s needed to keep consistency with how they integrate with other smart hub products. Anyway, thanks to everyone for help on this. As much as some people around here seem to loathe firmware updates, I look forward to the next one so I can get local execution of the dimmer switch DTH back!

I have now been directed here from Harmony support as they believe the issue I am having is related.

My issue is that I am unable to link my ST account with my Harmony account through the app. Everything had been working well until I tried to add a new plug to my harmony devices, running through the process broke the link and now I cannot get anything working so all my previous automations have stopped. I had it set that certain devices turn on when a activity starts…

What I see now when i try to go through the process on the Harmony App is “Harmony hub cannot find any supported devices” - however on the screen prior to this I can see a list of all my devices, tick the ones I want and then click the green button (apply or authorise - i cant check now as not at home)

Harmony believe this is a ST issue and a new firmware will resolve it? In the meantime they have asked me to use the workaround listed here but this won’t work in my case

Yeeea…you definitely might want to push back on that. Your issue is not even close to related. I gave credit to Logitech for actually looking into my issue and not just immediately pinning it on ST. Guess that didn’t last long

I also have ST supporting me on this and they are being more helpful!
They have managed to resolve a few niggles since moving over to Samsung Account… I do wonder if this is related in someway to changes with the accounts and not being able to authenticate properly

Phil - I’m having this exact issue and Harmony pointed me at this article as well. Did you get this to work, I’m fairly ignorant on what this article is telling me to do, so any help is appreciated!

@EODelf they’re inaccurately pointing you to this forum topic. Your issue is unrelated to the work around mentioned here.

@EODelf - unfortunately I had to fix it with my own workaround…

I tried for a week or so working with both ST and Harmony support but couldn’t get anyway. Then I decided to go through the motions from the Harmony App and log in to ST using my wifes credentials - this worked and can now do everything I want.

Do you share your location with anyone else to try this out? Or if not could you share with another email address of yours?

How do you self publish the DTH? Is there a guide I can follow? I’m new to smartthings but am having the exact same problem with the Logitech Harmony Home Control turning the GE/Jasco dimmer to 0% when turned off. I’m logged into the IDE, but don’t know if I should create DTH “From Code” or “From Template”.

Create the DTH from code. Copy and paste the code from here:

Change the name on line 15 to something other than “Z-Wave Dimmer Switch Generic” I made mine “Self Published Z-Wave Dimmer Switch Generic”. also change “runlocally” on that line to false. Then click create, and it will bring up the code editor with your new handler. Click the “Publish” button at the top and click the “For Me” dialog that pops up.

Now that the handler is published, you need to change the handler that your zwave dimmer switches use. Go to the “My Devices” page and click on one of your dimmer switches. At the bottom, click on the edit button. In the “Type” drop down, pick the new device handler you just created (it will be listed by the name you changed it to earlier). Do this for each of your dimmer switches. That’s it!

ST says it should be fixed in the next firmware release, so be sure to change the “type” back to “Z-Wave Dimmer Switch Generic” on each of your switches once a new firmware comes out. You can then delete the custom DTH you wrote (be sure to change your switches back to the default DTH before deleting, though!)

Was this issue fixed in the latest firmware update?

I am looking to use this dimmer switch with logitech hub and SmartThings.

Does anyone know if all types of dimmer switches are affected?