!WARNING - Smart apps and their settings ALL removed - WARNING!

Today, I tried to install a SmartApp “SmartSense by Idaho Farm Bureau” to see what it was. The SmartApp setup apparently didn’t complete - so I deleted this ONE SmartApp only). I did NOT select delete “all”

So all of the existing configured SmartApps were deleted (except about 6 of them)

I thought this was a SmartThings App issue - recently and every time, the SmartApps, page on the ST App it takes about a minute to be populated.

To see if this was something I had caused, I uninstalled the ST App from my iPhone and my iPad. I then reinstalled them. This made no difference to the slow refresh of my SmartApps
(Note that I am not using the Classic ST App)

Now, those 6 Apps that were there before were now gone.

I only have 1 SmartApp left - CORE (but this has had all its configuration deleted)

My problem is not installing all these SmartApps again (they all still show on the IDE and on the ST Add SmartApp page)…

My problem is the extensive configuration I now have to do.

There were originally about 12 SmartApps installed.

My question is: “Is there a way to restore SmartApps settings?” - Customer Support said no…
Also, can the configurations for SmartApps be backed up and later restored?

Lastly - this is to notify everyone else out there. There was nothing unusual that I did.

Any help would be appreciated.


Any chance a second Home Location was created and switched you over to it in the new app? Click on menu (3 bars in the upper left of the screen) and check if there might be two. If yes, switch to the other one :slight_smile:

And this one you may hate me for saying but you should really move off the very old version of CoRE. Instead update to the newer webCoRE.

1 Like

LOL - thanks for the advice. Now is a good time to update as it has no settings anyway.

I got this from rBoys as I paid for some other SmartApps there…

No such luck. I checked on the ST App and IDE too…

Contact ST support. Perhaps they just need to sync the data again for the new app. If things still show in IDE then always a possibility. Don’t give up quite yet and start over. Contact them first and see what they say.

Definitely a very strange situation. Contact them again and see if a different support person gives a different answer.

Tagging @blake.arnold @Brad_ST

Agreed on this - please contact support and I’ll give our escalations team a heads up.

Also worth checking - look at your locations in the app or IDE and see if still shows the same name you had before or if it’s displaying just “Home”. If the latter, check if any of your devices show still too.

@blake.arnold So I did check the locations on both the App and IDE. Only “My home” option - which is what I named it.

I already called support - my ticket number is 1014024

All devices and device handlers are still in the IDE an ST App

Oh - and last week I did have the Z-wave antenna turn itself off - but that was fixed with the help from support

@jkp That’s not a bad suggestion - I’ll try that tomorrow

No, there isn’t a mechanism for restoring SmartApp settings or for backing up configurations. Some third party apps such as WebCoRE have backup/restore functionality though.

I tried to reproduce this experience and wasn’t able to due to lacking a valid policy #. I admit the timing is suspicious. I wasn’t able to find anything in the logs that indicated removing the IFB SmartApp triggered the delete of all the other SmartApps. Is there any chance that “Delete all” was inadvertently tapped?


No - 100% - no doubt at all…

However, even if I had hit remove all by accident, the following behavior shouldn’t have happened:

  • 6 SmartApps remained
  • Closing and relaunching the ST App removed all of them except CORE
  • CORE configurations were all missing (the piston name was still there though)

Thanks for trying to replicate it though

I am really nervous now about putting in hours of work trying to remember and recreate all the SmartApps and their settings.