Wall Switch not responding to physical input


(Ian D) #1

My electrician just installed a bunch more Linear and GE Z-wave wall switches for me. Most of them work like expected, but I have two of them that don’t respond to physical input.

If I turn the switch on/off through the ST app tile, it works fine. I see the LED on the switch turn off/on and apps are fired as they should.

But if I turn the switch on/off physically, the little LED does turn off/on as expected, but it does not trigger anything in ST. The app tile is not updated, no SmartApp is fired and I don’t see anything happen in the logs, even in the IDE.

These switches don’t control any load, I’m using them only to fire apps that triggers things like Hue bulbs. I have many other switches of the same models that are used in the same manner and they work without trouble.

So… anybody has an idea what it could be? Thanks for your help.


(Ray) #2

When you said log. Do you mean the Ide live log? Look at that and flip the switch on/off. Maybe you apps are not working. As for the switch. How about check the load to see if there is any voltage when flip on. This way you will know if the switch is OK and not just the indication led.


#3

I understand that:

a) when you toggle the switch tile in the mobile app, everything runs as you expect, and the LED light on the physical light switch does go on and off

b) when you toggle the switch physically on the wall, the apps don’t run, but the LED light on the switch does go on and off.

Could be a routing table issue.

Are these switches by any chance farther away than the earlier ones that did work?

Did you pair them to the network in place, or did you pair them physically next to the hub and then move them to their current position for wiring? (This is sometimes called a “bench install.”)

If either of those two things are true, I would start with a Z wave repair to see if the switches can be set correctly in the routing tables.

See the following post:


(Ian D) #4

A routing issue does sounds right to me, although it seems to work one way. If I press the app tile, it does send the command to the switch (I see the LED changing).

I did pair them to the network in place. One is at the opposite side of the house but the other is much closer than many switches that work just fine. I did run a Z-wave repair and it doesn’t seem to make a difference. I’ll try again…

Thanks


(Ian D) #5

Anybody knows how to unpair a Linear or GE light switch? They don’t say in the provided documentation. Maybe if I unpair and repair those switches they will work properly…

I do have over 100 things on my ST hub, that may not help…

Thanks again


(Bruce) #6

Dimmers like yours are not instant reporting. So what you get from ST in terms of response time can be all over the map. On a good day you might see a lag of a few seconds. At other times it will simply fail to respond, with other “solutions” in between.

I gave up fighting it and put in instant reporting dimmers where it matters: Leviton VRMX1. Those have a response time of 1 to 2 seconds consistently unless ST is having issues. That’s the time from turning on the switch until everything is on to its correct level. Turning it off has similar timing.


#7

Do you want to break an association between two switches or exclude them from the network all together?

I would try repeating a Zwave repair 3 times first, as it’s easier to do. Then give it a few hours. If that doesn’t fix things, go ahead and exclude and then reinclude the balky devices.

You can use a minimote to exclude them or you can do it from the IDE, but you need to remove them from any smartapps first.

To see what smartapps are using them:

  1. open the mobile app to the Things page
  2. click on the tiny gear icon next to the device you want to review
  3. when the device’s detail page comes up, click on the SmartApps tile. This will show you all the SmartApps and Hello Home Actions that are associated with it.

(Ian D) #8

I do have a minimote and I understand where to go in the app but do I have to do anything with the wall switch? I mean do I have to press it after I press the exclude button on the minimote?

Thanks


#9

As @bravenel mentioned, the best way to get instant status update is with a switch that utilizes that patent.

Alternatively, if you really truly aren’t using this to physically control current to any devices and you’re just using them to run apps, hello home actions, and change modes, then you don’t need a dimmer switch at all, you can just use button controller. That can give you instant status update without violating the lutron patent because that patent applies only to light switches.

The options then are a wallmount tablet using a dashboard app, a minimote, or a button controller like the SmartenIT. None of these count as light switches, so you can get immediate update.

All of that said, though, I’d still start with repeating a zwave repair 3 times. The fact that it’s working one way (hub to switch) and not the other (switch to hub) could just be status reporting as @bravenel mentioned, or could be an orphaned node. The hub knows to go directly to the switch, but the switch may be trying to reach a neighbor that is no longer in range.

And with that many devices, you certainly have some hops in your network, so a repeated repair can only improve things.


#10

Yes. What model are the switches you want to exclude?


(Ian D) #11

One is a WD500Z and the other a WS15Z.


(Ian D) #12

I understand I don’t need dimmer switches, a model like the WT00Z (w/o load control) would have been enough- I just happen to have a bunch of WD500Z and WS15Z units at hand. I have purchased them before going crazy with Philips Hues. I have about 50 of them now and need my light sockets to be always powered- thus why I wire my wall switches to not control the loads.


(Ian D) #13

I’ve been able to exclude and re-include a WD500Z successfully using a minimote and now it works just fine. I suppose something went wrong with the first pairing… I will try the other one.

Thanks for your support guys, this is an awesome community and I hope I’ll be able to contribute too! Now that I have over a hundred “things” it’s safe to say I have some experience :smile:


(Ian D) #14

I’ve finally figured it out… I have a bunch of other Linear and GE models but these are the first WD500Z I’ve installed. They are dimmer switches (not just on/off) and they need to be double-tapped to turn on and off. I didn’t know that…

Is there a way to change that behaviour? I don’t actually care about the dimming capability, I just want a single tap to turn it on and off.


#15

It shouldn’t need a double tap unless you’ve associated it with a smartapp that does that for some reason.

A single tap on the top part of the switch should turn it on.

A single tap on the bottom part of the switch should turn it off.

Press and hold on the top part of the switch should change the brightness levels.

http://www.nortekcontrol.com/pdf/manuals/WD500Z1_manual.pdf

Do you have to double tap on the bottom part of the switch to turn it off? If so that sounds like a smart app issue.

If turning off works with a single tap, and you are only having to double tap on the top part of the switch to turn it on, that may have to do with the brightness level configuration.


(Ian D) #16

Yeah, I have to double tap the top part to turn it on and double tap the bottom part to turn it off. I will try with different device types and apps.

It was discovered as a “Dimmer Switch”.