V3 Hub (IM6001-V3P01) always says it’s disconnected

I just moved from iris and trying to get this setup. So far lots of frustration.
I have an iPad I want to connect. I have the old classic app downloaded and the new app. When I go to the new app I see all my devices but when I select the hub I get an error device disconnected. See the pic

When I go to the classic app I don’t see any devices connected. It asks me to connect a hub. I have the new WiFi hub. What am I doing wrong. How do I get other iPhones and such connected to my hub.

What’s the model number of your hub?


I reset the hub to factory. I think. Unplugged and help in the reset button until the rapid yellow flash turned to slow flash. When the hub connected it downloaded updates for a while. Then when I bring up the app all my old devices are connected. When I select the hub it says hub disconnected.

So now I have a bunch of devices on my app with no hub.

OK, that’s not a Wi-Fi hub. That’s a V3 hub (also called the 2018 hub) it does have Wi-Fi, but the “Samsung Wi-Fi hub” is the hub which is also a Wi-Fi router, which yours is not.

There’s a really weird thing in the new app. If you click the first icon which says “Wi-Fi/hubs” you get to the Wi-Fi hubs. Again, not the one you have.

Instead, you want to look in the next section and select the “SmartThings” brand. Not the “Samsung” brand.

Then when you select that, you’ll see another entry that says Wi-Fi/hubs, and this time, you’ll be able to select your V3 hub.

Then you can follow the directions:

I did use the SmartThings hub option. I reset the hub to factory conditions. Fast yellow the. Slow yellow flash. Waited for red green flash and connected the SmartThings WiFi hub im6001 option. Scanned the qr code and it registered. Added my WiFi network. It downloaded software updates and says it connected. When I select it in the app I get what you see in the screenshot. I also see all my old devices connected in the app.

Sorry, I’m not familiar with the new app (it’s not voice-accessible :disappointed_relieved:) and can’t help more. Have you contacted support?

Meanwhile, hopefully someone who has seen the issue will also comment here.

Thanks. I was on hold with support for 45 min last night - but hung up. Will try some other time.
I tried one more time with my hub and disconnected all connected devices. Then repaired the hub after a reset. But I get the same error - said the device is disconnected.

1 Like

You can try the following If you haven’t already except again you need to select the smartthings“ brand rather than the “Wi-Fi/hubs“ option on the first “add a device” screen. Because of the most recent app update.