V2 Hub, Migration, Zigbee

Before I dive deep into a weekend of troubleshooting, can anyone confirm that the new Smartthings app and the V2 hub are supposed to support Zigbee? When I upgraded all of my zigbee devices stopped responding and flipping them on and off while in discovery mode did nothing.

I put this switch off until the last minute because I have so many automations running in my hub I assumed I’d have to start from scratch. That seems to be the case. Probably a good time to try out what else is out there before I come back a wrestle with a new “simplified” interface.

maybe try contacting support and see if they can do something on the backend for you.

I have over 250 zigbee devices on a v2 hub working with the new app. BTW, the app has nothing to do with supporting Zigbee. Every version of an ST hub has supported Zigbee, and quite well actually (better that zwave in my opinion).

1 Like

I’m aware that Zigbee should be hardware. My dozen or so zigbee devices worked on the old app and do not work on the new app. I haven’t dug into why yet, but it is the same problem for all of them. Good to know it is working for you. I’ll try removing them and re adding them one at a time (and see if that breaks all the automation like it did with the old app) and see what results I get.


No worries, your stuff should work. Are you using any custom device handlers?

I am in the same boat as you. Mine stopped working yesterday. I tried to delete one and add it and had no success. I have a total of 5 and none of them is working with the new app. They used to work fine with the classic and the new app. But since the classic is gone, they stopped responding and I can only turn them manually with the switch.

I just fixed my issues by turning off the hub for 20 minutes. I turned it on back and the the light bulbs are working perfectly. You may want give it a try. Good luck.


Tried that first and it worked like a charm. There are a few other bugs but they are more manageable. Thanks!