v2 Hub Joined Existing Zwave Network - Missing New Devices

I am trying to setup my v2 hub as a secondary controller by using the join existing zwave network feature. It joined and all of my devices showed up and can be controlled however I have since tried adding a couple more of the same GE light switches and the ST hub will not see or detect any new devices added to the hub after the hub had joined. I don’t see any functionality to refresh the device list etc, and I also tried joining it to the existing network again but no change.

Could you describe where you found “join existing z-wave” in V2?

You can make SmartThings join existing Z-Wave network as a secondary controller. This function is buried in the mobile app and not easy to find. Go to the Dashboard and tap the menu (three horizontal bars in the upper left corner). This will open location menu (“Home” or whatever you named it). Now tap on the “gears” icon in the upper right corner. This will open configuration page. Scroll down to the “Hubs” section and tap on on the “Home Hub” (or whatever you named it). On the next page, tap “Z-Wave Utilities”, then “Join or Leave Existing Z-Wave Network”. Finally, tap “Join”. Now put your primary controller in inclusion mode and you should be set.

Those instructions are not quite the same for v2 of the app. Below are the steps for android app.

  • On the main screen(s) of your mobile app, tap the Menu (3 vertical dots) icon at the top RIGHT
  • From the menu select “My Locations”
  • On the new screen, tap the Gear icon at the top right of the screen
  • Scroll the new page down till you find “Home Hub”

Follow the remaining instructions described by Chris

Thank you both…I will post back if it works

I get the message “Z-wave Join/Leave” Failed. I had the same issue with V1 but I was hoping that with increased processing power of V2, it will work. My primary controller is z-troller with homeseer. IF I may ask, what primary controller works well with SmarThings.
I am new to SmarThings and this forum but my hope is use the smooth software interface of SmarThings with the more robust homeseer in the background. Any thought is appreciated.

I’m not sure yet if it is really feasible to use the SmartThings hub as a secondary controller. SmartThings customer support really doesn’t give much of any help on using it as a secondary controller. If you have any problems with this they will just say it was designed to be used as the primary controller and won’t give you any answers. One thing I have found is that there is no way for the ST hub to find out about new devices you add after doing the join existing zwave network. So it seems anytime you would want to add a device you have to start over from scratch, you lose all devices in your ST hub, have to re-join it and they have no answer for this. All I wanted it for was to provide a way to do Android tablet integration, however I am probably going to return it as setting everything up over and over each time you add a device is unacceptable.

Chris, I believe the z-wave protocol only allows for new devices to be added to primary controller. So, if I understand you correctly, your V2 was successfully added as a secondary controller (a feat I have not been able to achieve); then, you will not be able to add any more devices to V2 since it is not a primary controller. If you do add more devices to your primary controller though, you can update V2 with those newly added devices although as you said, you will be starting afresh.
If I were to be able to reach your level, I probably will be able to leave with the limitations since my z-wave mesh is matured. But even that, I am not able to do. I do not want to make V2 primary controller because I do not want to re-add all my devices and, I like the robustness of homeseer even though it less intuitive.
It makes not sense V2 is having difficulties performing a z-wave functionalities that I have done effortless with other controllers for more than 5 years.

Hi -

Setup: Alarm.com GE panel as primary z-wave with Smartthings hub as secondary. I only have 11 devices connected. I needed to add a new device to the primary, but it did not show up to secondary despite multiple attempts.

  1. Add device to primary z-wave controller (Alarm.com panel)
  2. Go to location, hub, z-wave utilities, include/exclude hub from existing z-wave network, and delete from primary.
  3. In same location, re-add smartthings to primary z-wave controller.
  4. Voila. New device now appears.

I did not need to rename or readd the previous devices, they remained intact.

Worked for me, your results may differ.