Utilitech Siren - Dashboard issues

I saw this siren featured in the blog recently so I bought it at lowes for $30. It paired as a zwave switch. I logged into the ide and changed it to smartsense siren. It works great and is very loud.

ST keeps talking about using the dashboard for everything and not using smart apps, so I tried this. I couldn’t find any apps for it anyway.

So if I go to motion section on the dashboard there is no option to add a siren (or even turn a switch on) if there is motion detected. The only place I found a siren option was in the damage and dangers section - I had to add a damage and dangers redundant motion dashboard app (because it’s the same motion detector that I’m already monitoring in the motion dashboard). Furthermore I could only use a siren option if I added it under unwanted access to valuable items and not unwanted access to dangerous items.

So basically it is doing what I want, but now I’m using the motion sensor in two dashboard sections. I guess I could just delete the motion section of the dashboard, but that seems silly since motions should be in the motion section. Please add “more options” in every dashboard category to include ALL OPTIONS.


Support sent me an e-mail yesterday saying the lack of siren support in the dashboard will be “rolled out in a week or two.”

Sweet - good to know!

Was this rolled out? I am about to purchase this same siren, but wanted to verify these issues were resolved before doing so… Thanks!

yes but only through damage and danger, not though motion. I just use the smart security app. It has better options than the dashboard.

Thanks for the info!

What do you mean by this? I can’t find a smartsense siren in the list.

I connected mine as z-wave switch.

Update: Found it. Listed as SmartAlert Siren

sorry SmartAlert Siren

How did you get it to pair? I open the app, go to things, click on connect new device. Then I put in the batteries, press the gray “pairing” button. The siren beeps every 5-10 seconds, but no new device is discovered.

Also tried resetting the siren by hitting e pair button 8 times, one second between each. No luck…

I bought one this weekend. I paired right next to the smartthings hub, and it was the second time that it worked. The first time, I had the same issue. I was within a foot of the hub.

I didn’t have issues pairing mine. Wasn’t anywhere near the hub actually.

I have the same exact issue, how did you fix it?

Are you using the Classic app? If not, please try that app.

Also, depending upon how good your zwave mesh is, you may need to pair the siren very close to the hub.

1 Like

I ended up figuring out the issue. Whenever the siren is beeping every 10-15 seconds it is some state and even when you successful add it to ST, it still doesn’t function properly. What I had to do was remove a battery and then hold down the pairing button and put the battery back in. The light on the siren stayed green. Then I repaired it and it functioned.

1 Like