Utilitech siren? (Same as Everspring siren SE812)

dth_siren
dth_security
dth_alerts

(Jeff L) #1

Had anyone made one of these units work recently? I’m on my second unit from Lowes and my hub absolutely sees nothing when I attempted to bind the siren. The hub is listening and the siren is looking but they just aren’t communicating. s
this is my second siren so I don’t think that’s the issue here. Has anyone made one work recently?


Everspring Indoor Siren SE812 Compatibility
#2

@jeff1, yes I’ve been using this siren for several months now. I recommend trying to exclude the device and then reincluding it into ST. Mine paired up the first pass, and I’m using the default device type - zwave siren. It doesn’t report battery status or have full functionality yet, but I plan on making my own device type very soon.


(Greg) #3

I have this siren also and it works great.


(Jeff L) #4

@johnconstantelo - Thanks, that did it!! Now of course I have another issue. The siren will sound if I manually turn it on, but if I use the “Smart Security” app to try to sound an alarm if certain motion sensors are tripped in a particular mode - it doesn’t make any noise. The app is working, I get the alert, etc. but the siren does nothing. Any ideas?

SOLVED - For some odd reason the SmartApp wants the setting “Yes” to be in place for “Silent alarm only”. If that is set to “No” then the siren makes no sound. Seems highly counter-intuitive!

-Jeff


#5

Cool, glad that worked for you. I was just putting together a reply when I saw your edit.


(Josh Galloway) #6

I am also using the Utilitech siren and get the same behavior of being able to sound the alarm manually, but I cannot get any motion or open/close sensors to set off the alarm. I can see that all the commands are going to the alarm, but it just doesn’t make any noise or light up. I am also trying to use this from the SmartAlarm app and it won’t work from there either.

I bought two from Lowes and have tried them each separately and they both do the same thing. I must be doing something wrong.


#7

Hi @Josh_Galloway, I don’t use the Smart Alarm app unfortunately. My siren is tripped by either my smoke/co2 detectors or leak sensors.

Try something? Can you go into SmartSetup (big Plus sign at the bottom of the Dashboard screen) and swipe over to Alerts, then scroll down and add an action to Dangerous Items (pick an open/close or motion sensor), and then select the sensor and walk through the setup process (which includes selecting your siren)? Trip the sensor you just set up. Did the siren go off?


(Josh Galloway) #8

No this did not work. I am still able to go into Things, see the alarm listed, and trigger it manually. However, setting it trigger from one of my open/close sensors did not work. I have a hard time believing these two separate alarms are defective out of the package. Am I missing something with setting them up? They pair with ST very easily and show up in the Things list. I am not sure what else I would have to do. I am tempted to just return them both to Lowes and get a FortrezZ.


#9

@Josh_Galloway, nah don’t do that yet because these do work. Sounds like the device type needs changed via the IDE. Can you look and see what it is? Mine is “Z-Wave Siren”.


#10

@Josh_Galloway, I just tripped a smoke detector to test and to make sure my siren would go off based on how actions are tied together in Damage & Danger for me, and it worked as expected (drove the wife, kids, and dog nuts while testing…):

Please make sure the IDE reflects the correct device type.


(Josh Galloway) #11

Yes it is set as a Z-Wave Siren. Here is the events list from me tripping it with the Open/Close sensor.

2014-12-31 12:11:31.602 PM EST
moments ago COMMAND off off command was sent to Basement Alarm
2014-12-31 12:11:31.582 PM EST
moments ago APP_COMMAND off Open/Close Monitor sent off command to Basement Alarm
2014-12-31 12:11:15.543 PM EST
moments ago COMMAND both both command was sent to Basement Alarm
2014-12-31 12:11:15.528 PM EST
moments ago APP_COMMAND both Open/Close Monitor sent both command to Basement Alarm

Sorry to paste it like this, but new users are unable to upload pictures apparently.

Do you think it has something to do with me trying to trigger both the siren and light on it? That’s why it is sending the both command. When I manually turn it on, the siren and light both work on it.


#12

No problem @Josh_Galloway, hmm interesting. Looking at mine more closely the smoke/co2 action really triggers an ON command since the siren also has switch capabilities. Looking at the default device type code more closely I do not see the handling of the “both” command, which is what you are sending.

Let’s try something. Can you modify the open/close test you just ran to send just “strobe” (it may just say light) instead of both the siren and light? It should actually still sound the siren and lights.

If that doesn’t work, I bet if you change the device type to “SmartAlert Siren” it will work.

I think you may have just found a bug in the default device type that needs fixed…


(Josh Galloway) #13

I changed the alert to just strobe and it worked. Interesting that it doesn’t work as designed. I appreciate you helping me through this. Does this bug need to be reported to someone?

I’ve only had ST for a week so I am just getting started. Do you have a variety of devices working? I’m wondering how any devices this thing can handle reliably. I would like to grow it, but it seems I will need to write the code to really customize it.


#14

@Josh_Galloway, no problem Josh glad to help any way I can. I have over 122 devices working, and still growing! I’ll probably reach 150++ when I’m done with everything. So far for me ST has been working very well. Hang in there.

For the most part I use the default device type from ST for every device, but I have customized a few just to let me use my own icons (look and feel primarily) instead of ST’s standard ones. The working guts are still as ST designed them. The only custom device type I’m really using are for the GE Link Bulbs, MIMOLite’s, and Philio’s 3-in-1 sensors.

EDIT: I am fixing the device type and will submit it for review. ST is quite busy so I don’t expect a fast fix. I’ll post it to GitHub for anyone to download soon!


(Jeff L) #15

@Josh_Galloway - That’s my experience as well. For many of the existing apps you have to say “Yes” for silent in order for the alarm to go off. For my apps I’ve just been using: alarm1.on() and that does it every time.

-Jeff


#17

Here’s SmartThings default device type but modified to include more logging, more refresh info, include polling, and to include handling the “both” command.

https://github.com/constjs/SmartThings-Devices/blob/master/utilitech_siren.device.groovy


(Jeff L) #18

@johnconstantelo - Thanks!! I just updated my siren and it seems to be working great. I’ll test out a few other smartapps and report back. Thanks again!

-Jeff


#19

Anytime Jeff, glad I could help!


(Micah Kordsmeier) #20

How do you update the device with this code? I’ve made tweaks to different apps before but not with any devices. Thanks!


(Jeff L) #21

Go to the IDE site: http://ide.smartthings.com Login, go to “My Devices”, click on your siren device, Click “Edit” at the bottom, and change the device type. You will have to “publish” the device code first under “My Device Types”. Then it will show up, and it works great.

-Jeff