SmartThings Community

[UPDATED] Osram Lightify RGBW A19/BR30 US version (HA) DTH

osram
dth_lighting

(John) #113

Works on strips too.


(Borristhecat) #114

Not if you’re in the UK :neutral_face:


(Christopher Capitumino) #115

That is how GitHub integration should work. I have it on most of my device handlers and smart as, but this one doesn’t show anything in the repo


#116

Really? Is this definitely true? ST doesn’t mention any regional restrictions? I’ve managed to turn on OTA updates in the IDE in preparation of receiving the Flex strip, I’ll be gutted if it doesn’t work now :frowning:


#117

This is the write up in the UK FAQ section, no mention of US only?


#118

Just had confirmation from ST that these updates are not supported in the UK despite being on their UK website, the message went on to say ST have ‘no idea when/if it ever will be implemented’.

To say I’m disappointed is an understatement, surely it can’t be that difficult to port this US functionality across? Plus there should be explicit reference to this on the website so UK purchasers of Osram products are not deceived.

Disappointing.


RGB Light Connect App
(Borristhecat) #119

yep

and yep :disappointed:

It really annoyed me as well, especially as I was having issues with these lamps and I assumed that they were up to date as my OTA allowed to be turned ON. It took me loads of research to then find I had to buy another hub just to do the updates. :angry:


#120

Jeez, that adds an expense I really could do without. Did the upgrade at least improve things?


(Borristhecat) #121

Yeah it fixed everything.

I just brought the lightify gateway was about £25, then follow my instructions from earlier on in the thread and you won’t lose anything.


#122

Thanks @borristhecat is there a possibility that my flex smart+ strips could potentially come with the latest firmware already installed? Do you know what the target firmware should be?

Many thanks again.


(Borristhecat) #123

Unfortunately I doubt they do, they order so much of stuff like this that it sits on the shelf for ages, but I won’t have a clue as I don’t have any. I can only tell you what version my RGB tunable White Osram lamps are, it could be the same but I wouldn’t know for sure.


#124

Thanks @borristhecat I’ll look up your updating instructions in preparation.

If anyone who has the smart+ flex strips could let me know what the latest/ST-safe firmware is that would be much appreciated. I don’t really want to have to buy a gateway if I don’t need one.

My strip is showing firmware version 0x01020493 in the IDE

Many thanks again.


#125

Today I got home and all of my lightify lights aren’t working. I tried resetting the hub and tried resetting one of the bulbs but nothing is working. Checked for outages and don’t see any. I’m completely at a loss.


#126

Just bumping this, can anyone help me figure out if the above is the latest strip firmware? Many thanks :slight_smile:


(Nathan Curtis) #127

My strip (US) is showing:

Target version: 0x01020492
Current Version: 0x01020492

Which means the latest firmware ST is pushing is 0x01020492, doesn’t mean 493 wont work… :slight_smile:


#128

Great thanks @nathancu that sounds promising, hopefully 493 for the outdoor strip will be ok and I won’t need a gateway, fingers crossed! :slight_smile:


(Patrick Mjoen) #129

I am also having issue with my Lightify Flex Strip. Smartthings quiclkly recognized the device and added, but when I use the app to turn on/off the status changes in the app and the ice but the light never turns on??? Here is the one I purchased:

Firmware is as follows:
0x01020492

Getting the following in the IDE:
92b01959-3352-4d45-a975-417559cf89ac 6:45:21 PM: info DID NOT PARSE MESSAGE for description : catchall: 0000 8021 00 00 0040 00 0DE9 00 00 0000 00 00 2A00
92b01959-3352-4d45-a975-417559cf89ac 6:45:21 PM: debug description is catchall: 0000 8021 00 00 0040 00 0DE9 00 00 0000 00 00 2A00
92b01959-3352-4d45-a975-417559cf89ac 6:45:19 PM: debug ON/OFF REPORTING CONFIG RESPONSE: SmartShield(clusterId: 0x0006, command: 0x07, data: [0x00], destinationEndpoint: 0x01, direction: 0x01, isClusterSpecific: false, isManufacturerSpecific: false, manufacturerId: 0x0000, messageType: 0x00, number: null, options: 0x0040, profileId: 0x0104, senderShortId: 0x0de9, sourceEndpoint: 0x03, text: null)
92b01959-3352-4d45-a975-417559cf89ac 6:45:19 PM: debug description is catchall: 0104 0006 03 01 0040 00 0DE9 00 00 0000 07 01 00
92b01959-3352-4d45-a975-417559cf89ac 6:45:17 PM: debug [raw:0000 8021 00 00 0040 00 0DE9 00 00 0000 00 00 2900, profileId:0000, clusterId:8021, sourceEndpoint:00, destinationEndpoint:00, options:0040, messageType:00, dni:0DE9, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:00, direction:00, data:[29, 00], clusterInt:32801, commandInt:0]
92b01959-3352-4d45-a975-417559cf89ac 6:45:17 PM: info DID NOT PARSE MESSAGE for description : catchall: 0000 8021 00 00 0040 00 0DE9 00 00 0000 00 00 2900
92b01959-3352-4d45-a975-417559cf89ac 6:45:17 PM: debug description is catchall: 0000 8021 00 00 0040 00 0DE9 00 00 0000 00 00 2900


#130

I’ve been using the device handler since OSRAM change the API. One nice things the lightify gateway and the old API had was setting transition times in the curl command. With their new API (that is not ready for primetime), this ability is gone.

I’ve worked through the code on your device handler and see where you set they transition values, I was wondering if anyone could help me take that a step further and make that a parameter I can pass at run time from Webcore. I’ve added the additional input to the function but it doesn’t show up in webcore.


(Cliff) #131

how can you change the default max blink(on) time from 3600 seconds to infinite or something larger? 1hour is not enough.


#132

This thread hasn’t been active in quite awhile. I stumbled across it doing a google search, and was surprised as I scrolled down that I had actually posted in here earlier this year asking the same question I had googled.

Anyway, I am still interested in updating this device handler to pass the color transition time as a parameter at runtime instead of a preference. While I’m somewhat competent with coding, groovy doesn’t quite click with me and I was looking for a little insight.