Unable to sign in to Samsung Account (Sept 2023)

While trying to Sign in to my Samsung account. I get the error

This has been like this for over a week. I have tried it on a number of different PC’s, tablets and phones. A friend says he is experiencing the same problem.

Is anyone else having this issue…

Check the error codes to make sure it matches those in the following thread. Sorry, image is small for me to read at the moment

All I get is this…

Couldn’t load webpage
The webpage didn’t respond to the request in time.
※ IAMUSSauseast1_1693669521110_99999-5891257706.999

I had this happen to me a few weeks ago and tried all kinds of things. The solution: turn off my ad blocker.

Which browser are you using?

I do not have an Ad blocker

Chrome, Edge and Firefox. Same problem on all. I get the same error on my phone as well

Interesting. What if you use an incognito tab?

Using Incognito tab on Edge and Chrome. Same error

Couldn’t load webpage

The webpage didn’t respond to the request in time.

※ IAMUSSauseast1_1693768221757_99999-2722146053.999

Sounds like it’s time to open a ticket with ST.

I did that. Opened a ticket via email ( support@smartthings.ca ) They never responded. I did a live chat with WECARE. The guy was useless…

I am having this same issue, and the only way I can login is by using DuckDuckGo. Chrome, Safari, IE all have the same error. I tried clearing everything from chrome (cookies, cache, passwords, etc.) as well.

Same issue for me, unfortunately.

Couldn’t load webpage
The webpage didn’t respond to the request in time.

The issues for me are on any of my Win 10 desktops/laptops using the Chrome browser. I tried all of the recomendations in this and other threads, with no luck. Even the QR code trick doesn’t work for me.

I do have ad blocking via DNS on the router and an added level via Chrome browser extension, but the issue persists when both are disabled, and incognito, so I doubt it has anything to do with that.

I should mention, that I can successfully login just fine on Chrome for Android on my S22 Ultra via cellular or via my WiFi. WiFi is with the same ad blocking via DNS on the router with an added level via an ad blocking app (blokada). So, the router and ad blocking don’t seem to be the issue, and even if they were, there is no way in h#!! I will ever use the internet without them.

Something obviously changed recently with the login process on the the Samsung side that may be conflicting with Google Chrome security that likely needs fixing.

I am going on 2 weeks now where I can’t login to my Samsung account on any of my desktop/laptop (Win 10) computers, just glad it isn’t broken on my phone… yet!

I guess I will keep an eye here for any updates.

I tagged @nayelyz in another thread on this issue. I appreciate finger pointing and the run around as much as the next guy… not! Since the Samsung Helpless-Desk, Samsung Support, and WECARE team are generally useless for most of us, perhaps someone on the SmartThings team can call or walk across the hall and work to get this resolved on everyone’s behalf. After all, SmartThings is also generally useless if their “third-party” authenticator doesn’t allow people access to it.

I can confirm that the login is now working for me again. I did not do anything on my end, so obviously they finally fixed whatever they had broken. It would be nice if they could provide an update here confirming the issue and outlining whatever they did to fix it, so next time it crops up again we can point them to this thread.