Unable to add locations, completely down, struggling with support.. any ideas?

Hi community, appreciate any advice you can give here.

I’ve been a Smartthings user for many years now, had a delightful experience using it to manage my owner occupied rental multifamily. I managed to go from the old app to the new app with only minor headaches and inconsistencies…

Last April I moved to a new home and bought the Samsung Mesh Wifi with integrated Smartthings, and set up my entire house with many devices with no issues.

Sometime mid to late last year, a couple devices I bought seemed to add OK but did not show up after adding them. I would dis-include them and whatnot and re-add them but still they would either show up once and disappear or not show up at all. I then noticed I could see them in my Alexa app as well as in my old smartthings app (sometimes) and I could always see them in the graph.api portal.

I finally got around to asking Samsung/Smartthings support about it, they claimed somehow my new home got created in the EU shard. I could believe this because I noticed in graph.api the URL would change to a eu address only when I went to that location. OK I will take the hit and remove the whole location and start from scratch there, at Samsung’s request…

I removed the location, and added it again. The location showed once and then after restarting the app it’s gone. it’s still in the system on graph.api and the old app shows it. Now they are telling me maybe I need to delete my whole account. This would mean wiping out my whole rental property with a bunch of devices, too…

Support has been conferring with engineers and being pretty responsive, which is nice, but it does not feel like we are making progress. I’ve been down a week now and getting restless.

I’ve tried uninstalling and reinstalling the app, wiping its caches, logging in with a different phone, even.

Anyone gone through anything like this before?

Tagging @Brad_ST @jody.albritton

1 Like

Did you change geographies? I understand that if you account was originally created on the US shard then you may have trouble adding locations outside the US and vice versa.

Since it looks like you’re on the EU shard, you may want to try to either delete your entire accounts and start over fresh with the EU region or create a new account all together in the EU region and then try to add a location.

Both homes are in the US. Any EU situation was either a glitch or user error somehow. I’ve never lived outside of the US. Honestly my only guess with that is that perhaps when things changed from Smartthings login to Samsung login, perhaps my samsung account (which was very old) had some sort of configuration error.

So, the new location was the one originally showing up in EU shard. I deleted that completely and am now creating the new location again, which from what little ability I have to tell, is creating in the US side of things. And that location (or any new location I create) is the one that will not show up in the new app.

P.s. - I’m a paying member of your apps RBoy, thanks for the suggestion!

1 Like

If your account is somehow tagged to the EU servers then you may continue to face issues if you try and create US locations.

Hoping Samsung/Smartthings can tell me if the account is tagged that way. Starting from scratch is a significant task now, if it happens again if/when I have say 5-10 properties managed with it, would be a disaster. My location in my samsung account is fine. It’s strange that all was working fine even with the new location until some random time in the past 6-8 months. :-/

Just for future readers, Smartthings explanation is that my original account was created in the EU (somehow) and I will need to remove and reset my system , create a new account and start from scratch. Major bummer. No real explanation as to why everything worked fine until some time in the recent past but I guess it is what it is!