Open discussion - Issues with expanding Philips Hue integration (Hue Connect)

I have 10 Hue’s scattered throughout my house. I went and bought number 11 and the app refuses to discover it. Support told me I need to undo and re-add my Hue Integration and was wondering if anyone has any thoughts? The last thing I feel like doing is blowing it all out and re-doing every action along with every bulb, light strip, bloom.

Ya know… I love Hue, but had a bulb go unreachable the other day. So I scan for lights and it finds it, but not at the same ID, and now I can’t remove the ID that went unreachable. Hue’s answer: “reset the hub and start over from scratch”.

That just sucks!

And of course, after the reset, I had to do the same thing you’re being asked to do. All in all… half a day of futzing around with this stuff.

In your case, it’s hard to know whether it is due to a glitch on the Hue bridge (but that’d be my guess) or SmartThings, but this stuff HAS to become more robust, and provide the ability to recover from error with something less than “delete it all and start over”.

Replacing a device in both systems is a PITA. Hell, I have some HA software written over ten years ago that is smart enough to remap all references to a device if it is replaced with another and given the same name.

@FullMetalNick If I were you I’d clear it all out of SmartThings, reset your Hue Bridge and reset it up, and then re-add it to SmartThings (and then write both of them a nasty letter ) (c;

What I don’t understand is that every other app out there that supports Hue has no problem discovering new bulbs. I just tried it out too.

I’d be ok with the nuke and rebuild approach as I like to tinker, but I just did that to the entire house recently not just Hue. Thought it was due for a reorganizing. I got everything just how I like it and I’m not looking forward to doing it again. Support said they were working on a fix so I may just wait.

As far as Smartthings as a whole, tons of potential. I jumped on board after plenty of research. I’m being patient but I agree that things need to be more robust. Some areas seem redundant of others and whatnot. It once took me about an hour to setup a smartsense multi and I had to open the thing up and reset the board along the way.

I haven’t looked at the code in Hue Connect, but if it is like most others that I have looked out, there is little to no error handling. So if something unexpected is encountered, it just stops. From someone who has written their fair share of code, no matter how carefully you do it, something unexpected/unforeseen almost always happens sooner or later. (c;

Hey all,

We have a fix queued up that will take care of this bug. After our next update you’ll be able to add new hue bulbs in without dismantling your existing setup.



That’s awesome. Any idea when you’ll be releasing the update?

It’s a server side update. Not sure exactly but I’ll do my best to come back to this thread to let you know.

You’re the man. Thank you for the efforts.

Anyone seeing any changes on this? Still having the issue

Hasn’t been deployed yet. The bug fix just went through QA so it should be soon.

Bug fix is live. You’re now able to add additional hue bulbs without having to remove all of your existing bulbs.

Thanks for your patience.


Great news. Can’t wait to try tonight.

Must not have rolled out to me yet. A saw the UI change in the app but still no luck discovering.

Still not working? Try verifying that the hue bridge is on the latest firmware.

I forgot to update this thread. Last night I have it a shot and the new bulbs showed up. So I’m all set here. Thanks for following up.

This still isnt working for me. I added 2 bulbs and an Iris today and they do not show up in Hue connect but the prev 11 bulbs still do. The philips hue app of course is able to find and control them fine.

That’s interesting. If it helps at all, I’ve noticed that you can only add new bulbs via the already installed smartthings labs tile for Hue Connect as opposed to going to the plus sign on the dashboard. If that doesn’t work you may try sending a reboot command to the hub from the site.


I’ve tried w/ the plus sign at a bulb, and I’ve got into my Hue Connect, and i still can not add my new Hue bulb to my setup.

I haven’t tried remove all of my bulbs and re-adding my Hue like I did the last time I added a bulb because I have so many smartapps that would be very time consuming.

How can I get it to see my additional bulb?

Tap in to the Hue (Connect) where it says “Bulb Discovery Started” and go to the bottom where it shows your “Bridge (IP Address).” If possible, compare that IP address to what your routers control panel says is the address of the Hue Bridge. Validate that they are the same. If not then tap into it in SmartThings and have it discover the new IP.

Here are my screenshots, this is the only way I’ve successfully added new bulbs without starting fresh…

I took a similar approach to restoring connectivity of my hue bulbs that I lost the ability to control via smartthing but could still control via the hue app… I noticed my hue Things said Hue Bridge was on a different IP than the one listed when I clicked on the Hue Connect gear/settings. My router uses DHCP and I think all the devices being rebooted (such as printer, hue bridge, smatthings hub, sonos, etc.) confused smartthings.

I ended up changing my router settings such that the MAC address of the hue bridge, smartthings hub and sonos bridge always map to the same IP address. Once I rebooted it took 20 minutes for everything to sort out and all of my hue bulbs worked again, without having to delete all the smartapps and devices. I had lost hue bulbs before and reinstalling took a lot of time and effort.

I am new at this and not super technical but perhaps this will work for others with similar challenges.