Unable to add Iris Smart Plug 3210-L (Zigbee)

Over the past few weeks I have added several Iris SmartPlugs, with no problems.

I am down to my last two devices, and both of them are failing in the same way - SmartThings doesn’t detect the Zigbee switch, but it does detect the Z-Wave repeater.

My existing Iris Smart Plugs still work, so I know my Zigbee radio hasn’t stopped working.

Since both switches are exhibiting the same bad behavior, this “feels” like there is a problem at the SmartThings end rather than the final two (of about 7) devices both being bad.

https://status.smartthings.com/ shows there are no issues. Is anyone else having a problem adding Zigbee devices currently?


How many Zigbee devices do you currently have added in your ST environment?

I have 19 - hopefully nowhere near the limit :grinning:

1 Like

That must be really frustrating, have you tried doing the troubleshooting steps:

  1. Reset the Plug
  2. Pair within one foot of your hub
  3. Reboot the hub including a complete shut down (remove batteries) for at least 15 minutes
  4. Make sure the hub is at least 6 feet away from a wifi router (for possible interference)

Thanks @Jimxenus.

Is there a better way to reset the Iris plug than power off the device for at least 10 seconds, hold the button while plugging it in to power, release the button when the LED blinks? Everything I have read says that those steps (which are identical to initial setup) are what you do to reset.

In terms of distance from the hub - it’s in the same location I set up my other plugs, but is not actually within a foot of the hub (more like 5 feet with no obstructions). I will move it closer to make sure I do my due diligence.

I have rebooted the hub, but have not yet tried the 15-minute downtime (with resulting Zigbee panic) - I’ll try that shortly.

The hub is about 10 feet from the Wi-Fi.

1 Like

That is the way to reset the plug.
One other thing you can try before resetting the Plug is to remove the Z-Wave radio that did get discovered (you may have to simply do a force remove z-wave) and then start the repairing process.

The 15-minute timeout did not improve the situation. Also, I had been removing the discovered Z-Wave repeater each time I went through the cycle of attempting to discover the Zigbee switch (with one exception where I forgot to delete it, and ended up with 2 Z-Wave devices associated with the one Smart Plug (not sure how SmartThings let that happen).

It occurs to me that each of these two smart plugs is behaving as if it knows that the Zigbee device has already been paired (yet no such device shows up either in the IDE or in the app) in that when I reset the smart plug the hub almost immediately finds the Z-Wave repeater (which is only supposed to show up after the Zigbee switch has been discovered and I subsequently hit the button a few times to start the Z-Wave discovery).

I’m going to let this “soak” overnight and try again tomorrow, when perhaps the HA gods will be in a better mood :grinning:

OK, so it’s tomorrow, and things are not looking any better. I was running a Z-Wave repair (experimenting to see if the ST app on Android tells me when it completes, see Cold Reboot), and it is giving errors about “failed to update mesh info” for a couple of my Iris Smart Plugs’ Z-Wave repeaters (maybe more, it’s still running after 30 minutes - yes, minutes).

Correction - the Z-Wave repair took 10 minutes (I checked in the log in the IDE) - the app was lying to me :frowning:

What’s odd is that the Smart Plugs it is complaining about (so far) are ones that have been in service for a few weeks (i.e. they are not the ones I am currently having problems with the Zigbee side).

And what’s frustrating is that I am adding all these Smart Plugs to improve my Zigbee mesh, and it seems to be having a serious effect on my Z-Wave mesh - I’ve got a Z-Wave siren that is now sounding 30 minutes after an event should have triggered it.

Although it’s possible that something is broken “in the cloud” and I am chasing my tail trying to fix this :frowning:

Yes, sorry it’s been so frustrating for you. You may need to contact support and see if they can see anything from their side of the equation. I also wonder a little bit about the reliability of the z-wave Repeater built into these plugs but I do have several other mains z-wave devices so I see these mostly as a bonus if they actually do anything to improve my z-wave mesh. I got them more for the Zigbee part of it.

OK, I think I am over the hump. Both remaining Iris Zigbee switches are now added, along with their Z-Wave repeaters. I had a huge mess of ghost Z-Wave devices (probably resulting from all my attempts yesterday to add Zigbee parts of the remaining two Iris plugs).

Thanks for the encouragement :slight_smile:

Background info (if anyone is interested) …

I checked the log of the Z-Wave repair and 14 of my Z-Wave devices “failed to update mesh info” and “failed to update route”. However, 12 of those devices were ghosts from yesterday (each time one of the two new smart plugs failed to add the Zigbee device, I deleted the corresponding Z-Wave repeater that got discovered, but apparently they were not fully deleted).

I cleaned out the ghosts by creating a Z-Wave device with the same “Device Network ID” as each of the ghosts. A subsequent Z-Wave repair yielded more Iris Z-Wave repeaters as “Failed to update mesh info” and “Failed to update route” (these had not been in the original list of failures from the first repair). I went through several “repair > find more ghost devices > remove them > repair again” iterations and ended up essentially reverting the addition of the Z-Wave repeater in every single Iris plug.

Then in turn I plugged in each Iris plug with the button pushed (i.e. in reset or discover mode) and had the hub re-discover each device’s Z-Wave repeater without it forgetting or re-discovering the Zigbee switch (except of course for the two new devices, where the Zigbee switch was discovered first and then the Z-Wave repeater).

This doesn’t really explain why adding Zigbee devices was not working, but … whatever. Here’s hoping this remains stable :grinning:

1 Like

Now that you’re set up, that is an excellent DTH for the Zwave part of the plug here.


I’ll check it out (so to speak), thanks.

I’m very new and not well versed in this whole smart home thing. I was able to get this plug to show up as zigbee and zwave successfully. I know this is kind of taking away from main thread, but can this plug be set up in google home app for voice control?

Old thread I know, but I can to get this thing to pair on either if my hubs. I hold the button down while plugging it in, then release when the light comes on. The light stays solid for maybe 1 second, then I get 4 or 5 quick flashes and that’s it. ST never finds it. If I press the button 8 times, it picks up the zwave repeater, but that’s useless to me without the switch part working. Any ideas?

You’ll find that you’re not the only one with this problem. See here.

Please excuse my ignorance here, but isn’t the 3210-L a first generation Iris smart plug? I didn’t think first gen Iris Zigbee devices were at all compatible with SmartThings…

Never mind, just googled Iris First Generation smart plug,a nd Iris Second Generation Smart plug, looks like the 3210-L is second generation…

I finally got this to pair with my hub. I had to go into the IDE and delete the custom device handler I had installed for it. Once that was gone, I tried again and it was detected in like 5 seconds.

I had hoped this would work for me, but it has not.

I have a question did you have any already paired to your system? I have thought that perhaps removing the 4 I already have working and starting over with none paired, might be the answer. I am afraid if I do , however, that I won’t be able to get any to pair again.

I have two hubs, one in the house, and one in my garage.

I have one that is paired and working in the house, but the one I was trying to pair and finally got to work was for the garage. Same account, but two hubs. Not sure if that matters or not.

I am assuming that your two hubs are working as separate locations. If they are working as the same location I would love to know how you did it.