Tv not being able to be assigned to a room on smartthings

I need help please , can someone please advise me what to do because i read all the things and done it but no luck.

-i resetted my tv
-uninstalled app and reinstalled
-renamed tv
-logged out of samsung account on tv and phone and signed in again

I tried all this but no matter what it just keeps on going to personal devices and not being able to be assigned to room , im not sure what to do.

You should be able to use the “Advanced Users” section of the new ST Web app - to change the room…

1 Like

If it’s in Personal Devices, it can’t be assigned to a room. You need to add it as a ST device by doing Add Device-> Select by Brand-> Samsung->TV, assuming your TV is a supported model.

So i tried both ways and both doesn’t work. When i go on the site , it doesnt pick up any device at all.

With the other way , i have a samsung 5 series N5300 smart tv which is supported, it shows on the app as being supported too. If i scan and do that process when it picks the tv up it automatically says “it will be directly connected to phone” and below it says “can’t assign to room” thats with only pressing add then selecting device.

Thank you i tried this but still didnt work

What is the specific model number?


That’s what it says behind my tv

Two things. First, don’t see that as a supported model in the app. Second, do you have a ST hub or just the app?

To be fair the device spec does indicate full ST integration but the images on tbe web site are outdated so it could be it used to work before Edge transition or a geographical lock out.

Phone and Tv both on same network 2.4ghz not 5ghz which might work but best to stick to 2.4ghz to begin with or is it hard wired to your Lan ?

If its Lan make sure cable is good and router not blocking anything

I am using the app

It’s wireless , nothing blocking and it is on 2.4ghz
Both on the same network