Help needed ! Trying to reconnect old samsung tv to smartthings

Trying to add my old samsung tv model UN55KU6300FXZA to smartthings app on my android phone the tv is found by Smartthings but goes straight to personal devices and dont allow me to move it or assign any room …wich means im not able to use automations or voice commands…The Tv is not in the supported list but somehow was previouly connected to smartthings and used to work with some basic voice commands and some automations like turn on off tv at certan time and some basic voice commands like turn on off …volume up or down…or change channels…i dont remember how or what i did to make it work before but now doesnt work anymore…i already tried all the troubleshooting tips mentioned here like factory resetting tv…reinstalled smartthings app…restard phone…log out and log back in into samsung account…changed network connections settings on tv etc…etc…nothing seen to work anymore could anyone help me out to get this issue solved ? I’ll greatly appreciated