TTS with Sonos and CoRE not working


(Marc) #1

My Sonos-ST integration works fine with the smartapp from the marketplace. However if I use “Speak text and resume” or “Speak text and Restore” with a CoRE piston, it does not work.

The IDE log doesn’t reveal any errors. Any ideas?


(Bobby) #2

The only idea I have is to tag @ady624


( I hate Mondays) #3

What dth are you using?


(Marc) #4

Built in Sonos one. It used to work in CoRE at one point.


( I hate Mondays) #5

Do they play but not restore?


(Marc) #6

Neither. However if I do "Play and “Restore”, it does raise/lower the volume according to what I set. It just never does the TTS. For “Play and Resume”, nothing seems to happen.


(Marc) #7

@ady624 do you have any advice to resolve this?


( I hate Mondays) #8

Have no clue, mine does play but won’t restore… never really looked into it but I will


(Marc) #9

Ok, thanks. Unfortunately, the built in smartapps in the marketplace don’t allow for the logic I need. When I open my sliding glass door that has a contact sensor, if my side gate is open, it announced on my Sonos outdoor speakers that the side gate is open. Since I let my dog out, I like to know that the side gate is closed.


#10

It’s remarkably inconsistent for me right now. Core was working for awhile, but recently I would say 90% of the time does not. I always assumed it was the Sonos integration’s problem and not Core’s though.


(Marc) #11

My smartapp that I got through the marketplace seems to work consistently though…


(Rod) #12

Thanks for checking into this. I have the same issue with you. Mine actually play the tts notification but it does not resume or restore. When it does, it is very inconsistent. I have tried save state to local variables and restore them, to no avail. It gets very annoyin when I am listening to music and someone opens the door and the music stops.


#13

I think I figured out something that explains a little more. If I have a Sonos speaker that I’ve told to play audio through the Sonos app, then after sending a TTS from ST, it does not resume or restore. If I am playing audio through the Sonos line-in without doing anything in the Sonos app, then it will pause for the TTS and resume playing from the line-in source.

My first thought is something from Sonos giving the speaker audio directions is prohibiting ST from pausing, executing the TTS, then resuming the audio as directed from the Sonos app.


(Daniel Heyl) #14

Any update to this? My Sonos still plays tts (consistently too) but does not resume or restore. Thanks!


(Marc) #15

This is a known issue. Smartthings is currently working on a new LAN Manager which is supposed to improve reliability with Sonos.


(Paul) #16

Just bumping this thread. Is everyone still having issues. I can get TTS to work with the Smarthings Smart App, but not Core. Looks like others have been having this issue for a while. Is it a CORE issue? or a ST issue?


(Tim Snyder) #17

Bumping this as well. Other Smart Apps text-to-speech work with Sonos but CoRE does not. Apparently I am not alone. Am I doing something wrong? I choose “audio notification device” and select my Sonos speaker. I then choose “Speak Text” and enter the text to speak. Yet nothing happens. Simulation Commands Executed:

Executing command: [Downstairs Speaker].playText([Testing Speak, 40]) (28ms)

Nothing happens. Help?


(Bob) #18

I use ‘control music players’.
Then speak text and resume.
Works ok for me.
Here is an example.


(Derek) #19

Just bumping as well. TTS does not work in Core or Webcore. Have tried setting up my piston with Sonos speakers as both audio notification device and media controller as well as using speak text and resume and speak text and restore. No luck. Normal TTS with ST works.


(Bob) #20

That’s a sweeping statement. It does for me.