Trying to use IFTTT, getting "Must select a valid option" errors

ifttt

#1

I’m trying to use a “Switch on” action on IFTTT, but no matter which switch I select, I get “Must select a valid option”:

I’ve disconnected and re-connected SmartThings, and I’m still getting the same error — any ideas?


#2

This problem was reported last month by a number of users, although it seemed to be corrected later. I would definitely report it to support. Here’s the previous discussion:

And here’s the information on contacting support

https://support.smartthings.com/hc/en-us


#3

Same issue here. It’s a different issue than the one quoted by JDRoberts.

I submitted a ticket to the support.

Has anyone been able to fix this?


#4

I’m also having this issue, but with the action “Switch on”. The thing I’m trying to switch on is a GE Smart switch. Anyone have any ideas?


(Adam Penn) #5

I am trying to do the same thing with a GE smart outlet and having the same error. Any update?


#6

I’m having the same issue with trying to set an applet to switch on our switch off the devices.

Anyone have a solution to this? Messaged IFTTT support but they haven’t helped (only received automated responses)


#7

No issues with IFTTT on this end. Just created a test applet for switch on / switch off. Selected various devices (GE Smart Outlet, Simulated Switch, a Bose speaker, light bulbs, etc.). No errors received either selected or saving. Selected devices both as an Action Service and Trigger service.

In IFTTT, goto Search, then select My Apps and select SmartThings (Should show active in Green), select Gear Icon, then Edit connection, and it will have you login to ST again, select your Location and any new devices. See if that fixes things for ya.

Note: DO NOT press Disconnect at bottom on the Edit connection screen or you will lose any applets using SmartThings service.


#8

Thanks for the reply. I’ve done that reconnection 2x before and once more again by your suggestion to be sure and still the same issue reoccurs both with the premade applets and ones that I create myself.

The switches and the STH work fine as my GH/Echo control these flawlessly.


(Jason) #9

I’ve encountered this same issue. I’ve only been a ST user for a couple months now, and the first time I tried to integrate IFTTT I had this problem. I’ve tried updating the connection multiple times, I’ve disconnected ST from my IFTTT account and set it back up again multiple times. Any time I try to turn on an IFTTT applet that uses ST devices, I get an error that my device is not a valid option, regardless of which device I choose. I’ve tried applets that use ST switches, door/window sensors, sirens, lights, door locks, and temp sensors. I’ve tried applets that use ST as both an action and as a trigger. Happens with the standard published applets as well as my own applets. I simply can’t seem to get IFTTT and ST to work together at all, no matter what I do.

I’ve reported the issue to both IFTTT and ST and so far have yet to receive a response from either beyond automated replies.

Any thoughts or ideas?


(Matt) #10

Same problem. All I wanted to do was link a door sensor to IFTTT, and got the same error message. I tried to do it with another IFTTT item and got the same. Not a very good experience for someone new to the ecosystem.


(Adrian) #11

I want to tell Alexa to unlock my door! IFFT should offer a way… but I need help


#12

months later and this issue is still not resolved… what is ST and IFTTT doing??

Anyone have a solution yet?


(Adrian) #13

Cortana is now part of IFFT! I went to set up the lock features for ST device… same error!


#14

I gave up waiting for this to be fixed and started using stringify instead. Much better


(Dan ) #15

I’m having this exact problem. Removed connection, reauthorized, tried various ST switches, tried via Android app and web. Every time “Please select a valid option”. Been happening for the last month.


(David IFTTT) #16

Hi everyone!

Quick update from IFTTT: we’ve deployed a fix for this issue and it should be resolved now. Thanks a lot for your reports and apologies for the long time it took to fix this (it was super tricky to figure out what the problem was!)

Best of luck and please let me know if this issue still persists

David
IFTTT Engineering