Trying to find a rule triggered by a button

I’m seeing a behavior that I can’t account for. I want to delete the behavior but can’t see what is causing it. I have button that turns on a light and sets it to a specific light level and temperature whenever I double click it.

  • In the SmartThings App, the “Double pressed” option has no action assigned. If I assign an action, it starts doing the assigned action but still turns on the light.
  • Under SmartApps, “Smart Lighting” is disabled, but even inside it, there is nothing that would result in this behavior.
  • Under Automations, there is no automation that would cause this behavior. I did delete a number of automations related to the button and the light, probably for the behavior that I’m still seeing.

When I log in to the API system through the web browser, I can see both the button and the light. I can also see the events generated by the button and the light. But I can’t see what causes the button to trigger the light.

The light is connected to SmartThings through Hue (I have Hue Hub too) and both are connected to Alexa. I’ve looked through the other apps and can’t see any connection that accounts for this behavior.

How do I debug what is causing the button to turn on the light?

First rule of home automation: “the model number matters.“ What is the exact brand and model of both the button and the light?

There are some handheld remotes which will exhibit the behavior you describe and there just isn’t anything you can do about it. When you press the button, it always sends the turn on function directly to the light.

There are others which only communicate to the hub, so it depends on the device you were using, as well as the DTH you are using for that device.

Good point - I should have thought of that.

  • The SmartThings Hub is: hub v2, US customer Rev E
  • The button is a “SmartSense Button” as reported by I can’t find a specific version number. The manufacturer is Samjin.
  • The bulb is “LAN Hue Color Temperature” model LTW015

The button I purchased was not tied to the light at all and I’ve programmed it to do different things over the last few months. But this is the first time that when I reprogrammed the button, the old behavior seems “stuck.”

OK, you’re not the only one having new problems with existing rules with that model, but I don’t know what the fix is. :disappointed_relieved: Here’s someone else reporting the same issue:

The best bet for now is to report it to support since that’s a Samsung brand.

Thanks for the suggestion. I submitted it to technical support. A second automation “disappeared” from the button (the one for a long press). The automation still works, but it just doesn’t show up in the app. I also noticed that over the last day or two there seems to be a number of other people posting similar problems related to buttons and automations. So I’m guessing it is an issue with SmartThings and not localized to my own setup.

1 Like

I had a similar problem. What worked for me was deleting the trigger device, which in turn deleted the “ghost” automation. Then I added the device again. Unfortunately that was the only thing that worked for me.

1 Like

Thanks for the suggestion. Technical suggested the same thing. I deleted the button and re-added it. That fixed the problem. What surprised me was how easy it was to delete and re-add. Had I known that would be so quick, I might have tried it first!

Problem Solved. Thanks.

1 Like