Trouble Pairing/Finding D-Link DCS-5222L Camera with V2 HUB

devices
video
integration
hubv2
cameras

(Matt Richling) #1

Purchased the D-Link DCS 5222L a month or so ago since it is compatible with the new ST hub. I’ve been loving the V1 hub and knew I would be switching soon. Set the camera up and was using mydlink app etc with no problems. Received the new V2 hub today and got (almost - haha) everything removed and re-installed and working perfectly. Was surprised how quickly and trouble free it was.

Went to pair the cam and no dice. Sat for good chunk of time and no luck to find it. I assumed that maybe it needed to be a new un-synced product - so did the 8second reset button thing.

Tried to re-pair - nothing.

I have it sitting near the hub, and connected directly to the router.
Thought maybe I have to start the install procedure? I have tried it all. :frowning:

There is NOTHING easy about this. Any ideas or help? I have tried to search on here but no specifics or info since the cameras have been fully supported. Tried the live chat for 3 hours with no response, and created a ticket - but lets be honest here. Figure one of you must have gone through this…

Help?!


(Matt Richling) #2

Started a ticket last night as per @twack suggestion. Appreciate the help Todd. Also thank you for letting me vent! However I am hoping someone else on here can give a suggestion or two. Would like to take advantage of the trial period before it runs out.

Some of you seem to have had similar issues - @vdumas @Jason_Troska @Meriwether_R @anewsom

Any help is appreciated!


(Victor Patrick) #3

I purchased the D-Link camera also and what I found out was there are 2 different models of the camera. The “A” model being the one that has a red power light that never goes green and a “B” model that starts red and then goes green after it is online. From what ST said the “A” model is the one that has not worked, what we are thinking is that the ST Hub does not like the way the camera supports UPDM or whatever that protocol is. D-Link says that it supports it but there is something that the ST hub doesn’t like.

Hopefully they figure it out. I have sent screenshots of the page where it says that it supports the protocol. So we’ll see if it gets fixed.


(Matt Richling) #4

Yes. I have the A - and purchased it specifically since I would be able to use it with ST. Pretty sure I am not able to return it now.


(Matt Richling) #5

@vpatrick1217 how long ago did you find this out?


(Doug) #6

How can you tell the two versions apart before you buy? Is there a model number difference or some other marking on the box? thx


(Victor Patrick) #7

The one that is the “A” version has a red light that will never go green and the “B” version has the light that will go green. I am not sure how to tell in the packaging that is how I got fooled. If it is a big box store have them open it up because you have to have the B version or it will not work.


(Matt Richling) #8

Its on the underside of the box… part of the black and white UPC code area. It is pretty clear when you see it.


(Richard Smart) #9

Hi there,

Did you ever get this resolved?

Im having exact same problem after buying 2 DCS-5222L cameras because it was stated as a supported product. I bought them from ebay & the seller has already said he wont accept them back…


(Matt Richling) #10

At this point there is no work around other than using the correct B vs A model. I know that the Smartthings team is currently working on fixing this.

That being said - the two seconds it would take to add a little disclaimer regarding A vs B would have been the first thing I would assume the team to do. Why it has still not been changed is beyond me.


(Steve) #11

I have both the A and the B version. Neither of them being found.

Updated the firmware on both cameras today and left the app scanning for a good 5 minutes… nothing!

At a loss!


#12

I have two B version cameras and have no trouble finding them using the SmartThings app and V2 hub. Sometimes in the SmartThings app the cameras are unavailable when they should be available, so I occasionally have to delete them from the app and find them again, which solves the problem, I have no idea why. End of the day, the dLink app with cameras works great, which is very good due to the SmartThings hub working infrequently at best. I turn the camera on and off with plug in switches controlled, when I can, by the hub. By the way, when the cameras are working in the SmartThing app, the functionality is so limited I do not use it. I only use the dLink app, lite version at that.


(Bret Hoskins) #13

I was able to get it a Version A working… with making some changes to this old code I found on github

https://github.com/blebson/DCS-5222L/tree/master/devicetypes/blebson

I been able to get streaming to work and some other things… Let me know if you need any assistance.

Good Luck!