Cant connect 2 Dlink cameras - DCS-5222L


(Richard Smart) #1

Hi guys

I have 2 Dlink DCS-5222L cameras I bought as they are listed as supported by Samsung Smartthings

so i go through setup

“connect new device” - have tried both “Setup New Camera” as well as “connect to existing camera” Neither option works. Have also tried using wired/wireless, wiping the camera completely so it has no settings, but nothing works and it doesnt find either camera.

Any ideas process I should try to connect these cameras up to Smartthings?

I can confirm I have had both cameras working using dlink cloud.

Thanks!


#2

I am having the same problem. Hopefully someone can help us out.


(Mark Lint) #3

Same problem here as well. I’ve read in other postings that there are 2 models of the DCS-5222L camera. Seems like the “A” model has issues. Sure hope Smartthings can correct this ASAP since they have listed this as a compatible device!!!


(Gaggles) #4

Hi same here
I have the DCS 5222L B and it works fine on the dlink app (although will not update software) but will not connect using smartthings
shows as active, but as soon as you press play it shows - unknown error 1 there was a problem retrieving the live stream


#5

I am having issues with my DCS-5222LB reconnecting to ST also. It had been working until recently. I tried unplugging the cameras, rebooting the cameras from the DLink website, and the cameras continue to be labeled “UNAVAIL” by ST.

I’ll wait until after tomorrow’s ST Hub v2 firmware update to see if they reconnect. If not, I’ll contact ST support.

UPDATE: no change to my DLink cameras, so I have submitted support ticket #193446.

@twack and @jackchi I see your names in threads for these cameras back in Nov & Dec. Any help for us would be great!


(Pr Prdm) #6

same issue here… smartthings never discovered my dcs-5222l… dies anyone have a dcs5222l working on smartthings?


(Jack Chi) #7

@CDJ @Pr_Prdm @gaggles @Mark_Lint @gingertips @karp13

Let’s look into this issue. What I need from you is your e-mail address that is associated with the account / name of the Hub (Location) and the D-Link Camera name.

Let’s all do something real quick to check. If you log into “My Devices” in the SmartThings IDE -
https://graph.api.smartthings.com/device

Let’s compare SmartThing’s D-Link IP with one scanned by a network scanner.

Fing - Android https://play.google.com/store/apps/details?id=com.overlook.android.fing&hl=en
Fing - iOS https://itunes.apple.com/us/app/fing-network-scanner/id430921107?mt=8

After you post your e-mail, Hub name, Device name, I can pull the logs and see what’s going on here.

Thanks for being patient!

Jack


#8

@jackchi

Jack,
Thanks for your help here and via email on Monday. I was too busy at work yesterday to follow up, so I appreciate finding your post here tonight.

I will get my info to you tonight.

Chris


(Mark Lint) #9

Hi Jack!
The email address associated with my account is marklint@gmail.com. I’ve
never been able to add my DCS-5222L camera to my account so not sure if you
will see any error messages in the log files. If you want to set up some
type of controlled test to see any messages when I try to add this device
to my hub please let me know and I’d be happy to run thru this. Please let
me know what I can do to help you out with debugging this…
Thanks!
Mark…


(Jack Chi) #10

I believe CDJ is also having issues discovering the D-Link Camera. For those having issues discovering, see if you can use a network scanner to find it.

Fing - Android https://play.google.com/store/apps/details?id=com.overlook.android.fing&hl=en
Fing - iOS https://itunes.apple.com/us/app/fing-network-scanner/id430921107?mt=8

For those who have successfully added the camera but the “status:unavailable”, post your e-mail & Hub ID here for me to take a deeper dive.
Jack


(Gaggles) #11

Hi Jack,
how strange, received your message, but before doing anything the camera became active on smarthings. absolutely no intervention from my end. would not work for over 10 days since purchase and installing, now fine.
regards

gary


(Jack Chi) #12

Hi Mark,

Sorry for the delay. It seems like you removed the D-Link DCS-5222L Camera. Did you end up returning it or something? I no longer see it under ‘My Devices’ in graph.api.smartthings.com

Jack


(Jack Chi) #13

Mark,

I downloaded your Hub logs and I see at least 1 thing that went wrong with the Hub updates.
If you haven’t restarted your Hub since 02/29/2016, please do so and re-install the camera.

Jack


(nathan) #15

I’m having the same issue with trying to install my DCS 5222L to my
SmartThings Hub. The camera works fine in the dlink app and I’ve
reinstalled it two times. I ran Fing and I’m able to see the device with
no issues. Has anyone found a solution for this yet?


(Richard Smart) #16

hi all
is there any update to this? I purchase 2 cameras from ebay because they were showing on the supported list, but as this posting states, apparantly “A” models dont work? I feel really cheated and I cant return these back…


(Stephen) #17

I am also having this issue. I did the live chat with Samsung and the representative told me it was a known issue and that Smartthings support of cameras was still in “beta”. Apparently, uninstalling the app reseting the device, camera etc will eventually work. I was told some people have to do this 7-8 times. Given that it takes around 45 minutes to go through the whole process, it therefore can take 6 hours or so to install each supported camera. What a joke!!! This is completely unworkable. Does anyone have a work around on this? I only bought the DCS-5222L because it was supported. I am told that even the Samsung camera suffers from the same issue. I downloaded the Fling app but am unsure what to do with this information.


(Richard Smart) #18

Wonder if anyone’s actually managed to do this with a model A version. Hopefully someone in the community can comment on whether they’ve got it working or not


(Richard Smart) #19

Any update to this? Thanks


(Mark Lint) #20

Any updates to this??? Still not able to connect my DCS-5222L Mod A camera…


(Richard Smart) #21

Would like to know the same. Bought 2 of these cameras would be great if we can integrate with Smartthings. Bought them because they were on the confirmed devices list. Still not able to use for what I bought them for. (Sad face)