Trouble pairing Enbrighton motion switch

I have several other GE motion switches in the house that work fine but this is the first one with the “Enbrighton” branding. I can’t get the sucker to pair. All onboard controls seem to work fine but when trying to pair with ST, ST just searches indefinitely. Do you guys think I have a dud or am I missing something? Thank you in advance!

Model Number?

26931? I guess

How far away is it from your hub? That last couple of Z-Wave+ switches I added (not GE) I had to bring my hub close to the switch to get it to pair.

You could also try a general exclusion of the device to make sure that it is ready for pairing before trying to drag the hub around the house. :thinking:

It’s less than 10 feet away on the other side of a wall. This switch is probably right in the middle of the hub and another z wave devices further down the hall. I’ll try bringing it closer. What do you mean by a general exclusion? I’ve factory reset the switch a few times.

Try excluding and then pairing

1 Like

I would think that your are plenty close enough to the hub. The switched I had issues with were about 30ft and several walls away.

With a general exclusion you put your hub into genaral exclusion mode from the Z-Wave utilities menu and then power cycle the device you want to exclude. Doing this clears any previous pairing that the switch may have had.

I would think that the factory reset should accomplish the same thing as a general exclusion.

To me it sounds like you may have bad switch, though I have had some devices that seemed to take an exceptionally long time to pair. Long past the “it’s taking a long time” message displayed by the app. You could try and let it set in pairing mode for a bit and keep power cycling the switch.

I have never paired that particular switch so hopefully someone that has can add to the the discussion and advise if there are any subtleties to pairing this particular device.

I will give this a try when I get home. This sounds like hopefully it could be the right direction. I’ve already had to send one of these back because I’m dumb and this one is installed so I don’t want to send this one back too!

I would also follow the directions in the link provided by Jimmy and do the general exclusion. I won’t hurt. Just be sure you don’t power cycle anything else while in general exclusion mode or that device will be removed from your hub too.

Good luck!

Well I tried the general exclusion and right away the app told me “a device has been removed.” Then I moved the hub to within inches of the switch. Same thing. I had to run out for a bit but I’ll try again when I get home for longer and we’ll see.

Do you happen to be using a custom device handler? If so, re-publish the handler, exclude the device again and then pair it.

This worked! Strange requirement but it worked right away. Thank you!

There is a bug with custom DTH going stale. The device will pair, but it never shows in the app or IDE. Really annoying.

Got it. Now I know!

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.