Trouble adding Hue to ST


(Morgan) #1

I’m having trouble adding my Philips hue setup to ST. It was part of my v1 hub, and now I’m not able to add it to my v2 hub. Is there something else to do besides go into Marketplace and add the bulbs? I’ve tried it with and without hitting the button on the Philips Hue bridge.

I’m trying to add them through the Hue integration, and not directly to the ST hub.


(jkp) #2

Do they still show in My Devices in IDE?


(Morgan) #3

Nope… nothing. They had been working perfectly with my v1 Hub.


(jkp) #4

static IP assigned to the hue bridge? If yes, perhaps give it a different address?


#5

Is your Hue Bridge Ethernet cable connected to the same router as your ST hub?


(Morgan) #6

Yep, same router, they are on the same sub net on the network, nothing crazy there.
I’ve had a static IP assigned to the hue bridge, and one each for the ST hubs, @jkp why give it a different IP, that seems like it would have less of a chance of connecting.


(jkp) #7

OK, my final thought… restart your router.


#8

When you goto Things and select Add New Device, it should automatically try to discover the Hue Bridge and it will discover this first, not the bulbs.


(jkp) #9

@WB70 are you able to click on objects with your arthritic fingers?? :grinning:


#10

Only on Sundays :grin:


(Morgan) #11

Yeah, it should but it isn’t at all. Nothing, i’ve changed the IP just to try it and no luck still.

@jkp Yeah, i’ve restarted my router several times with no luck.


#12

If you login to IDE and cruise through your list of devices, do you see anything Hue related? An incomplete device or anything?


(Morgan) #13

Nope, nothing in my device list at all. It is like it can’t find the Hue bridge, but they are on the same network and both accessible. It has discover Sonos and Wemo devices on the same network, so I just don’t know why it can’t find anything.


#14

I’m wondering if there are still remnants of it when it was on V1 hub.

Goto Locations / Installed SmartApps. Scroll down to Other. Do you have any Hue related SmartApps installed, whether you are using them or not?


(jkp) #15

I was about to ask if he set up his new v2 hub on the same location as his old v1 hub


#16

Here’s one more thing to take a look at.

Under Locations / Installed SmartApps / Other

You should see Super LAN Connect

Select that (Do this on a laptop or desktop) and you will see a large section “Devices”. Copy everything out of there and paste into Notepad.

Turn Word Wrap off

Do a search on Hue. Does it list what appears to be your bridge? If that’s the case, I’m going to guess that this is being held onto from when you were on v1.

This will contain a listing of ALL Devices in your environment that are using a LAN based Device Handler (ie: Bose / Belkin - Wemo, etc.).


(Morgan) #17

No, I don’t have any references to Hue in either my new location or my old one. I uninstalled all devices before I did the new location on the new hub. Good idea though.


(Morgan) #18

I went through everything again, with a reboot of the hub, and then i rebooted the Hue bridge while it was searching for devices and after about 5 minutes they finally showed up. So it worked. Support gave me the steps, so that was great.